Scrolling icons doesn't work? Change the window size!

Bug #1637723 reported by Bill_MI on 2016-10-29
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Ubuntu MATE
Undecided
Unassigned

Bug Description

This affects 16.10 applications like Control Center and Caja in Icon or Compact view. It seems to be a general problem with viewing icons with a scroll bar present so not easily classified.

1) Open Control Center.
2) Attempt to scroll to the bottom - it won't go there!

If this doesn't create the bug it may be theme dependent.

I find Control Center happens to open at a bad width. Changing the width can make the problem come and go in a very particular way. Bad widths are just before switching to a larger number of columns.

For example, Control Center opens with 2 columns but is at a width just short of 3 columns - a bad place to be. Increase width to 3 columns and the problem goes away. I didn't measure the bad width but it's a band of 10 pixels or so.

Caja in Icon view behaves much like Control Center but Caja in Compact view has a sensitivity to rows and vertical size. Caja also looses the ability to rename files while scrolling is broken.

This bug has been discussed and first reported by Mountain_Man:
https://ubuntu-mate.community/t/mate-control-center-cant-scroll-all-the-way-down-in-16-10/9730
https://ubuntu-mate.community/t/upgraded-from-16-04-to-16-10-file-manager-caja-cannot-scroll-to-bottom-cannot-rename-no-icon-highlight/9805

Bill_MI (bill-mi) on 2016-10-29
description: updated
Bill_MI (bill-mi) on 2016-10-29
tags: added: icons
Steffen Günther (stguenth) wrote :

Same here (ubuntu-mate 16.10):
Caja not scrolling to the bottom with icon-view.

Martin Wimpress (flexiondotorg) wrote :

This is fixed in mate-control-center 1.18 that will feature in Ubuntu MATE 17.04 and is available for testing in the daily iso images.

Changed in ubuntu-mate:
status: New → Fix Released

mate-control-center appears fixed, Caja is not.
Running 17.04 with Caja 1.18.1-0ubuntu1,

Fixed in Caja 1.18.2... released 20 days ago.
Can we get a new release to fix this 6+ month old bug?

Douglas Silva (o-alquimista) wrote :

Affecting Ubuntu MATE 17.04. Resizing or maximizing window is a workaround.

Bill_MI (bill-mi) on 2017-09-13
Changed in ubuntu-mate:
status: Fix Released → Confirmed
MLapin (mlapin) wrote :

There seems to be a regression since this is affecting me on 18.04. It's not theme dependent, I tried Ambiant-Mate, Arc, Numix, Menta.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers