at-spi-registryd.desktop not responding on shutdown

Bug #1605224 reported by bedfojo on 2016-07-21
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
at-spi
Confirmed
Medium
ubuntu-mate
Undecided
Unassigned
at-spi (Ubuntu)
Undecided
Unassigned

Bug Description

This issue is recurring again on Ubuntu MATE 16.04. It happens intermittently on two different machines, both fully updated. The assistive technologies are not loaded on startup (diabled in "Startup Applications" but it still occurs.

There was an old bug from 2010 which has now expired as has the related upstream bug.
https://bugs.launchpad.net/ubuntu/+source/at-spi/+bug/477978

There are workarounds but these are hacks:
https://ubuntu-mate.community/t/issue-shutting-down-16-04-at-spi-registryd-desktop/5435
https://ubuntuforums.org/showthread.php?t=2321728
https://askubuntu.com/questions/792638/ubuntu-mate-16-04-restart-shut-down-halts-due-to-a-not-responding-program-how-t

A proper fix would be welcome.

I note that all the recent reports linked to above relate to Ubuntu MATE only.

Changed in at-spi:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in at-spi (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1605224

tags: added: iso-testing

Still happening after upgrade to 16.10.

Damodar Das (damodaranudas) wrote :

Ubuntu MATE 16.04 64bits, the same bug here, any solution?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.