MATE Panel (inc. Menu) displayed at the top of the screen when using the Redmond panel layout and Compiz

Bug #1579421 reported by Curt on 2016-05-07
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
mate-menu (Ubuntu)
Medium
Unassigned
mate-panel (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]

After I log in, the panel at the bottom of the screen draws in but not correctly. If you try to click on the advanced menu or anything at the bottom of the screen, nothing happens. But if you click at the top of the screen, it will render it as if the menu is at the top. If you click a couple of times, it will fix itself.

[Test case]

1. Login
2. Click in the menu Button
3. Expect the menu opens in correct position

[Regression potential]

Windows are positioned wrongly.

Related branches

Curt (x12magnycours) wrote :
Curt (x12magnycours) wrote :

This is what it should look like.

Curt (x12magnycours) wrote :

After further testing, I have concluded that this only happens with compiz enabled. When I switch to Marco everything works as it should.

description: updated
Martin Wimpress (flexiondotorg) wrote :

What version of Ubuntu MATE?

Changed in ubuntu-mate:
status: New → Incomplete
Curt (x12magnycours) wrote :

This is 16.04.

Curt (x12magnycours) wrote :

Also, I am using an Nvidia graphics card and I tried two official nvidia drivers and the Nouveau drivers and it happens with all of them.

Martin Wimpress (flexiondotorg) wrote :

Bother. I thought we'd fixed that.

Changed in ubuntu-mate:
status: Incomplete → New

I have the same problem and have had for some time. I have a single panel at the bottom of the screen. The problem arises when using compiz.

When booting, the panel shows (with the wrong theme) at the bottom then at the top and then at the bottom again. Intermittently however even though the panel is shown at the bottom of the screen, it is impossible to click on it - as described above what responds is the space at the top where the panel was temporarily. Usually after a while (or after opening a window and maximising and minimising it) the system starts to work correctly.

I am on Ubuntu MATE 16.04, compiz. AMD GPU using the open source drivers.

I assume it is a race problem with the panel starting too soon before compiz is fully loaded.

MATE 1.14.1 I should add.

Changed in ubuntu-mate:
status: New → Triaged
Changed in mate-menu (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
summary: - Redmond panel layout+Advanced MATE menu is not rendering correctly on
- boot up
+ MATE Menu displayed at the top of the screen when using the Redmond
+ panel layout and Compiz

Indeed, I can confirm that this is a problem with compiz. On two different machines (AMD and Nvidia graphics) the panel flipping happens only with compiz.

Could I also add that this is not only an issue with mate-menu. The same problem occurs for all items on the panel (launchers, calendar, indicators, window list etc).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

Still happening after upgrade to 16.10.

summary: - MATE Menu displayed at the top of the screen when using the Redmond
- panel layout and Compiz
+ MATE Panel (inc. Menu) displayed at the top of the screen when using the
+ Redmond panel layout and Compiz

This was apparently equally a problem in Linux Mint MATE.

For a discussion and workaround see:
https://forums.linuxmint.com/viewtopic.php?t=169308
and
https://ubuntu-mate.community/t/bottom-panel-problems-with-compiz-ubuntu-mate-16-04-solved/6091/5

Here it is suggested that it was solved in Linux Mint 17.1 (without saying how) - could the fix be copied to Ubuntu MATE:
https://github.com/mate-desktop/mate-panel/issues/249

drwt (6lobe) wrote :

I am also experiencing this in 16.10.

Dont the Mint guys (Clem) contribute upstream? Apparently not.

If they could share the fix that'd be great.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mate-panel (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.13.1+17.10.20170427-0ubuntu1

---------------
compiz (1:0.9.13.1+17.10.20170427-0ubuntu1) artful; urgency=medium

  [ Alberts Muktupāvels ]
  * Ensure that surfaces used by metacity theme have device scale set to
    1 (LP: #1530277). (LP: #1530277)
  * gtk-window-decorator: require libmetacity 3.22.0 or newer.
  * Fix initial serverFrame position. (LP: #1390157, #1579421)
  * Fix move rectangle size.
  * gtk-window-decorator: scale window decorations on HiDPI (LP:
    #1530277)

  [ Colomban Wendling ]
  * Restore the ColorChooser plugin by porting it to new OpenGL plugin
    API.

  [ Marco Trevisan (Treviño) ]
  * debian/65compiz_profile-on-session: don't export
    COMPIZ_CONFIG_PROFILE in unity

  [ Martin Wimpress ]
  * Mate: don't use the workaround plugin (LP: #1611797)

  [ ksamak ]
  * obs: added default o/b/s spawn values for new windows
  * debian: added pacakging for colorfilter plugin

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 27 Apr 2017 06:41:27 +0000

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released

Great to see the fix, thanks. Any chance of a backport to Zesty?

Changed in mate-menu (Ubuntu):
status: Triaged → Invalid
Changed in mate-panel (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-mate:
status: Triaged → Invalid
Vlad Orlov (monsta) on 2017-06-19
tags: added: xenial yakkety zesty
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.