Accessibility indicator is missing from ubiquity-dm at the "Try Ubuntu" dialog

Bug #1546317 reported by Laszlo Papp on 2016-02-16
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-orca
Invalid
Undecided
Unassigned
ubuntu-mate
High
Unassigned
a11y-profile-manager (Ubuntu)
Undecided
Luke Yelavich
casper (Ubuntu)
Undecided
Luke Yelavich
ubiquity (Ubuntu)
Undecided
Luke Yelavich
ubuntu-gnome-meta (Ubuntu)
Undecided
Luke Yelavich
ubuntu-mate-meta (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Steps to reproduce:
1. Boot from a media containing the 15.10 32-bit image. Let it just boot, do not select anything.
2. After the bongo drum sound, select your language and click "Try Ubuntu".
3. After the desktop has been loaded, start Orca screen reader with the dedicated Alt+Super+s combination.
Expected: the screen reader comes up talking
Actual: the system remains silent.
4. Try starting Orca from a terminal (Ctrl-Alt-t) and also from the Run dialog (Alt+F2).
Results are the same as for point 3.

Related branches

If you don't mind, try testing it with 16.04 alpha 2 release (32-bit) and 64-bit if possible.

summary: - Orca cannot be started from the desktop that comes up after selecting
- the "Try Ubuntu" option on a live image
+ MATE 15.10 32-bit: Orca cannot be started from the desktop that comes up
+ after selecting the "Try Ubuntu" option on a live image
Laszlo Papp (papp-laszlo3) wrote :

16.04 alpha 2 32-bit image behaves exactly the same way. Just for preciseness I sum it up:
1. After booting and the bongo drum sound press Alt+Super+s to start Orca - result: no speech
2. Fire up a terminal (Ctrl+Alt+t) and start Orca manually - result: Orca comes up talking. Now the language selector becomes screen reader accessible, however you must press Alt-tab to focus the selector (the same happened with 15.10). This could be logical, but I found no way to make the terminal go away (typing exit or pressing Alt+f4 were in vain), theAlt+Tab is still needed to focus the selector.
So far this is the original Bug #1545516. Now comes this bug:
3. Now with speech feedback select your language and click "Try Ubuntu". Result:
Orca stops speaking. Restarting it with Alt+Super+s or via the Terminal or even the Run Dialog doesn't succeed. The system remains silent, but it doesn't freeze, it's possible to shut it down: power switch - bang sound - Enter key - shutdown.
4. However if you click "Install Ubuntu" instead, the installer comes up talking. It's possible to complete the first two screens with speech feedback, and it'smost probably very possible to get through the entire install process with speech, but I didn't want to do that.
5. Interestingly if you quit the install program prematurely (which I did as I was just testing it a bit) the same happens as in point 3. and you are stuck with a silent desktop and the only option is to shut it down.
I haven't tested with the 64-bit image, because I don't have access to such hardware.

gravy45 (gravy45) wrote :

I see now, Orca doesn't start functioning until after "Try Ubuntu", on both 32-bit and 64-bit editions of Ubuntu MATE.

The Alt-tab sequence sounds correct. To make the terminal go away, it needs focus and then Alt-F4 should close it.

Changed in ubuntu-mate:
status: New → Confirmed
gravy45 (gravy45) wrote :

The central issue as I see it is that speech cannot be enabled normally until after "Try Ubuntu" is selected. I would expect it to be available on the very first screen, however I don't know if it was designed this way, or is an unintended consequence with the introduction of the MATE welcome screen, or is simply a bug.

The temporary workaround is small at best:
It can be started with the terminal prior to "Try Ubuntu" but then when the user selects "Try Ubuntu" it shuts off and will not come back on. Selecting "Install Ubuntu" will allow speech to turn back on but this is not a workable solution for someone just trying the product out.

Any other findings related to Orca, and unrelated to starting it up at or around "Try Ubuntu" should be separated.

summary: - MATE 15.10 32-bit: Orca cannot be started from the desktop that comes up
- after selecting the "Try Ubuntu" option on a live image
+ MATE 15.10, 16.04 32/64-bit: Orca cannot be started from the desktop
+ that comes up after selecting the "Try Ubuntu" option on a live image

Orca availability from the bongo drum sound onwards seems to be the intended Ubuntu design principle for live images according to this citation from the Ubuntu Accessibility Wiki: "When you boot the live CD, you should hear a bongo drum sound. At this point, you can go ahead and enable Orca. Once again, the keyboard shortcut Alt + Super + S is used to enable orca. Orca should start speaking, and from this point you can select your language, and either boot into a live Ubuntu desktop by selecting the "Try Ubuntu" push button, or you can elect to install Ubuntu by selecting the "Install Ubuntu" push button."

Martin Wimpress (flexiondotorg) wrote :

The key bindings for enabling the screen reader in Ubuntu MATE are Alt+Super+s

Can you confirm that Alt+Super+s works for enabling Orca please?

Changed in ubuntu-mate:
status: Confirmed → Incomplete
summary: - MATE 15.10, 16.04 32/64-bit: Orca cannot be started from the desktop
- that comes up after selecting the "Try Ubuntu" option on a live image
+ Orca cannot be started from the desktop that comes up after selecting
+ the "Try Ubuntu" option on a live image

On the live image you mean? No, Alt+Super+s never activates Orca on a live Ubuntu Mate image, neither on 15.10, nor on 16.04 alpha 2. I've detailed Ubuntu Mate's reaction in this respect above with steps to reproduce and it was confirmed.
On an installed image? I don't know, perhaps, I haven't tried that, because right now I am not willing to install Ubuntu Mate on my system in this accessibility state, as I am totally blind.

gravy45 (gravy45) wrote :

Orca seems fine on an installed image, other than the other reported issue about speech not working with escalated privileges on certain programs. The alt+super+s key combination works on an installed image other than this.

For the live edition, one has to click on "Try Ubuntu" first and then the alt+super+s key combination works. If I could not see, I believe I would be perplexed at having to first find the "Try Ubuntu" button to enable speech. I suppose one's other senses are heightened to some extent to compensate but I found the installer difficult to use per the 15.04/15.10 qa instructions, and I remember reporting that (not here but in the qa tracker).

Martin Wimpress (flexiondotorg) wrote :

I've just tested and noticed that the Accessibility indicator is no longer being displayed in the Ubiquity display manager. This also affects Ubuntu Unity. The indicator provide F-keys to enable/disable the screen reader at the "Thy Ubuntu" menu.

Changed in ubuntu-mate:
status: Incomplete → Confirmed
summary: - Orca cannot be started from the desktop that comes up after selecting
- the "Try Ubuntu" option on a live image
+ Accessibility indicator is missing from ubiquity-dm at the "Try Ubuntu"
+ dialog
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Colin Watson (cjwatson) on 2016-03-17
affects: ubiquity → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Changed in ubuntu-mate:
importance: Undecided → High
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1546317

tags: added: iso-testing
Luke Yelavich (themuso) wrote :

The accessibility indicator is no longer showing because I have been revamping the accessibility profile system this cycle, and unfortunately ran out of time to properly implement support for flavours other than Ubuntu Unity.

It is worth noting however that the accessibility indicator only provided real use in Ubuntu proper anyway, as the profile settings were entirely geared around Ubuntu only. They likely would have mostly worked in the GNOME flavour, but not very likely to work in mate at all, since mate has different GSettings schemas to GNOME and Unity. So for example, if you were to try and enable a profile in Ubuntu Mate 15.10, you wouldn't see any real change, other than maybe Orca loading, because all the settings are GNOME and unity related. In addition, if you were to dig into the installer logs, you would notice errors when attempting to select a profile, because GSettings schemas required for profile functionality in GNOME/Unity are not likely present in the mate flavour.

This doesn't excuse my lack of providing support for Mate. As I said, it was planned, and due to some other work that was required for this to go ahead taking longer than I hoped, I did not get around to adding non-Unity support in time.

If enough people want this, and enough of us could put a case forward to get an FFE approved, I could add support for Non-Unity flavours, and we could add some Mate specific settings to the profiles, and if you want, add extra profiles specific to Mate, since the advantage of the new profile system is adding custom profiles, whereas the previous sytem was all hard-coded in a script that lived in the casper package.

The accessibility indicator is missing from Ubuntu Unity too. I've been testing both.

Yes, I am aware of this, and it will be addressed post beta. The needed package for it only recently made it into main, and ubuntu-meta needs to be updated for it.

I expect this is the same story for Ubuntu MATE? Just a matter of seeding the right packages in? Does this require a change in ubiquity at all?

Changed in ubiquity (Ubuntu):
status: New → Incomplete
Luke Yelavich (themuso) wrote :

As I said above, even if the relevant packages were present on the mate images, the profiles wouldn't apply, because the profiles only have Ubuntu/Unity settings in them at this time. Before a profile is applied, it is validated. The validation process makes sure the gsettings schema found in the profile settings file is present on the system. If the gsettings schema is not found, the profile cannot be validated, and will not be applied.

So for example, if I were to add mate specific settings to the profiles, they wouldn't apply in Ubuntu/Unity because the mate gsettings schemas are not present, and therefore cannot be found, and the profile will not be applied.

Luke Yelavich (themuso) wrote :

Ok, with some further thought, I have an idea to resolve this without having to write any more code.

1. I create profiles with Mate and GNOME specific settings.
2. I package them separately, similarly to how the unity profiles are packaged now.
3. I make sure all the profiles are co-installable, just in case someone thinks that having all installed is a good idea.
4. Each flavour seeds its own profile package.

Its not as tidy has having desktop specific settings in each profile, but its something that can be worked on next cycle, and we can do things properly then.

Ubiquity wise, I can submit a small change to handle the flavour specific profile bits where required, and all the flavours would need to do is update their seeds as above.

I'll sart working on the profiles today, and should have everything ready by either EOD today or tomorrow.

I hope this is satisfactory for all concerned.

Luke

Luke, that sounds fab. I'll definitely update the seeds to add this new a11y indicator :-)

Luke Yelavich (themuso) wrote :

Is mate running an indicator applet in its panel? If so, can it work with GTK3 based indicators?

Luke

Luke Yelavich (themuso) on 2016-04-05
Changed in gnome-orca:
status: New → Invalid
Changed in ubiquity (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: Incomplete → In Progress
Luke Yelavich (themuso) wrote :

 affects ubuntu/a11y-profile-manager
 status inprogress
 assignee themuso

 affects ubuntu/ubuntu-mate-meta
 status inprogress
 assignee themuso

 affects ubuntu/ubuntu-gnome-meta
 status inprogress
 assignee themuso

Luke Yelavich (themuso) wrote :

Re the indicator question, never mind, I've got my answer.

Luke Yelavich (themuso) wrote :

 affects ubuntu/casper
 assignee themuso
 status inprogress

Luke Yelavich (themuso) wrote :

Ok, almost all implemented here, testing as I go.

I have a bit to do in casper too to make this all work, hense casper being added as a task. As for ubiquity, the changes work, however seems something is running in ubiquity on the mate live image that prevents Orca from being launched with the shortcut key super + alt + S. The same changed code works properly in the Ubuntu live environment for Unity, so its either something running from mate that is intercepting the keystroke, or for some reason, the super key is being interpreted differently in ubiquity, why I don't know, but I did note that changing a shortcut key in Mate's keyboard shortcuts shows the super key as Mod 4. Is there a remote chance that ubiquity running with the mate settings daemon etc sees super as mod4, even though mate uses gtk 2 and ubiquity uses GTK 3?

I should note that this applies when booting directly into the installer, not loading the desktop first and then running the installer.

Anyway, will debug further tomorrow.

Luke Yelavich (themuso) wrote :

 affects ubuntu/ubiquity
 status fixcommitted

Ok, I managed to work out the problem and a solution for the shortcut keys. Ubiquity is the first part. I now have to finalize the profiles for mate/GNOME, and upload a new a11y-profile-manager. Once thats done, the seeds can be updated.

Will post back when a11y-profile-manager is done, likely not today though, gotta head out early.

Changed in ubiquity (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.54

---------------
ubiquity (2.21.54) xenial; urgency=medium

  * ubiquity/frontends/gtk_ui.py:
    - Extend keyboard shortcut code for accessibility profiles to work with
      flavours other than Ubuntu/Unity (LP: #1546317)
    - Disable the screen reader activation keyboard shortcut in Unity, GNOME,
      and Mate flavours. In almost all cases, the settings daemon catches the
      keystroke before Ubiquity gets it, and was preventing the blindness
      profile from being properly activated
  * Drop unused profile set method that was missed previously
  * Automatic update of included source packages: console-setup
    1.108ubuntu13, hw-detect 1.117ubuntu1, netcfg 1.135ubuntu2,
    choose-mirror 2.65ubuntu6.

 -- Luke Yelavich <email address hidden> Wed, 06 Apr 2016 14:07:33 +1000

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released

Luke, thank you for working on this I really appreciate it.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package a11y-profile-manager - 0.1.10-0ubuntu1

---------------
a11y-profile-manager (0.1.10-0ubuntu1) xenial; urgency=medium

  * New bugfix release:
    - Sleep for 0.25 seconds when applying profile settings in the indicator
      to avoid a race condition and to make sure gnome-session notices the
      changing signals for starting orca/onboard.
    - Add accessibility profiles for GNOME and Mate. (LP: #1546317)
  * Split out unity profiles into new package
  * Add packages for mate and GNOME profiles, the various flavours will
    now need to have their respective profile packages seeded (LP: #1546317)

 -- Luke Yelavich <email address hidden> Wed, 06 Apr 2016 15:39:00 +1000

Changed in a11y-profile-manager (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-meta - 0.54

---------------
ubuntu-gnome-meta (0.54) xenial; urgency=medium

  * Refreshed dependencies
  * Added a11y-profile-manager to desktop-recommends
  * Added gnome-accessibility-profiles to desktop-recommends (LP: #1546317)

 -- Luke Yelavich <email address hidden> Thu, 07 Apr 2016 07:11:39 +1000

Changed in ubuntu-gnome-meta (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-mate-meta - 1.152

---------------
ubuntu-mate-meta (1.152) xenial; urgency=medium

  * Refreshed dependencies
  * Added a11y-profile-manager to live
  * Added a11y-profile-manager-indicator to cloudtop, core, desktop
  * Added mate-accessibility-profiles to cloudtop, core, desktop
    (LP: #1546317)

 -- Luke Yelavich <email address hidden> Thu, 07 Apr 2016 06:36:24 +1000

Changed in ubuntu-mate-meta (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-mate:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.372

---------------
casper (1.372) xenial; urgency=medium

  * ubiquity-hooks/30accessibility:
    - Extend profile code to support profiles for Mate and GNOME flavours
      (LP: #1546317)
    - Add code to support lightdm-gtk-greeter used by Ubuntu Mate
  * scripts/casper-bottom/30accessibility:
    - Allow the screen reader shortcut to load the blindness profile in
      Mate/GNOME as well

 -- Luke Yelavich <email address hidden> Fri, 08 Apr 2016 12:25:00 +1000

Changed in casper (Ubuntu):
status: In Progress → Fix Released
Tuukka Ojala (tuukka-ojala) wrote :

I'm still seeing this on both the 16.4 release as well as the 2016-05-28 Yakkety build. Either I am missing something or this is a separate bug.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers