mate-terminal.wrapper fails to run post-install ecryptfs-unwrap-passphrase script

Bug #1445198 reported by costales on 2015-04-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Medium
Unassigned

Bug Description

Hi!

Steps:
1. Install Ubuntu MATE 14.04.2 or 15.04.
2. Choose into the installation: Encrypt my home
3. Restart and login into the installed system
4. In the dialog (auto launched) choose "Run this action", because you need to set the password.
5. BUG: The shell script needs to close the apostrophe.

Thanks in advance!

costales (costales) wrote :
gravy45 (gravy45) wrote :
Changed in ubuntu-mate:
status: New → Confirmed
costales (costales) wrote :

I confirm same bug in 15.04 beta2 i386

description: updated
gravy45 (gravy45) wrote :

Same in both amd64 and i386 4/17/15.1 release candidate/final testing.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1445198

tags: added: iso-testing
tags: added: rls-v-incoming
Martin Wimpress (flexiondotorg) wrote :

This is the error:

Failed to execute child process "sh -c 'ecryptfs-unwrap-passphrase $HOME/.ecryptfs/wrapped-passphrase 2>/dev/null && echo [Enter] && head -n1 && touch $HOME/.ecryptfs/.wrapped-passphrase.recorded '" (No such file or directory)

no longer affects: ecryptfs-utils
Changed in ubuntu-mate:
importance: Undecided → Medium
Martin Wimpress (flexiondotorg) wrote :

This issue manifests because mate-terminal.wrapper doesn't support double quoted strings.

Attached is a debdiff that replaces mate-terminal.wrapper with one adapted from gnome-terminal.wrapper. This patch has been submitted upstream for inclusion in the next major release of mate-terminal.

summary: - Failed script for encrypt home after installation
+ mate-terminal.wrapper fails to run post-install ecryptfs-unwrap-
+ passphrase script
Changed in ubuntu-mate:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers