After booting to lightdm-gtk-greeter, get a white screen until I click a mouse button

Bug #1426664 reported by Simon Redmond on 2015-02-28
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
LightDM GTK+ Greeter
Undecided
Unassigned
Ubuntu MATE
Undecided
Unassigned
lightdm-gtk-greeter (Ubuntu)
Undecided
Unassigned

Bug Description

Boot laptop, when the boot process finishes I get a white screen until I hit a mouse button, after that the normal login screen appears and I can login as normal.

Related branches

Martin Wimpress (flexiondotorg) wrote :

WHat version of Ubuntu MATE?

Changed in ubuntu-mate:
status: New → Incomplete
Simon Redmond (simon-sibass) wrote :

sorry... its

Ubuntu 14.04.2 LTS

Simon Redmond (simon-sibass) wrote :

see the same white screen if I log out of a desktop session
have to hit the mouse button to see the login prompt

Ragnar (artenp) wrote :

Also having the problem, in 64-bit 15.04 Beta 1. Haven't tried logging out though.

summary: - after booting to login page, get a white screen until i hit a mouse
- button
+ 14.04.2 LTS after booting to login page, get a white screen until i hit
+ a mouse button

I haven't been able to reproduce this on Ubuntu MATE, but I just updated my Arch Linux box and got lightdm-gtk-greeter 2.0.0 and experienced the same "white" screen. Clicking anywhere made the screen repaint.

Changed in ubuntu-mate:
status: Incomplete → Confirmed
Martin Wimpress (flexiondotorg) wrote :

Bugs and wiki from Arch Linux.

  * https://bugs.archlinux.org/task/43999
  * https://wiki.archlinux.org/index.php/LightDM#White_screen_after_upgrading_the_GTK_greeter_to_2.0.0

Question, does everyone use multiple monitors who has experienced this issue? I do.

Martin Wimpress (flexiondotorg) wrote :

The 2.0.0 greeter may display only a white screen with specific configurations. Clicking the white screen may get rid of it. A fix is pending for the next release, in the meantime you can set active-monitor=0 (or the appropriate number) in /etc/lightdm/lightdm-gtk-greeter.conf.

Changed in lightdm-gtk-greeter (Ubuntu):
status: New → Confirmed
summary: - 14.04.2 LTS after booting to login page, get a white screen until i hit
- a mouse button
+ After booting to lightdm-gtk-greeter, get a white screen until I click a
+ mouse button
Martin Wimpress (flexiondotorg) wrote :

Reproduced on my dual screen workstation running Ubuntu MATE 15.04.

Changed in ubuntu-mate:
status: Confirmed → Fix Released
Nils Fenner (nilsfenner) wrote :

Having this issue as well. Running Lubuntu 15.04 with custom LXQt installation - two screens. Seems like this behaviour is caused by lightdm.

Jakub Liput (kliput) wrote :

The same issue in Xubuntu 15.04 - using two screens. Will this fix be available for lightdm-gtk-greeter for 15.04 as well?

Same issue in Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=785055

2 monitors, white screen, 100% CPU usage.

This seems to be the same bug as bug #1410406 (though this one says that the screen is black).

Sean Davis (bluesabre) on 2015-05-21
Changed in lightdm-gtk-greeter:
milestone: none → 2.0.1
Sean Davis (bluesabre) on 2015-05-21
Changed in lightdm-gtk-greeter:
status: New → Fix Released

Where is the fix. I still experience it in 16.04. Using 2.0.1* version.

2 monitors, black screen, 100% CPU Usage.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.