15.04-Beta-1: Package 'grub-pc' has no installation candidate

Bug #1426436 reported by Ish Sookun on 2015-02-27
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-mate
Critical
Martin Wimpress

Bug Description

Installation of Ubuntu Mate 15.04 Beta 1 fails at the end without installing Grub.
The error displayed is:

ubuntu-mate ubiquity: : Package 'grub-pc' has no installation candidate
ubuntu-mate grub-installer: info: Calling 'apt-install grub-pc' failed

Screenshot attached for more information.

Ish Sookun (ish.sookun) wrote :
Martin Wimpress (flexiondotorg) wrote :

Multiple installs were successfully completed during the Beta 1 test period, no one encountered this?

  * Can you confirm amd64 or i386 version?
  * Can you also check that your iso image MD5 or SHA sums are correct please?

Changed in ubuntu-mate:
status: New → Incomplete
Ish Sookun (ish.sookun) wrote :

It's the amd64 version. MD5 and SHA sums correspond to :

http://cdimage.ubuntu.com/ubuntu-mate/releases/15.04/beta-1/MD5SUMS
http://cdimage.ubuntu.com/ubuntu-mate/releases/15.04/beta-1/SHA1SUMS

~# md5sum ubuntu-mate-15.04-beta1-desktop-amd64.iso
66fa1382739752af54303d6402130ec7 ubuntu-mate-15.04-beta1-desktop-amd64.iso

~# shasum ubuntu-mate-15.04-beta1-desktop-amd64.iso
e435716bdf88d24f44a01aa26c605d41355a927b ubuntu-mate-15.04-beta1-desktop-amd64.iso

I tried installations formatting the disk with Btrfs and a second time Ext4. Previously, the same laptop (HP Compaq 6515b) ran Ubuntu Mate 14.04 64Bit fine.

Changed in ubuntu-mate:
status: Incomplete → Fix Committed
Martin Wimpress (flexiondotorg) wrote :

This should be fixed in the updated daily image. Can you test and confirm please?

  * http://cdimage.ubuntu.com/ubuntu-mate/daily-live/20150302.1/

Ish Sookun (ish.sookun) wrote :

I tested the ISO on an ASUS X75V that has Linux Mint 17 alongside. I received the error:

The 'grub-efi-amd64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.

See screenshot for details.

Philip Guyton (phil-lxnet) wrote :

Procedure to reproduce for me:-

Note I used easy2boot as this compaq mini 700 is not happy booting directly it seems.
Don't get the opportunity (due to gfxboot.c32: not a com32R image even if live-installer boot option used) to add the following:-
removed quiet splash and put in nomodeset acpi_os_name=Linux via F6 option on boot screen

English
Download updates & 3rd party stuff
(long pause here)
something else
used existing vg and lvs
xfs format / (on lv)
swap area (on lv)
sda1 ext2 /boot
left device for booting installation at “/dev/sda”
login auto
When it got to the “Installing ‘grub2’ package…”
Dialog
“The ‘grub-pc’ package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.”
OK = only option.
Bootloader install failed (as superuser)
chose the same device ie /dev/sda
Then both the installation is complete dialog and a repeat of the Sorry, an error occurred and it was not possible to install the bootloader.

N.B. in syslog we have:-

Ubiquity: Package grub-pc is not available, but is referred to by another package.
However the following packages replace it: grub-common

E: Package ‘grub-pc’ has no installation candidate
grub-installer: info : Calling ‘apt-install grub-pc’ failed

Hope that helps (MD5 checked and is:- d74b2ca893e227f2063804db627d98c5
ie 3/3/2015 32bit version.
also note that apt-get install grub-common shows grub-common as installed.

On trying to install grub-pc I got an error that a repository couldn't be reached (seemed to be via ipv6 address), downed and upped eth0 and was then able to find and install grub-pc but I had problems configuring grub-pc.
Could this be an ipv6 issue as seems rare and I am on a pretty bizarre network (at least double natted)

Philip Guyton (phil-lxnet) wrote :

Installed again as in my last post but this time without download updates ticked and without 3rd party ticked and got the same result.

Martin Wimpress (flexiondotorg) wrote :

Are you testing the daily inages?

Philip Guyton (phil-lxnet) wrote :

@Martin haven't tested any more since 3/3/2015, has anything else changed in this regard since 3/3 build (md5 indicated)? It was perfectly reproducibly but takes ages to do on my 700 mini. Will try again with the 5th March build. Is there a definitive changelog for these specific builds so I can try only when something relevant has been updated?

Philip Guyton (phil-lxnet) wrote :

OK just got the same result with 32 bit image dated 5/3 md5sum d7848e6f0215deace1e5b3ab51e7ec8e using the same install procedure.
ie:-
Dialog
“The ‘grub-pc’ package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot.”

Is there anything else I can report that might help?

ahadpo (ahadpo) wrote :

I have tested daily i386 build (7-March) on my desktop & laptop
Desktop Intel - Installation Sucsessfull
Laptop Lenvo E430 - Install failed Grub Error

What is different beteen "Desktop Intel" and "Laptop Lenvo E430"?

Are they both amd64? Is one EFI?

Phil Norbeck (ptn107) wrote :

Same thing with the 32-bit image on real hardware. I tried to install it on a desktop with one single 80GB IDE drive.

grub-pc fails to install to /target/

image: ubuntu-mate-15.04-beta1-desktop-i386.iso
date: Feb 25, 2015 13:44
md5: c90f1cf79976921b106b39cbb04f0bf5

Changed in ubuntu-mate:
status: Fix Committed → In Progress
importance: Undecided → Critical
assignee: nobody → Martin Wimpress (flexiondotorg)
Changed in ubuntu-mate:
status: In Progress → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1426436

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers