Umlaute (ä,ö,ü) are written in small caps in the pdf, even if the translation is right

Bug #795031 reported by Das Auge
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual
Low
Ubuntu Manual Team

Bug Description

Im Kapitel "Ist Ubuntu das Richtige für sie" muss im 2. Satz "Ähnlichkeiten" groß geschrieben werden.

Gabor Kelemen (kelemeng)
Changed in ubuntu-translations:
assignee: nobody → Ubuntu German Translators (ubuntu-l10n-de)
status: New → Triaged
importance: Undecided → Low
Revision history for this message
Hendrik Knackstedt (hennekn) wrote :

Cannot find this string in Ubuntu Manual. What version of Ubuntu and what version of the affected package are you using?

Changed in ubuntu-translations:
status: Triaged → Incomplete
Revision history for this message
Carsten Gerlach (carsteng) wrote :

I think he mean the manual from http://ubuntu-manual.org/. In the last german version (10.04, direkt link http://ubuntu-manual.org/download/10.04/de) is the mentioned string. The Launchpad project is here: https://translations.launchpad.net/ubuntu-manual. But this project looks a little outdated, or? I see only Maverick there …

Revision history for this message
Carsten Gerlach (carsteng) wrote :

I just translated the affected string, so this bug can be closed.

Changed in ubuntu-translations:
status: Incomplete → Fix Committed
Revision history for this message
Daniel Schury (surst) wrote :

You've got to tell me exactly, were you find this String. In lucid-e1, the only version released in german, the sentence is correct, as in lucid-e2 (which isn't released so far). In maverick the string isn't translated at all. So, were is the misspelling?

affects: ubuntu-translations → ubuntu-manual
Changed in ubuntu-manual:
status: Fix Committed → Incomplete
Revision history for this message
Carsten Gerlach (carsteng) wrote :

Daniel, you are right. I try to be more precise: In lucid-e1 is the translation correct, https://translations.launchpad.net/ubuntu-manual/lucid-e1/+pots/ubuntu-manual/de/69/+translate. In lucid-e2 is also a translation, but with another formulation, without "Ä", https://translations.launchpad.net/ubuntu-manual/lucid-e2/+pots/ubuntu-manual/de/89/+translate. In Maverick is not yet a translation, so I made a suggestion which I updated now to the lucid-e2 version (https://translations.launchpad.net/ubuntu-manual/maverick/+pots/ubuntu-manual/de/92/+translate). Conclusion: There is no mistake in all the translations.

I think, the problem is the generating of the final PDF document, which you find here: http://ubuntu-manual.org/download/10.04/de. On page 9 is the mentioned string.
In general for the whole document: All words which start with Ü, Ö or Ä are "scaled down" to ü, ö, or ä. The same problem is the letter ß: It is printed as "/ss".
This is not all: If I copy some text from the PDF to a text editor, I get some rubbish. "ch" becomes to , and with small capitals (Kapitälchen) it is the same (for example page 23: GNOME becomes to ) . But this depents on the used font. The problem is the normal text font; in captions and notes in the margin is all ok.

So I think, this bug can be closed, because this problem is not a translaton mistake. But this bug should be forwarded to the ubuntu manual project itself.

Revision history for this message
Carsten Gerlach (carsteng) wrote :

Hups, my last section is outdated. I did not notice, that you already forwarded this bug to the ubuntu-manual project.

Daniel Schury (surst)
summary: - translation bug in ubuntu manual de
+ Umlaute (ä,ö,ü) are written in small caps in the pdf, even if the
+ translation is right
Changed in ubuntu-manual:
assignee: Ubuntu German Translators (ubuntu-l10n-de) → Ubuntu Manual Team (ubuntu-manual)
Revision history for this message
Kevin Godby (godbyk) wrote :

Does this bug refer only to errors in the lucid-e1 edition? With the lucid-e1 translation, I believe some post-processing was done that mistakenly converted ß to /ss. The same find-replace operation may have screwed up the capitalization of the umlauts.

If you have Ä, Ö, Ü, etc. in the translation on Launchpad and the lucid-e2 PDF isn't displaying it correctly, then I'll have to look into the problem.

Revision history for this message
Daniel Schury (surst) wrote :

Ah, well there was something. I'm compiling lucid-e2 with the attached script and everything is fine. So the bug can be closed?

Revision history for this message
Daniel Schury (surst) wrote :

As we do not re-release lucid-e1 and lucid-e2 will be released soon, it should be changed to won't fix

Changed in ubuntu-manual:
status: Incomplete → Confirmed
Daniel Schury (surst)
Changed in ubuntu-manual:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers