"/ss" instead of "sharp s (ß)" in german manual - revisionnumber 907

Bug #610777 reported by Pa_trick17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual
Undecided
Kevin Godby

Bug Description

Hello, in the great new german version of the manual "Getting Started with Ubuntu" i get in Evince ("...uses poppler/cairo (0.12.4)") an "/ss" instead of "sharp s (ß)" (see screenshot attached). I haven't (yet) noticed this problem with other german documents.

Greets,

Pa_trick17
-------------------------------------------------
Hallo, im tollen neuen Handbuch "Erste Schritte mit Ubuntu 10.04" ist (bei mir) in Evince ("Dokumentenbetrachter
Verwendet poppler/cairo (0.12.4)") das "ß" immer mit /ss dargestellt (siehe Screenshot im Anhang). Dieses Problem ist mir bei anderen deutschen Dokumenten (noch) nicht aufgefallen.

Gruß,

Pa_trick17

Revision history for this message
Pa_trick17 (trick17) wrote :
Pa_trick17 (trick17)
affects: ubuntu-translations → ubuntu-manual
Revision history for this message
Pa_trick17 (trick17) wrote :

Hi, i can't assign this bug to "Ubuntu German Translators" as described under bug-reporting at their launchpad page (https://launchpad.net/~ubuntu-l10n-de). Maybe this fault, that if you make a bug-report like proposed there you don't have the permissions to assign it like described, shall be overworked, too.

Thanks,

Pa_trick17

Revision history for this message
Pa_trick17 (trick17) wrote :

I'm setting status to "confirmed" because i found comments (for example http://ikhaya.ubuntuusers.de/2010/07/29/ubuntu-manual-in-deutsch-veroeffentlicht/#comment_2) of others having the same issues. In named comment it seems as "/ss" shall be "\ss".

Greets,

Pa_trick17

Changed in ubuntu-manual:
status: New → Confirmed
Pa_trick17 (trick17)
description: updated
summary: - "/ss" statt ß in Revisionsnummer 907
+ "/ss" instead of "sharp s (ß)" in german manual - revisionnumber 907
description: updated
Revision history for this message
Pa_trick17 (trick17) wrote :

A fix to this bug has been released. See Revision 908: http://bazaar.launchpad.net/~ubuntu-manual/ubuntu-manual/main/revision/908 .

Changed in ubuntu-manual:
status: Confirmed → Fix Released
Revision history for this message
Kevin Godby (godbyk) wrote :

The commit fails to fix the bug, unfortunately.

I have the proper fix ready, but haven't committed it yet. (I'll get it committed when i get back home after the weekend.)

Changed in ubuntu-manual:
assignee: nobody → Kevin Godby (godbyk)
status: Fix Released → In Progress
Revision history for this message
Kevin Godby (godbyk) wrote :

I've committed a patch and regenerated the PDFs. Could you please look at http://builds.ubuntu-manual.org/builds/ubuntu-manual-de-screen.pdf and let me know if the ß and umlauts look okay now? (I changed the input encoding for the umlauts in addition to the ß.)

Thanks!

Changed in ubuntu-manual:
status: In Progress → Fix Committed
Revision history for this message
Paul Jaros (madmike77) wrote :

Fixed as far as I can tell.

Revision history for this message
Pa_trick17 (trick17) wrote :

Same here. In linked build, the "ß" and umlauts are correct.

Thank you.

Pa_trick17

Revision history for this message
Kevin Godby (godbyk) wrote :

While the ß bug has been fixed, I noticed that there are no capital umlauts. Somewhere in the editing process they were converted to lowercase. I've emailed the German translation editor and we'll hopefully get these corrected soon as well.

Changed in ubuntu-manual:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers