Graphical interface in Linux (incorrect information)

Bug #508265 reported by Xuacu Saturio on 2010-01-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Manual
Low
Benjamin Humphrey

Bug Description

Located in ./prologue/prologue.tex :131 (Launchpad Translations reference)

It reads:
"For many years, Linux was entirely command line based --- it didn't have a Graphical User Interface [...]"

My first Linux was an Slackware distro, circa 1995 and it came with Fvwm, Netscape Navigator and a lot of Motif(ish) based applications... only 4 years after Linux was born :)

My suggestion is to change "many years" by "some years", and add some reference to older GUIs being hard to configure (actually, a nightmare)

Regards

alamati (alamati) wrote :

Hi all,
I suggest:
many years -> first years
or
For first years, similar other operating systems, Linux was ...

In response to alamati's suggestion, I believe that the suggestion
isn't that grammatically correct instead it may be better to say "For
its first few years, Linux was controlled entirely by a command line
interface lacking an easily configurable GUI [...]"

Regards / Cofion,
Christopher Swift.

2010/1/16 alamati <email address hidden>:
> Hi all,
> I suggest:
> many years -> first years
> or
> For first years, similar other operating systems, Linux was ...
>
> --
> Graphical interface in Linux (incorrect information)
> https://bugs.launchpad.net/bugs/508265
> You received this bug notification because you are a member of Ubuntu
> Manual Team, which is subscribed to Ubuntu Manual.
>
> Status in Ubuntu Manual: New
>
> Bug description:
> Located in ./prologue/prologue.tex :131 (Launchpad Translations reference)
>
> It reads:
> "For many years, Linux was entirely command line based --- it didn't have a Graphical User Interface [...]"
>
> My first Linux was an Slackware distro, circa 1995 and it came with Fvwm, Netscape Navigator and a lot of Motif(ish) based applications... only 4 years after Linux was born :)
>
> My suggestion is to change "many years" by "some years", and add some reference to older GUIs being hard to configure (actually, a nightmare)
>
> Regards
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ubuntu-manual
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~ubuntu-manual
> More help   : https://help.launchpad.net/ListHelp
>

Why not simply state the year? Like:

"Until 1995, and like every other operating system, Linux was..."

Bruno Bernardino (eNz1m3 @ forums)

On Sat, Jan 16, 2010 at 18:52, Christopher Swift <
<email address hidden>> wrote:

> In response to alamati's suggestion, I believe that the suggestion
> isn't that grammatically correct instead it may be better to say "For
> its first few years, Linux was controlled entirely by a command line
> interface lacking an easily configurable GUI [...]"
>
> Regards / Cofion,
> Christopher Swift.
>
> 2010/1/16 alamati <email address hidden>:
> > Hi all,
> > I suggest:
> > many years -> first years
> > or
> > For first years, similar other operating systems, Linux was ...
> >
> > --
> > Graphical interface in Linux (incorrect information)
> > https://bugs.launchpad.net/bugs/508265
> > You received this bug notification because you are a member of Ubuntu
> > Manual Team, which is subscribed to Ubuntu Manual.
> >
> > Status in Ubuntu Manual: New
> >
> > Bug description:
> > Located in ./prologue/prologue.tex :131 (Launchpad Translations
> reference)
> >
> > It reads:
> > "For many years, Linux was entirely command line based --- it didn't have
> a Graphical User Interface [...]"
> >
> > My first Linux was an Slackware distro, circa 1995 and it came with Fvwm,
> Netscape Navigator and a lot of Motif(ish) based applications... only 4
> years after Linux was born :)
> >
> > My suggestion is to change "many years" by "some years", and add some
> reference to older GUIs being hard to configure (actually, a nightmare)
> >
> > Regards
> >
> >
> >
> > _______________________________________________
> > Mailing list: https://launchpad.net/~ubuntu-manual
> > Post to : <email address hidden>
> > Unsubscribe : https://launchpad.net/~ubuntu-manual
> > More help : https://help.launchpad.net/ListHelp
> >
>
> _______________________________________________
> Mailing list: https://launchpad.net/~ubuntu-manual
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~ubuntu-manual
> More help : https://help.launchpad.net/ListHelp
>

Tom Cantara (tacantara) wrote :

I think Bruno is on the right track. IBM/PC-DOS based machines didn't have Windows until 1985 (Version 1.0), and Apple's GUI was introduced on the Lisa in 1982/1983. If you go back far enough, the Xerox Alto (1970's) had a GUI, and it was the inspiration for the Lisa. Yes, TMI...but I had fun doing some quick research on it ;)

Xuacu Saturio (xuacusk8) wrote :

According to Wikipedia
http://en.wikipedia.org/wiki/X_Window_System
X11 appeared in 1987 (4 years before Linux)

I couldn't find when it made into Linux... almost certainly, before 1995

Regards

Changed in ubuntu-manual:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Benjamin Humphrey (humphreybc)
status: Confirmed → In Progress

Or perhaps it could read . " in the beginning... "or " in its inception.
"something along those lines. :)

On Mon, 2010-01-18 at 00:03 +0000, Benjamin Humphrey wrote:
> ** Changed in: ubuntu-manual
> Status: New => Confirmed
>
> ** Changed in: ubuntu-manual
> Importance: Undecided => Low
>
> ** Changed in: ubuntu-manual
> Assignee: (unassigned) => Benjamin Humphrey (humphreybc)
>
> ** Changed in: ubuntu-manual
> Status: Confirmed => In Progress
>

Changed in ubuntu-manual:
milestone: none → alpha-release
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers