Factual Error Terminal vs. Shell (Chapter 7)

Bug #506803 reported by Anmol Sarma on 2010-01-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Manual
Medium
Ryan Macnish

Bug Description

Section 7.1 suggests that the shell and the terminal are the same.

The terminal provides input and output functionality while the shell processes the user's commands. the uses accesses the shell by means of a terminal. They are two distinct concepts implemented by two distinct programs. A beginner might need a simplified yet factually correct explanation.

Changed in ubuntu-manual:
assignee: nobody → Ryan Macnish (nisshh)
status: New → Confirmed
Ryan Macnish (nisshh) on 2010-01-27
Changed in ubuntu-manual:
status: Confirmed → In Progress
Ryan Macnish (nisshh) on 2010-01-27
Changed in ubuntu-manual:
status: In Progress → Fix Committed

The new version again suggests that a terminal and a shell are the same. I
could not come up with a better way so I did this
http://ubuntuforums.org/search.php?searchid=69501913 Hope you don't mind.

On Wed, Jan 27, 2010 at 2:10 AM, Ryan Macnish <email address hidden> wrote:

> ** Changed in: ubuntu-manual
> Status: In Progress => Fix Committed
>
> --
> Factual Error Terminal vs. Shell (Chapter 7)
> https://bugs.launchpad.net/bugs/506803
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu Manual: Fix Committed
>
> Bug description:
> Section 7.1 suggests that the shell and the terminal are the same.
>
> The terminal provides input and output functionality while the shell
> processes the user's commands. the uses accesses the shell by means of a
> terminal. They are two distinct concepts implemented by two distinct
> programs. A beginner might need a simplified yet factually correct
> explanation.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu-manual/+bug/506803/+subscribe
>

Changed in ubuntu-manual:
milestone: alpha-release → beta-release
Changed in ubuntu-manual:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers