No translation support for project

Bug #503325 reported by Benjamin Humphrey on 2010-01-05
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual
Critical
Ubuntu Manual Team

Bug Description

We have no support for translations at the moment.

https://wiki.ubuntu.com/ubuntu-manual/Help#Translations

Changed in ubuntu-manual:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Ubuntu Manual Team (ubuntu-manual)
RJQ (qcuchulain) wrote :

I just came across with this project, (I am slowly digesting this hopping to get somewhere) http://po4a.alioth.debian.org/
It seems like we need someone experienced in gettext in order to use Rosetta in Launchpad, and for what I had read in the above web page this po4a can keep the context of the documents updated with any change, I believe that could work for the Ubuntu-Manual project since the goal is to keep it moving with the releases of Ubuntu.

I going to keep reading to see what else we can do.

RJQ.

Benjamin Humphrey (humphreybc) wrote :

Hey I just had a brief read over it just now and it seems like it could work. So I'm guessing it stores the translations in .po format which has support for UTF-8 and special characters. This po4A is just a way to make LaTeX interact with the .po files?

Josh Holland (jshholland) wrote :

I've had a bit of a look at it, and it looks like it could be a goer. It is pretty much a way to get .pot files out of LaTeX, which can just be uploaded into Rosetta, and then translated from there. One thing I'm slightly wary of is that the gettext system is designed for translating short individual sentences in a program, rather than a big chunk of documentation. However, I think the Rosetta integration will probably make using it worthwhile.

I've been having a fiddle in my bzr branch, and it looks like it should be pretty simple to get a .pot file uploaded so that translations can start. We'll need to look at automatically exporting them from a branch for the future, but for now doing it by hand will do.

Joe Burgess (joemburgess) wrote :

So this will work the only issue is actually figuring out rosetta. It looks like we have to create a translation team so that we can approve items in the translation queue, which is annoying. I will look around and see how to make a translation team.

Josh Holland (jshholland) wrote :

I added the po4a stuff into the main branch and pushed it up. Hopefully, the translation auto-syncing thing should pull in what it needs to, and things should be able to kick off as soon as Launchpad sorts its translation import queue out.

Now we just need to work out how to get the translations back into the project. I think a bit of Makefile fiddling could be needed, so we could do eg make LANG=es all and get a Spanish version out.

RJQ (qcuchulain) wrote :

I am using it already and it seams everything is fine, a least to start moving the translations, it also is working as supposed since is grabbing chunks of paragraphs as they appear on the text. now we can star calling the caballería for it. awesome job Josh, thanks guys for your time.

Changed in ubuntu-manual:
status: Confirmed → In Progress
Changed in ubuntu-manual:
status: In Progress → Fix Committed
milestone: none → alpha-release
Changed in ubuntu-manual:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers