Restart is not working at the end of bionic final installation

Bug #1766049 reported by Saikat Sen on 2018-04-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual Tests
Undecided
Unassigned

Bug Description

I installed bionic final iso on my system (i3-4130, 8GB RAM). The installation went well and I got the option to "restart now" at the very end. But when I clicked it system was not restarted properly. It was stuck. I had to manually restart. Also I think test cases (step 17 and 18) need modification because remove media warning is not shown any longer.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766049

tags: added: iso-testing
Leó Kolbeinsson (leok) wrote :

Tested (Bionic Final 21.04.18) on Dell Optiplex 620 with 2GB RAM and did not encounter this problem.

Saikat Sen (saikosen) wrote :

@Leok I noticed a warning related to Intel microcode update. Can it be because of that?

Łukasz Zemczak (sil2100) wrote :

I tested it on a KVM instance and it seems to work here, I think we would need some more information regarding your case. After pressing the "Restart now" button, does your system switch to the terminal and print out a prompt about removing installation media and pressing enter to continue? Did you try pressing enter when it was 'hung'? Could you maybe provide a screenshot/photo of how the hang portion of the system after installation looks like?

Saikat Sen (saikosen) wrote :

@sil2100 I did not get any such prompt in terminal. I will try to install again and attach screenshot.

On 23/04/18 11:20, Łukasz Zemczak wrote:
> I tested it on a KVM instance and it seems to work here, I think we
> would need some more information regarding your case. After pressing the
> "Restart now" button, does your system switch to the terminal and print
> out a prompt about removing installation media and pressing enter to
> continue? Did you try pressing enter when it was 'hung'? Could you maybe
> provide a screenshot/photo of how the hang portion of the system after
> installation looks like?
>
Just testing the OEM install in Xubuntu.

Using kvm etc via virt-manager.

No remove media message - just a black screen, pressing enter and it
rebooted.

Ftr - wasn't seeing this yesterday while doing a different test on
exactly the same virtual machine with the same iso.

attaching installer syslog and debug seperately

Kev Bowring (flocculant) wrote :
Kev Bowring (flocculant) wrote :
Leó Kolbeinsson (leok) wrote :

Did 2 tests this morning on Bionic Final (240418 build) Lubuntu Desktop I386 and one on the amd64.

1. on a Dell Optiplex machine with 2GB Ram and got this bug - restart failed and had to do a manual restart.

2. The second test in a Hyper-V virtual machine (same build the I386 eintire disk) no bug encountered.

3. Did a third test on the Lubuntu amd64 entire disk build 240418 - no bug - restarted no problem - installed on a Virtual Box machine running on Lubuntu 17.10.

Łukasz Zemczak (sil2100) wrote :

@flocculant Ok, so sadly that's a known issue caused by the way we currently perform the prompt display and reboot, making it a bit non-deterministic regarding what is left in the cache for the actual final reboot. Sometimes plymouth can be visible, sometimes terminal, sometimes - nothing. This is something we'd like to get fixed but for this cycle it's already too late.

Saikat Sen (saikosen) wrote :

Did another test this morning and in

First attempt installer crashed
Second attempt same issue.

Attaching snapshot for 2nd now.

Saikat Sen (saikosen) wrote :
Dill Pickles (dimapoter) wrote :

Intel Core i5 4210U (Low Voltage Mobile VT-x capable Haswell).

Getting this same error. For me, it doesn't even bring up the GRUB menu. Just gives this message (exactly as in screenshots by previous posters), and hangs on a black screen after a while. I have to manually power off by holding. Installation was this Apr 24 Kubuntu Bionic image made with Rufus in MBR for UEFI or BIOS mode.

BIOS on this physical machine was updated with the end of '17 Intel ME Meltdown/Spectre workarounds.

Is there a workaround? Should I dare try a workaround (i.e. will the installation itself be messed)? Please advise.

Łukasz Zemczak (sil2100) wrote :

@saikosen In this hanged state, did pressing enter cause a reboot?

@dimapoter This bug is about missing reboot after the installation is finished. I might be misunderstanding your comment, but from reading it it sounds to me like you have issues with actually booting up your installed system? Since the workaround for the missing reboot after install is just manually hardware rebooting the system.

Saikat Sen (saikosen) wrote :

@sil2100 pressing enter did not make any difference

Kev Bowring (flocculant) wrote :

On 24/04/18 09:34, Łukasz Zemczak wrote:
> @flocculant Ok, so sadly that's a known issue caused by the way we
> currently perform the prompt display and reboot, making it a bit non-
> deterministic regarding what is left in the cache for the actual final
> reboot. Sometimes plymouth can be visible, sometimes terminal, sometimes
> - nothing. This is something we'd like to get fixed but for this cycle
> it's already too late.
>
ack - I know I've seen this in pretty much as many cycles as I can
remember - off and on ...

would be awesome to see the back of it one day :D

Leó Kolbeinsson (leok) wrote :

Tested the latest build this morning - both amd64 and i386 - the problem seems to be solved- at least it worked fine for me.

Saikat Sen (saikosen) wrote :

Ok thanks, fingers crossed for tomorrow. Good job folks. Make us proud, make Ubuntu no. 1 OS 😊

Rik Mills (rikmills) on 2018-04-26
Changed in ubuntu-manual-tests:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers