OEM installation test case doesn't follow screen sequence

Bug #1754150 reported by Richard Elkins on 2018-03-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Manual Tests
Undecided
Unassigned

Bug Description

Steps 1 and 2 work as expected.

Step 3. "3. Select your language and then press Enter
 The installer menu is displayed"

Actually, the initial installation menu is displayed in the same screen with the language selection. Pressing Enter is equivalent to selecting "Install Ubuntu". Pressing F4 has no effect. I pressed Enter as instructed in the test case step 3.

"Keyboard layout" is then displayed. Pressing F4 has no effect. Pressed Enter to continue.

"Preparing to install Xubuntu" is then displayed. Pressing F4 has no effect. Pressed continue button.

"Installation type" is then displayed. Pressing F4 has no effect. I gave up at this point of getting to anything that contains the text string "OEM".

Note that the phrase "Installer menu" is vague. It would help if the tester could see exactly which installation menu to expect (E.g. "Keyboard layout").

Richard Elkins (texadactyl) wrote :

Machine used:

 - Assembled 2009-04-15
   - Zotac IONITX-F-E Mini-ITX motherboard
      * CPU Intel Atom 330 (1.6GHz, dual-core)
      * NVIDIA GeForce 9400
   - RAM: 4GB DDR3
   - Graphics support auto-selected:
      * Kernel module - nvidiafb
      * Xorg video driver - nvidia-340
   - Permanent storage: SSD 60GB
   - RJ45 Ethernet: Nvidia forcedeth kernel module
   - Mini-ITX enclosure: Habey EMC-800S Silver

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1754150

tags: added: iso-testing
Kev Bowring (flocculant) on 2018-03-07
summary: - Xubuntu Bionic Beta-1 OEM installation test case doesn't follow screen
- sequence
+ OEM installation test case doesn't follow screen sequence
Kev Bowring (flocculant) wrote :

Not sure that you followed the testcase correctly here - just re-checked it. Works fine for me. Vid included

Changed in ubuntu-manual-tests:
status: New → Incomplete
Richard Elkins (texadactyl) wrote :

Your mp4 is not what I was seeing after I downloaded & installed from the above URL on 2018-03-07 i.e.

zsync http://cdimage.ubuntu.com/xubuntu/daily-live/20180306.1/bionic-desktop-amd64.iso.zsync

The resulting installation several times with the same image were the 18.04 beta-1 desktop.

I just now re-did the same exact procedure starting with `zsync` and now I am seeing a different sequence which does follow the test script and resembles your mp4. Is it possible the image changed since March 6th? If not, then I cannot explain the sequence of screens that I saw.

Richard Elkins (texadactyl) wrote :

Thanks for checking me.

Changed in ubuntu-manual-tests:
status: Incomplete → Invalid
Kev Bowring (flocculant) wrote :

@texadactyl - the image I used is the one you used. One of those things, thanks for changing bug status.

Changed in ubuntu-manual-tests:
status: Invalid → New
Richard Elkins (texadactyl) wrote :

There is nothing wrong with the OEM script when the system startup correctly detects the video hardware.

Sometimes I get what you saw in your mp4 and sometimes I see what I originally reported (see attached JPEG).

Richard Elkins (texadactyl) wrote :

I believe that this report and report #1754072 are related. The test hardware is circa 2009.

   - Assembled 2009-04-15
   - Zotac IONITX-F-E Mini-ITX motherboard
      * CPU Intel Atom 330 (1.6GHz, dual-core)
      * NVIDIA GeForce 9400

I have seen this sort of anomaly in video-detecting before. I should have realized it immediately.

It is not preventing me from using bionic beta-1 since once it is installed, the performance is excellent - including video.

Richard Elkins (texadactyl) wrote :

I'll leave it as invalid since the title is misleading.

Changed in ubuntu-manual-tests:
status: New → Invalid
A. Denton (aquina) wrote :

Don't know what happened here, but this bug/issue (OEM installation test case doesn't follow screen sequence) is by no means INVALID.

The problem of a missing OEM install option after pressing F4 just occoured and is now documented and confirmed on http://iso.qa.ubuntu.com/qatracker/milestones/389/builds/171062/testcases/1305/results/

Status: Failed
Reporter: aquina (me)
Last update: 2018-04-26 11:54
Bugs: #1754150
Comment:
Tested on 2018-04-26 with CURRENT bionic daily/final ISO on VirtualBox 4.3. Test FAILED ("Press F4 and select 'OEM Install (for manufacturers)' and press Enter") since option unavailable.

The reporter Richard Elkins (2018-03-07) of this bug also described, quote:
""Installation type" is then displayed. Pressing F4 has no effect. I gave up at this point of getting to anything that contains the text string "OEM"."

Changed in ubuntu-manual-tests:
status: Invalid → Opinion
A. Denton (aquina) wrote :

The problem was confirmed and documented on iso.qa.ubuntu.com on 2018-04-26.
see: http://iso.qa.ubuntu.com/qatracker/milestones/389/builds/171062/testcases/1305/results/

Changed in ubuntu-manual-tests:
status: Opinion → Confirmed
A. Denton (aquina) on 2018-04-26
no longer affects: boot (Ubuntu)
A. Denton (aquina) wrote :

After some reboots/shut offs of the VirtualBox machine the OEM option is finally displayed. The reason for that is yet unknown.

Someone suggested to try booting to UEFI mode on boot of the computer, press the specific key to open the boot menu and from there select UEFI mode. However that was not tried/the culprit.

Kev Bowring (flocculant) wrote :

You don't see this?

A. Denton (aquina) wrote :

Yes, after the 2nd or 3rd time that was displayed (screenshot). However, during the first boot from the ISO image on VirtualBox it showed just one(!) field, with the option/letters "None". That of course was not a -great- option to choose from at all.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers