ristretto: mouse wheel does NOT zoom image rather it goes back and forth through image list

Bug #1292073 reported by Jack Kern on 2014-03-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Manual Tests
Undecided
David Pires
ristretto
Fix Released
Low

Bug Description

http://packages.qa.ubuntu.com/qatracker/milestones/306/builds/55995/testcases/1600/results

"This test case will verify that the adjustable settings in the Preferences dialog box work properly."

"6. Go to Edit->Preferences->Control tab, and check the "Invert zoom direction" checkbox. Zoom in and out of the image using the mouse scroll button.
The zoom direction is reversed"

Failed

Jack Kern (schproodle) on 2014-03-13
summary: - mouse wheel does zoom image rather it goes back and forth through image
- list
+ mouse wheel does not zoom image rather it goes back and forth through
+ image list

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1292073

tags: added: package-qa-testing
Jack Kern (schproodle) on 2014-03-13
summary: - mouse wheel does not zoom image rather it goes back and forth through
- image list
+ ristretto: mouse wheel does not zoom image rather it goes back and forth
+ through image list
summary: - ristretto: mouse wheel does not zoom image rather it goes back and forth
+ ristretto: mouse wheel does NOT zoom image rather it goes back and forth
through image list
Changed in ubuntu-manual-tests:
status: New → In Progress
assignee: nobody → David Pires (slickymaster)

Expected behavior:
By default, Ristretto zooms in when turning the scroll-wheel forward, and zooms out when turning the scroll-wheel backward.
This setting can be inverted by navigating to Edit -> Preferences -> Control tab, and check the "Invert zoom direction" check box.

What is actually happening:
After checking the "Invert zoom direction" check box it's still zooming in when turning the scroll-wheel forward and zooming out when turning the scroll-wheel backward.

~$ apt-cache policy ristretto
ristretto:
  Installed: 0.6.3-2
  Candidate: 0.6.3-2
  Version table:
 *** 0.6.3-2 0
        500 http://pt.archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status

~$ lsb_release -a && uname -r

Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty
3.14.0-031400rc6-generic

Changed in ristretto:
importance: Unknown → Low
Elfy (elfy) wrote :

if there is a bug in ristretto - then any bug reported against a testcase should be invalid

Changed in ristretto:
status: Unknown → Confirmed
David Pires (slickymaster) wrote :

Actually step 6 of the adjustable settings in the Preferences dialog box block in the testcase is wrong. In order to perform the intended zoom action in Ristretto, the Ctrl key has to be pressed while turning the scroll-wheel of the mouse.

Changed in ubuntu-manual-tests:
status: In Progress → Fix Committed
Elfy (elfy) on 2014-03-14
Changed in ubuntu-manual-tests:
status: Fix Committed → Fix Released

Created attachment 5475
Patch

The attached patch solves the problem.

Also affected, this is the only bug making me use Eye of Gnome 2, would be glad if it gets fixed! However in my case the "Invert zoom direction" check box does not affect the behaviour: Whether it is checked or not, the mouse wheel scrolls through the image list instead of zooming in and out.

André, works great, thanks! Pushed to master in:

commit 465a9f5bde65cd6af8ef559c43cd0f4421437583
Author: André Miranda <email address hidden>
Date: Sun Jan 25 09:49:18 2015 +0300

    Fix invert zoom direction (Bug #10746)

    The patch fixes the code so that the invert zoom direction is
    applied when doing a scroll-wheel zoom.

    Signed-off-by: Eric Koegel <email address hidden>
http://git.xfce.org/apps/ristretto/commit/?id=465a9f5bde65cd6af8ef559c43cd0f4421437583

Changed in ristretto:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.