software-center crashed with TransactionFailed in _run_transaction(): <unprintable TransactionFailed object>

Bug #1097946 reported by Håkon Emil Olsen on 2013-01-09
304
This bug affects 67 people
Affects Status Importance Assigned to Milestone
Cute Software Center
Confirmed
High
Unassigned
Wine
Invalid
Undecided
Unassigned
gnome-smartdimmer (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
Nominated for Vivid by Alberto Salvia Novella
software-center (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
Nominated for Vivid by Alberto Salvia Novella
software-center (Ubuntu Linaro Evaluation Build)
Undecided
Unassigned

Bug Description

I try to install Skype on ubuntu 13.04

ProblemType: RecoverableProblem
DistroRelease: Ubuntu 13.04
Package: software-center 5.5.3
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.8-0ubuntu1
Architecture: amd64
Date: Wed Jan 9 21:59:07 2013
DuplicateSignature: software-center:trans-failed:error-dep-resolution-failed
ExecutablePath: /usr/share/software-center/software-center
InstallationDate: Installed on 2013-01-04 (5 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130103)
InterpreterPath: /usr/bin/python2.7
MarkForUpload: True
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/software-center
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
SourcePackage: software-center
Title: software-center crashed with TransactionFailed in _run_transaction(): <unprintable TransactionFailed object>
Traceback:
 Traceback (most recent call last):
   File "/usr/share/software-center/softwarecenter/backend/installbackend_impl/aptd.py", line 990, in _run_transaction
     yield trans.run(defer=True)
 TransactionFailed: <unprintable TransactionFailed object>
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Revision history for this message
Håkon Emil Olsen (hemilo) wrote :
tags: removed: need-duplicate-check
Changed in software-center (Ubuntu):
importance: Undecided → Medium
tags: added: u1-by-support
Revision history for this message
Sebastien Bacher (seb128) wrote :

Hey Rodney, any chance you could look at this one? It's ranking quite high on errors.ubuntu.com with 249 reports on the daily score

information type: Private → Public
Changed in software-center (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
importance: Medium → High
status: New → Confirmed
Revision history for this message
nick p. (jjpris) wrote :

hey , I got this message when I was trying to install wine1.5 and .4 so i could instal playonlinux. I hope this helps. If not, let me know <email address hidden>

wine1.5: PreDepends: dpkg (>= 1.15.7.2~) but 1.16.10ubuntu1 is to be installed
         Depends: libc6 (>= 2.14) but 2.17-0ubuntu4 is to be installed
         Depends: wine1.5-amd64 (= 1.5.27-0ubuntu1) but 1.5.27-0ubuntu1 is to be installed
         Depends: wine1.5-i386 (= 1.5.27-0ubuntu1) but it is not going to be installed

Julien Funk (jaboing) on 2013-04-10
Changed in software-center:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Rodney Dawes (dobey)
Revision history for this message
Charlie Callow (wollac11) wrote :

I get this error while trying to install stormcloud (which I had previously purchased and used on 12.10) from the Ubuntu software centre on a clean install of Ubuntu 13.04 beta 2.

Revision history for this message
Bluppie (benhyper) wrote :

I was trying to install Xeoma.

Revision history for this message
Bluppie (benhyper) wrote :

Xeoma has broken and with beathbit I have repaird it but when I try to reinstall it the program is broken again.
Also synaptic cant repair the broken package but after bleathbit has run it is reporting that there are no broken package anymore.

Revision history for this message
Johan Melotte (jmelotte) wrote :

This error occured when I try to install Quick 'n Easy Web Builder.
The installation failed !
Please help me in trying to solve this problem.

Dave Morley (davmor2) on 2013-04-17
tags: added: u1-by-user u1-on-production
Dave Morley (davmor2) on 2013-04-17
Changed in wine:
status: New → Invalid
tags: added: saucy
Revision history for this message
Paul Homer (cedar-creek2) wrote :

It happened when I Installed LibreOffice. I got an unresolved package error. I unchecked the add on in question, then after a successful install I added it back successfully.

dobey (dobey) on 2014-01-29
Changed in software-center:
assignee: Rodney Dawes (dobey) → nobody
Changed in software-center (Ubuntu):
assignee: Rodney Dawes (dobey) → nobody
dobey (dobey) on 2014-01-29
Changed in software-center (Ubuntu Raring):
assignee: Rodney Dawes (dobey) → nobody
status: Confirmed → Won't Fix
hassan (hassan6632) on 2014-02-03
Changed in software-center (Ubuntu Linaro Evaluation Build):
status: New → Incomplete
Revision history for this message
hassan (hassan6632) wrote :

PLEASE UPDATE MY UBUNTU

Revision history for this message
Reviews-10 (allan3) wrote :

Please reconfigure my OS :s

Revision history for this message
Cristobal Ortiz Ortiz (prangfamily) wrote :

this worked for me:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype

hope it helps

i am on Ubuntu X64 14.04

Revision history for this message
Takumi Yamazaki (xdddrngy2j) wrote :

Got this error trying to install Steam

Revision history for this message
Eric Goulet (eric-m-goulet) wrote :

Attempting to install Steam on Ubuntu GNOME 14.04.

Revision history for this message
Eric Goulet (eric-m-goulet) wrote :

Takumi Yamazaki (xdddrngy2j), for me, the solution was via these answers:
http://askubuntu.com/questions/257084/how-do-i-install-steam-on-a-64bit-system

This might be a dependency related issue.

Revision history for this message
David Nelson (commerce) wrote :

I was trying to install Banshee through the Ubuntu Software Center. I selected all the addons and clicked on the 'Update settings' (or something similar to that wording, can't remember exactly). Got an unmet-dependencies error. When, instead, I clicked on the Install button (to install the main Banshee application), everything went fine.

Revision history for this message
Veldkornet (veldkornet) wrote :

Attempting to install Steam on 140.04

Revision history for this message
David Pearson (akxwi-dave) wrote :

As above I was trying to install Steam via Software centre

Revision history for this message
Pedro Henrique Moreira Caldeira (pdrocaldeira) wrote :

Trying to install Google Chrome at Ubuntu 14.04

Revision history for this message
Edwin Burgos (edwin-burgos101) wrote :

Hello

I made an attempt to istall steam from the Ubuntu software center when an error occurred. After doing a little research on Steam support, it states that only 12.04 with KDE, GNOME and some other are the only ones support by Steam. SO of course I must ask, due to my lack of knowledge on the matter. Does Ubuntu 14.04 have suck SDK's or packages and should I install version 12 instead?
Mot sure if this helps, and thanks for your time and effort.

Revision history for this message
David Pearson (akxwi-dave) wrote :

it may be due to 14.041 still being in beta testing stage.

if you have 14.04 installed, installing Steam via the CLI works.
open a terminal and install using "sudo apt-get install steam"

Revision history for this message
berend (berenddeboer) wrote :

I got this when installing steam. I think it complained about some jockey (?) package not available.

Revision history for this message
berend (berenddeboer) wrote :

Just saw the command-line suggestion, I get this:

The following packages have unmet dependencies:
 steam-launcher : Depends: jockey-common but it is not installable
E: Unable to correct problems, you have held broken packages.

Revision history for this message
David Pearson (akxwi-dave) wrote :

try running "sudo apt-get --fix-missing install" and then try "sudo apt-get install steam" again..

Revision history for this message
Charles B Gibby (klemorali) wrote :

Attempted to install steam-launcher from Software Center. Installed failed and prompts brought me here.

Revision history for this message
Jaufré Aligé (jaufre) wrote :

I tried to install Steam-launcher and ended here.
I tried again and here is the next error (translated by me because it was in french) :
steam-launcher: Depends: jockey-common but will not be installed
Depends: libc6 (>= 2.15) but the version 2.19-0ubuntu4 will be installed

looks like some dependencies missing.

Revision history for this message
Jaufré Aligé (jaufre) wrote :

Ok, I made it work by :
wget http://fr.archive.ubuntu.com/ubuntu/pool/universe/j/jockey/jockey-common_0.9.7-0ubuntu15_all.deb
sudo dpkg -i jockey-common_0.9.7-0ubuntu15_all.deb
sudo apt-get update && sudo apt-get install steam-launcher -y
steam
(Don't use the new link in the bar. Remove it and launch it from the dash then pin it or it crashes)

Revision history for this message
dominique desforges (dominiquedesforges69) wrote :

frezzing on drivers nvidia install

Revision history for this message
Bryan G. Jensen (ki-ubuntu) wrote :

Fresh install of Xubuntu 14.04, was trying to install Screensaver Control directly from the Software Center. The only thing I did between the fresh install of Xubuntu 14.04 and the attempted install was run the Software Updater and reboot as prompted.

Revision history for this message
Bryan G. Jensen (ki-ubuntu) wrote :

The following packages have unmet dependencies:

screensaver-settings: Depends: libc6 (>= 2.2.5) but 2.19-0ubuntu6 is to be installed
                      Depends: libgcc1 (>= 1:4.1.1) but 1:4.9-20140406-0ubuntu1 is to be installed
                      Depends: libpulse0 (>= 1:0.99.1) but 1:4.0-0ubuntu11 is to be installed
                      Depends: libqt5core5 (>= 5.0.1+dfsg) but it is not going to be installed
                      Depends: libqt5dbus5 (>= 5.0.1+dfsg) but 5.2.1+dfsg-1ubuntu14 is to be installed
                      Depends: libqt5gui5 (>= 5.0.1+dfsg) but 5.2.1+dfsg-1ubuntu14 is to be installed
                      Depends: libqt5widgets5 (>= 5.0.1+dfsg) but 5.2.1+dfsg-1ubuntu14 is to be installed
                      Depends: libstdc++6 (>= 4.1.1) but 4.8.2-19ubuntu1 is to be installed
                      Depends: screensaver-control but it is not going to be installed

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

This report was set by accident of a user set to incomplete. Ubuntu 14.04 is also affected.

Changed in software-center (Ubuntu Linaro Evaluation Build):
status: Incomplete → Confirmed
tags: added: trusty
Leon TYLER (leon212012) on 2014-07-28
Changed in software-center (Ubuntu):
assignee: nobody → Leon TYLER (leon212012)
assignee: Leon TYLER (leon212012) → nobody
tags: added: vivid
Revision history for this message
Andriopoulos Nikolaos (sirnicolas21) wrote :

15.04 cannot install ubuntu sdk also.

Revision history for this message
frank mahler (crmhound) wrote :

15.04 Vivid
Was installing Maps, and subsequently Tribler. Hit me both times.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-smartdimmer (Ubuntu Raring):
status: New → Confirmed
Changed in gnome-smartdimmer (Ubuntu):
status: New → Confirmed
Changed in gnome-smartdimmer (Ubuntu):
importance: Undecided → High
Changed in gnome-smartdimmer (Ubuntu Raring):
importance: Undecided → High
no longer affects: software-center (Ubuntu Raring)
no longer affects: gnome-smartdimmer (Ubuntu Raring)
Revision history for this message
frank mahler (crmhound) wrote :

trying to install tribler.

fail

Revision history for this message
Chris Bainbridge (chris-bainbridge) wrote :

This is not a real bug report. The issue is that when a package is not installable (e.g. dependencies conflict etc.) a crash report is automatically created. It is not a real crash, and arguably should not be treated as a crash.

If you do get this "crash" and were brought to this bug report, and want to see what the actual problem is, then open a terminal and do `sudo apt-get install xxxx` where xxxx is the name of the package you want to install. The output of apt-get will show you the real problem.

Changed in software-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-smartdimmer (Ubuntu):
status: Confirmed → Triaged
hendyawan (whiindy) on 2015-11-01
affects: software-center → cute-software-center
Revision history for this message
Gordon Petts (gonzo69) wrote :

fix authenticate. once and for all

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers