arm64 support to generate linux-source for crosstool bulds

Bug #1063895 reported by Wookey
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Andy Whitcroft
linux (Ubuntu Linaro Evaluation Build)
Undecided
christopher wayne hess

Bug Description

[Not sure If I've filed this aginst the right package. It should be linux-3.5.0, but that doesn't exist according to launchpad. ]

Attached is a first-cut patch adding arm64 support to the linux-3.5.0 package so that it builds linux-source packages which can be used to build cross tools against. The arm64 support is just the core stuff so isn't much use for making binaries. It's also an unholy backport of 3.6/3.7 vintage stuff to 3.5 so it probably bust in important ways. However that's not relevant for the primiary purpose here of building cross-tools, which just needs a correct set of headers in linux-libc-dev, and arch/package machinery in linux-source.

I'm not expecting this to be uploaded but wanted to put it somewhere public for anyone else to build with.

Revision history for this message
Wookey (wookey) wrote :
tags: added: patch
Revision history for this message
Brad Figg (brad-figg) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 1063895

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Wookey (wookey) wrote :

Logs not relevant to packaging/new arch update.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Opinion
Revision history for this message
Andy Whitcroft (apw) wrote :

If this is happening against raring, then we only need the debian.master changes. Will handle.

Changed in linux (Ubuntu):
status: Opinion → In Progress
assignee: nobody → Andy Whitcroft (apw)
Revision history for this message
dann frazier (dannf) wrote :

We've had an arm64 kernel throughout the 14.04 cycle, so moving to fix-released.

Changed in linux (Ubuntu):
status: In Progress → Fix Released
Changed in linux (Ubuntu Linaro Evaluation Build):
assignee: nobody → christopher wayne hess (hess8519)
Changed in linux (Ubuntu Linaro Evaluation Build):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers