[Keyboard] No way to understand which layout is selected

Bug #1428146 reported by Riccardo Padovani on 2015-03-04
48
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu UX
High
Rae Shambrook
ubuntu-keyboard
Confirmed
Medium
Michael Sheldon
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

I have both english and italian layout activated on my keyboard.

Everytime I start to write a message I don't know which layout is selected because layouts are the same.
There should be a clear indication, like it or en on the space bar, so user knows which layout is selected before starting to write

[UPDATE]

Discussed this last week with Mike and Rae, we will remove the language button and add current language to space bar (changeable with long press). Rae will provide the visual

--------------------------------------

Visuals updated with language on the spacebar https://docs.google.com/presentation/d/16rPezaXSWqQlh0JeGq7A3LXOBA_EZpA1cE52EEAkIxI/edit#slide=id.gc39169429_0_76

Related branches

summary: - No way to understand which layout is selected
+ [Keyboard] No way to understand which layout is selected
Changed in ubuntu-ux:
assignee: nobody → Magdalena Mirowicz (magdalena-mirowicz)
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → High
assignee: Magdalena Mirowicz (magdalena-mirowicz) → nobody
assignee: nobody → Alex Milazzo (digitalalex)
Changed in ubuntu-ux:
assignee: Alex Milazzo (digitalalex) → Jouni Helminen (jounihelminen)
Changed in ubuntu-keyboard:
status: New → Confirmed
Matthew Paul Thomas (mpt) wrote :

The appearance of the layout button was not specified in detail originally. <http://goo.gl/IjLpHs> It was described vaguely as a "button labelled with current language or an icon indicator" (well, which?), and shown as "ENG" in a wireframe. ("ENG" isn't a keyboard layout; English has multiple keyboard layouts.) This error wasn't caught when the spec was reviewed, either.

Meanwhile, Simon Xenitellis on ubuntu-devel-discuss@ has made a couple of mockups of how the layout might be shown, but they're a bit cramped. <https://i.imgur.com/3468iBV.png> <https://i.imgur.com/x3CAvpm.png> Solving the problem solely with the layout button would involve two competing needs: communicating the current layout, and making the button easily findable across layouts. For example, many emoji and currency symbols involve a combination of letter-like symbols, which could make the layout switcher hard to find if it showed just the code of the current layout. Conversely, the U+1F310 emoji is quite similar to the current globe image on the button.

themeles (themeles) wrote :

Regarding to the different keyboard layouts in one language: Is there anybody who has more than one keyboard layout for one and the same language?

It's obvious that people (as I do aswell) use different languages but different layouts in one language, doesn't make to much sence in my opinion.

Jouni Helminen (jounihelminen) wrote :

Will explore showing the current language on the space bar, like Android does

Changed in ubuntu-ux:
status: Triaged → In Progress
Jouni Helminen (jounihelminen) wrote :

Would suggest doing this - display current language on the space bar. Long pressing the space bar could give the same language selector as pressing the language selector button (when it's available)

Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
Changed in ubuntu-ux:
status: In Progress → Fix Committed

If we're making the language switcher available via a long press on the space bar is it worth considering removing the language button altogether? That would free up some space on the bottom row which can be a bit crowded for some languages (especially in the URL layouts), resulting in quite a small space bar.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Changed in ubuntu-keyboard:
importance: Undecided → Medium
Jouni Helminen (jounihelminen) wrote :

Discussed this last week with Mike and Rae, we will remove the language button and add current language to space bar (changeable with long press). Rae will provide the visual

Changed in ubuntu-ux:
assignee: Jouni Helminen (jounihelminen) → nobody
assignee: nobody → Rae Shambrook (raecontreras)
description: updated
Changed in ubuntu-ux:
status: Fix Committed → In Progress
description: updated
Changed in ubuntu-ux:
status: In Progress → Fix Committed
description: updated
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww04-2016
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+16.04.20160128-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+16.04.20160128-0ubuntu1) xenial; urgency=medium

  [ Aron Xu ]
  * Transition from libpinyin4 to libpinyin7, no actual code change
    required.

  [ Michael Sheldon ]
  * Fix selection deletion autopilot test
  * Update keyboard visuals to match new design spec (LP: #1428146,
    #1321603, #1385431)

 -- Michael Sheldon <email address hidden> Thu, 28 Jan 2016 19:08:52 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-ux:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers