Fix auto punctuation handling on a period

Bug #1398503 reported by Pat McGowan on 2014-12-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
ubuntu-keyboard
Fix Released
High
Michael Sheldon
ubuntu-keyboard (Ubuntu)
High
Unassigned
ubuntu-keyboard (Ubuntu RTM)
High
Unassigned

Bug Description

Entering a period currently automatically appends a space. It should not, but rather wait for a space then add a second and capitalize.

As a fallback we can turn off auto punctuation as a default.

Related branches

Changed in canonical-devices-system-image:
importance: Undecided → Critical
milestone: none → ww51-2014
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) on 2014-12-03
Changed in ubuntu-keyboard (Ubuntu RTM):
importance: Undecided → High
Changed in ubuntu-keyboard:
importance: Undecided → High
tags: added: ww51
Bill Filler (bfiller) on 2014-12-03
Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
Bill Filler (bfiller) wrote :

I don't think it's a good idea to turn off these settings by default as they work pretty well. The bug that was reported complains that after inputing a "." a space is added, which is true. We should fix this bug rather than turn off the defaults. The fix would be to not automatically add a space (and capitialize the next letter) when typing the "." but only do so after in the following cases:
1) typing "." then pressing the space bar would add a space and turn on the shift key
2) double tapping the space bar with the auto punctation setting turned on would add the ".", a space, and turn on the shift key

Changed in canonical-devices-system-image:
status: Confirmed → New
summary: - Turn auto correction and auto punctuation off by default
+ Fix auto punctuation handling on a period
description: updated
Changed in canonical-devices-system-image:
status: New → Confirmed
Victor Tuson Palau (vtuson) wrote :

the problem is that it is not intuitive enough to be turn on by default IMHO

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20141209-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20141209-0ubuntu1) vivid; urgency=low

  [ Michael Sheldon ]
  * Disables automatic insertion of space characters after punctuation
    except when punctuation has been added by double space. (LP:
    #1398503)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 09 Dec 2014 15:37:46 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20141209~rtm-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20141209~rtm-0ubuntu1) 14.09; urgency=low

  [ Michael Sheldon ]
  * Disables automatic insertion of space characters after punctuation
    except when punctuation has been added by double space. (LP:
    #1398503)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 09 Dec 2014 21:03:34 +0000

Changed in ubuntu-keyboard (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in ubuntu-keyboard:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers