words with apostrophes are not suggested by prediction

Bug #1384800 reported by Bill Filler
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-keyboard
Fix Released
High
Michael Sheldon
presage (Ubuntu)
Undecided
Michael Sheldon
presage (Ubuntu RTM)
Undecided
Unassigned
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned
ubuntu-keyboard (Ubuntu RTM)
Undecided
Unassigned

Bug Description

The current word prediction does not suggest or correct words like "we'll", "it's" "they're" etc.

The expected behavior is if I typed "its" it should be autocorrected to "it's" and similar for other common words.

Related branches

Bill Filler (bfiller)
Changed in ubuntu-keyboard:
importance: Undecided → High
status: New → In Progress
assignee: nobody → Michael Sheldon (michael-sheldon)
tags: added: rtm14
Revision history for this message
Olli Ries (ories) wrote :

please fix _after_ RTM in an OTA

tags: added: ota-future
Changed in presage (Ubuntu):
assignee: nobody → Michael Sheldon (michael-sheldon)
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package presage - 0.9-1ubuntu2

---------------
presage (0.9-1ubuntu2) vivid; urgency=medium

  * debian/patches/dont-tokenize-on-apostrophes.patch:
    - Allow words with apostrophes to be predicted (lp: #1384800)
 -- Michael Sheldon <email address hidden> Wed, 04 Feb 2015 10:16:01 +0100

Changed in presage (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20150209-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150209-0ubuntu1) vivid; urgency=medium

  [ Michael Sheldon ]
  * Add contractions as overrides (I've, you've, I'm, etc.). (LP:
    #1416020)
  * Recreate prediction databases with apostrophe support and remove
    Gutenberg license text from sample data. (LP: #1384800)
  * Always display the language button, even when only one language is
    enabled (so settings is easily accessible) and modify language
    button behaviour to toggle between most recently used layouts when
    tapped and to only show the menu when long pressed. (LP: #1417048,
    #1416037, #1416157)

  [ CI Train Bot ]
  * Resync trunk

  [ Michael Terry ]
  * Add em dash, en dash, and the bullet as extended hyphen options.
    (LP: #1414763)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Bill Filler ]
  * enable emoji by default (LP: #1416036)

  [ Penk Chen ]
  * Add mechanism for pure QML layouts to provide suggestion candidates.

  [ Mike Sheldon ]
  * Recreate prediction databases with apostrophe support and remove
    Gutenberg license text from sample data. (LP: #1384800)
 -- Ubuntu daily release <email address hidden> Mon, 09 Feb 2015 21:15:02 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package presage - 0.9~rtm-1ubuntu2

---------------
presage (0.9~rtm-1ubuntu2) 14.09; urgency=medium

  * debian/patches/dont-tokenize-on-apostrophes.patch:
    - Allow words with apostrophes to be predicted (lp: #1384800)

presage (0.9-1ubuntu1) vivid; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - debian/patches/lib_underlinkage.patch:
      + Added missing lib to link, fixing FTBFS. (Closes: #776720)
  * Drop following patches, fixed upstream:
    - debian/patches/automake-parallel.patch
    - debian/patches/no-automake-werror.patch

presage (0.9-1) unstable; urgency=medium

  * New upstream release.
  * Use dh-autoreconf to fix FTBFS on ppc64el. Closes: #756518
  * Fix regression introduced with upgrade to wxPython3.0. Closes: #758499
  * Fix out-of-date-standards-version lintian warning.
  * Convert libpresage1, libpresage1-dbg, libpresage-data, and
    libpresage-dev binary packages to multiarch. Closes: #728979

presage (0.8.9-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * Update for wxPython3.0 (Closes: #758499):
    + New patch: wxpy3.0-compat.patch

presage (0.8.9-1) unstable; urgency=low

  * New upstream release.
  * Fix FTBFS caused by changes in GTK and Glibc. Closes: #713617
  * Fix out-of-date-standards-version lintian warning.
  * Added missing build dependency.
 -- Michael Sheldon <email address hidden> Wed, 04 Feb 2015 10:16:01 +0100

Changed in presage (Ubuntu RTM):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20150213.2~rtm-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150213.2~rtm-0ubuntu1) 14.09; urgency=medium

  [ CI Train Bot ]
  * Resync trunk
  * New rebuild forced.

  [ Michael Sheldon ]
  * Add a brief delay before evaluating swipes (LP: #1421742)

ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150213-0ubuntu1) vivid; urgency=medium

  [ CI Train Bot ]
  * Resync trunk
  * New rebuild forced.

  [ Michael Sheldon ]
  * Fix memory leak when unloading word engines (LP: #1420891)

ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150209-0ubuntu1) vivid; urgency=medium

  [ Michael Sheldon ]
  * Add contractions as overrides (I've, you've, I'm, etc.). (LP:
    #1416020)
  * Recreate prediction databases with apostrophe support and remove
    Gutenberg license text from sample data. (LP: #1384800)
  * Always display the language button, even when only one language is
    enabled (so settings is easily accessible) and modify language
    button behaviour to toggle between most recently used layouts when
    tapped and to only show the menu when long pressed. (LP: #1417048,
    #1416037, #1416157)

  [ CI Train Bot ]
  * Resync trunk

  [ Michael Terry ]
  * Add em dash, en dash, and the bullet as extended hyphen options.
    (LP: #1414763)

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Bill Filler ]
  * enable emoji by default (LP: #1416036)

  [ Penk Chen ]
  * Add mechanism for pure QML layouts to provide suggestion candidates.

  [ Mike Sheldon ]
  * Recreate prediction databases with apostrophe support and remove
    Gutenberg license text from sample data. (LP: #1384800)

ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150202-0ubuntu1) vivid; urgency=medium

  [ Michael Sheldon ]
  * Enable auto-punctuation for Pinyin input. (LP: #1407588)
  * Speed up autopilot tests by only restarting maliit-server at the
    beginning and end of all tests
  * Restore a user's original input if they press backspace immediately
    after auto-completing a word. (LP: #1411645)
  * Allow Emoji keyboard to be shown for URL and email field types and
    switch out of Emoji layout when changing fields. (LP: #1415129,
    #1415127)
  * Adds a setting to allow the keyboard to remain hidden at all times
    (e.g. when a hardware keyboard is connected) (LP: #1415126)
  * Fix autocaps for clients that send multiline surrounding text (LP:
    #1415881)

  [ Ubuntu daily release ]
  * New rebuild forced

ubuntu-keyboard (0.99.trunk.phablet2+15.04.20150119-0ubuntu1) vivid; urgency=low

  [ Michael Sheldon ]
  * Deactivate autocaps if we receive find out we're in a field that
    doesn't support it after having already entered the field (LP:
    #1412460)
  * Add dependencies for any keyboard layouts used in autopilot tests
 -- CI Train Bot <email address hidden> Fri, 13 Feb 2015 20:33:15 +0000

Changed in ubuntu-keyboard (Ubuntu RTM):
status: New → Fix Released
Changed in ubuntu-keyboard:
status: In Progress → Fix Released
Bill Filler (bfiller)
tags: added: ww09
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers