Can't use pinyin for Chinese in browser URL bar due to Qt.ImhUrlCharactersOnly

Bug #1335007 reported by Christian Dywan on 2014-06-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
ubuntu-keyboard
Fix Released
High
Michael Sheldon
ubuntu-keyboard (Ubuntu)
High
Michael Sheldon
ubuntu-keyboard (Ubuntu RTM)
Undecided
Unassigned

Bug Description

With Chinese pinyin input method enabled, open the browser, tap the URL bar/ search bar, type "n" and "i". You should see "你" as a word prediction. In fact no words show up.

Related branches

Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
Bill Filler (bfiller) on 2014-07-31
Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Michael Sheldon (michael-sheldon)
tags: added: rtm14
Bill Filler (bfiller) on 2014-09-08
tags: added: 20014-09-25
Bill Filler (bfiller) on 2014-09-08
tags: added: touch-2014-09-25
removed: 20014-09-25
tags: added: ota-1
removed: touch-2014-09-25
Rex Tsai (chihchun) wrote :

Is this a expected behavior ? Any input component with ImhUrlCharactersOnly hint should not allowed to input Chinese.

I think this is valid, non-latin characters can be used in URLs via the internationalised domain name standard: http://en.wikipedia.org/wiki/Internationalized_domain_name (they should get converted to a latin encoding by the browser, so we might need browser changes for this as well, haven't checked yet what's implemented there). Plus the browser URL bar works as a search bar, so it should be possible for people to search for things in Chinese.

Rex Tsai (chihchun) wrote :

I agree to in order to support Internationalized domain name and search function, the url bar need to accept non-Latin characters.

Should this bug be fixed from the browser by removing ImhUrlCharactersOnly hint?

Did a bit of testing and the browser does handle non-latin characters correctly once they're entered, so I think the fix should be in the keyboard since Chinese characters are URL characters and we can already input Arabic characters in this mode, plus the URL characters hint is what allows the keyboard to display the URL layout with .com/.cn/etc. keys. Working on a fix for this from the keyboard side now.

Changed in ubuntu-keyboard:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+15.04.20141202-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+15.04.20141202-0ubuntu1) vivid; urgency=low

  [ Michael Sheldon ]
  * Fix old autopilot tests and implement some new ones.
  * Allow Pinyin to be used in URL and email fields and fix text
    selection issues. (LP: #1393492, #1335007)
  * Add ".com" as extended key on URL and email layouts for all language
    that don't have it as their primary URL key (LP: #1369510)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 02 Dec 2014 19:25:25 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Bill Filler (bfiller) on 2014-12-19
tags: added: ww03
Bill Filler (bfiller) on 2015-01-17
tags: added: ww05
removed: ww03
Bill Filler (bfiller) on 2015-01-21
Changed in ubuntu-keyboard (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
milestone: none → ww05-2015
status: New → Fix Released
Changed in ubuntu-keyboard:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers