cant' swipe the keyboard away anymore

Bug #1332624 reported by Bill Filler on 2014-06-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard
Fix Released
Critical
Michael Sheldon
unity-mir
Critical
Alexandros Frantzis
ubuntu-keyboard (Ubuntu)
Undecided
Unassigned
unity-mir (Ubuntu)
Undecided
Unassigned

Bug Description

on image 91, with qt5.3
Can no longer swipe the keyboard from the top to make it disappear anymore. This seems to break after the upgrade to Qt5.3.

Note, similar problem occurred when switching from Qt5.1->Qt5.2
https://bugs.launchpad.net/ubuntu/+source/ubuntu-keyboard/+bug/1277186

Need to revist the changes made there, but on initial testing reverting those changes did not help the problem

Related branches

Bill Filler (bfiller) on 2014-06-20
tags: added: qt5.3
Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Julien Funk (jaboing) wrote :

Can we ensure that a fix for this comes with a new test please? Especially since this regression has affected us in the past.

Seems to be related to the reported keyboard geometry being slightly too short (and so cutting off the MouseArea that handles swiping down); will test with a pre-5.3 image tomorrow to see if the reported geometry has actually changed or whether the interpretation of that geometry elsewhere in the system is possibly at fault.

Turns out this is unrelated to the upgrade to Qt 5.3, this issue can be reproduced in image #89. It appears to be the same underlying cause as bug 1332632, the keyboard requests a geometry of 768x1280, but with the version of Mir/unity-system-compositor(?) introduced in image #90 it gets resized to 768x1222. This results in the conversion made from the keyboard co-ordinate system to the screen co-ordinates being off by 58 pixels, cutting off the top of the keyboard and sending touch events through to the app underneath the top of the keyboard. This also results in it being impossible to press items in the word ribbon when it is enabled.

I would guess that the 58 pixel discrepancy is coming from Mir or the compositor resizing the window to account for the toolbar, but I'm not sure this should happen when an app either sets fullscreen mode or explicitly sets its own geometry (at least this doesn't seem to have been the behaviour in the past).

I'll see if we can work around this in Keyboard for now (possibly by passing in the actual screen geometry and account for any discrepancy).

Sorry, above should say 'introduced in image #89', not image #90.

It seems that in image #88 we also received a height of 1222 but swiping worked, so I don't know if maybe Mir was previously doing something internally that accounted for the top bar when setting the input region, which it's no longer doing? Either way the issue was definitely introduced in image #89, and the upgrade to Mir 0.3 would seem the most likely area to focus on.

kevin gunn (kgunn72) wrote :

assigning alf for mir. he actually worked on it his entire day today, although I don't think he found anything conclusive

Changed in mir:
assignee: nobody → Alexandros Frantzis (afrantzis)
kevin gunn (kgunn72) wrote :

ok, after some wrangling & fully verifying. I did flash image #88....and then took the latest mir along with unity-mir, platform-api, unity-system-compositor into the build
And the problem does occur so there's definitely something that change in the mir/unity-mir/platform-api stack to effect this.

Olivier Tilloy (osomon) on 2014-06-27
Changed in ubuntu-keyboard:
status: New → In Progress
Changed in mir:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.10.20140626-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.10.20140626-0ubuntu1) utopic; urgency=low

  [ Michael Sheldon ]
  * Handle any discrepancy between keyboard's fullScreenItem size and
    the real screen size (e.g. caused by the shell's top bar) (LP:
    #1332624)
 -- Ubuntu daily release <email address hidden> Thu, 26 Jun 2014 16:55:34 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
Changed in mir:
status: Confirmed → Invalid
no longer affects: mir
Changed in unity-mir:
status: New → In Progress
assignee: nobody → Alexandros Frantzis (afrantzis)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-mir - 0.4+14.10.20140701.1-0ubuntu1

---------------
unity-mir (0.4+14.10.20140701.1-0ubuntu1) utopic; urgency=low

  [ Alexandros Frantzis ]
  * Use surface relative coordinates when setting the input region for
    the input area Mir changed at some point to use surface relative
    coordinates for input regions. (LP: #1332624)

  [ Gerry Boland ]
  * Bump Mir dependencies to 0.4.0.

  [ Cemil Azizoglu ]
  * Bump Mir dependencies to 0.4.0.

  [ Alberto Aguirre ]
  * Bump Mir dependencies to 0.4.0.
 -- Ubuntu daily release <email address hidden> Tue, 01 Jul 2014 14:19:04 +0000

Changed in unity-mir (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2014-07-03
Changed in unity-mir:
status: In Progress → Fix Released
Changed in ubuntu-keyboard:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers