osk displayed on top of shell components

Bug #1323850 reported by Bill Filler on 2014-05-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-keyboard
Fix Released
High
Unassigned
unity-mir
High
Unassigned
unity8 (Ubuntu)
High
Unassigned

Bug Description

The OSK is displayed on top of certain shell elements. It should either be beneath the shell elements or hidden when displaying those elements.

For example:

- launch multiple apps that take text input
- go to one of the apps and click in input field to bring up OSK
- pull in the launcher from the left edge - it's displayed behind the OSK. Should be behind or first call QtInputMethod.hide() to force osk to hide
- long right edge swipe will bring in the app switcher carousel and this is behind the OSK
- pulling down the indicator bar will be displayed behind the OSK

This came up during the sprint as a usability issue that needs to be addressed for rtm

Related branches

Bill Filler (bfiller) on 2014-05-27
Changed in unity-mir:
importance: Undecided → High
Changed in ubuntu-keyboard:
importance: Undecided → High
Changed in unity8:
importance: Undecided → High
tags: added: rtm14
Changed in ubuntu-keyboard:
status: New → Confirmed
Michał Sawicz (saviq) wrote :

Feels like this is a dupe of bug #1210200

Changed in unity8:
status: New → In Progress
Changed in unity-mir:
status: New → In Progress
Michał Sawicz (saviq) on 2014-08-04
Changed in unity8:
status: In Progress → Fix Released
Changed in unity-mir:
status: In Progress → Won't Fix

All these actions cause the keyboard to close now.

Changed in ubuntu-keyboard:
status: Confirmed → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: unity8 → unity8 (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers