[OSK]holding the back button should remove the text quickly

Reported by Omer Akram on 2013-07-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Rachel Liu
touch-preview-images
Undecided
Unassigned
ubuntu-keyboard
Wishlist
Günter Schwann
ubuntu-keyboard (Ubuntu)
Wishlist
Günter Schwann

Bug Description

1. type some text into the notes-app
2. press and hold the back button on the On Screen Keyboard

What happens:
the text is removed slowly, once by one.

What should happen:
the removal of text should accelerate depending on the time back button is held down.

--------------------------------------------------------

Refer to: https://docs.google.com/a/canonical.com/document/d/1UunhUqLkUiAhsy9iu_Pu3Sn6jUTCn3d7E8WxkfT6ZVQ/edit# for the design spec

Desired solution:
- Backspace to delete one character at a time. When you long-press, it clears word by word.

Related branches

lp:~schwann/ubuntu-keyboard/keyboard-delete-words
Merged into lp:ubuntu-keyboard at revision 84
Thomas Moenicke (community): Approve on 2013-10-24
PS Jenkins bot: Approve (continuous-integration) on 2013-10-24
Omer Akram (om26er) on 2013-07-16
summary: - holding the back button on OSK should remove the text quickly
+ [OSK]holding the back button should remove the text quickly
John Lea (johnlea) on 2013-09-09
Changed in ubuntu-ux:
assignee: nobody → Rachel Liu (rachelliu)
Rachel Liu (rachelliu) wrote :

On the design spec, we want to delete it word by word as the acceleration when you long-press on the backspace.

description: updated
description: updated
Changed in ubuntu-ux:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Bill Filler (bfiller) on 2013-09-25
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → Wishlist
Changed in ubuntu-keyboard:
importance: Undecided → Wishlist
assignee: nobody → Günter Schwann (schwann)
Changed in ubuntu-keyboard (Ubuntu):
assignee: nobody → Günter Schwann (schwann)
Changed in ubuntu-keyboard:
status: New → Confirmed
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-keyboard at revision 84, scheduled for release in ubuntu-keyboard, milestone Unknown

Changed in ubuntu-keyboard:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-keyboard - 0.99.trunk.phablet2+14.04.20131025-0ubuntu1

---------------
ubuntu-keyboard (0.99.trunk.phablet2+14.04.20131025-0ubuntu1) trusty; urgency=low

  [ Daniel d'Andrada ]
  * ubuntu-keyboard-info socket now reports the keyboard's scene
    geometry That's enough to cover keyboard rotations and animations.
    (LP: #1236489)

  [ Thomas Moenicke ]
  * adding key to change language.

  [ Leo Arias ]
  * Prepare for the release of autopilot 1.4 adding the dependency on an
    earlier release.

  [ Christopher Lee ]
  * Minor update/fixes for the autopilot emulators.

  [ Guenter Schwann ]
  * Keep url and @ key unchanged in shiftet state. (LP: #1240603)
  * Keep removing text when keeping the backspace key pressed.
  * Disable auto capitalization for any other content type than
    FreeTextContentType Wieth auto capitalizatin start with a capital on
    empty text fields.
  * After holding the backspace for a while, remove whole words. (LP:
    #1201988)
  * Reorganize tests let "make check" pass.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1234685, #1214695)
  * Revert last 2 commit because of language issues.
  * Decouple autocaps from predictive text fixes LP: #1214695. (LP:
    #1214695)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 91
 -- Ubuntu daily release <email address hidden> Fri, 25 Oct 2013 11:04:48 +0000

Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers