ubuntu_kernel_selftests ftrace fails on arm64 F / aws-5.8 / amd64 F azure-5.8

Bug #1927749 reported by Krzysztof Kozlowski
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Krzysztof Kozlowski
linux (Ubuntu)
Medium
Krzysztof Kozlowski
Focal
Medium
Unassigned
Groovy
Medium
Unassigned
Hirsute
Medium
Unassigned
Impish
Medium
Krzysztof Kozlowski
linux-aws (Ubuntu)
Focal
Undecided
Krzysztof Kozlowski
Groovy
Undecided
Krzysztof Kozlowski
Hirsute
Undecided
Krzysztof Kozlowski
Impish
Undecided
Krzysztof Kozlowski

Bug Description

[Impact]

arm64 only focal/aws 5.8.0-1031.33~20.04.1-aws and 5.8.0-1032.34~20.04.1-aws - regression. Works fine on previous Focal cycle (5.8.0-1028.30~20.04.3-aws) and current Groovy 5.8.

12. 05/06 07:01:39 DEBUG| utils:0153| [stdout] TAP version 13
13. 05/06 07:01:39 DEBUG| utils:0153| [stdout] 1..1
14. 05/06 07:01:39 DEBUG| utils:0153| [stdout] # selftests: ftrace: ftracetest
15. 05/06 07:01:39 DEBUG| utils:0153| [stdout] # === Ftrace unit tests ===
16. 05/06 07:01:39 DEBUG| utils:0153| [stdout] # [1] Basic trace file check [PASS]
17. 05/06 07:01:41 DEBUG| utils:0153| [stdout] # [2] Basic test for tracers [PASS]
18. 05/06 07:01:41 DEBUG| utils:0153| [stdout] # [3] Basic trace clock test [PASS]
19. 05/06 07:01:41 DEBUG| utils:0153| [stdout] # [4] Basic event tracing check [PASS]
20. 05/06 07:01:42 DEBUG| utils:0153| [stdout] # [5] Change the ringbuffer size [PASS]
21. 05/06 07:01:42 DEBUG| utils:0153| [stdout] # [6] Snapshot and tracing setting [PASS]
22. 05/06 07:01:42 DEBUG| utils:0153| [stdout] # [7] trace_pipe and trace_marker [PASS]
23. 05/06 07:01:42 DEBUG| utils:0153| [stdout] # [8] Test ftrace direct functions against tracers [UNRESOLVED]
24. 05/06 07:01:43 DEBUG| utils:0153| [stdout] # [9] Test ftrace direct functions against kprobes [UNRESOLVED]
25. 05/06 07:01:43 DEBUG| utils:0153| [stdout] # [10] Generic dynamic event - add/remove kprobe events [PASS]
26. 05/06 07:01:43 DEBUG| utils:0153| [stdout] # [11] Generic dynamic event - add/remove synthetic events [PASS]
27. 05/06 07:01:44 DEBUG| utils:0153| [stdout] # [12] Generic dynamic event - selective clear (compatibility) [PASS]
28. 05/06 07:01:44 DEBUG| utils:0153| [stdout] # [13] Generic dynamic event - generic clear event [PASS]
29. 05/06 07:01:44 DEBUG| utils:0153| [stdout] # [14] event tracing - enable/disable with event level files [PASS]
30. 05/06 07:01:45 DEBUG| utils:0153| [stdout] # [15] event tracing - restricts events based on pid notrace filtering [FAIL]
31. 05/06 07:01:45 DEBUG| utils:0153| [stdout] # [16] event tracing - restricts events based on pid [PASS]
32. 05/06 07:01:45 DEBUG| utils:0153| [stdout] # [17] event tracing - enable/disable with subsystem level files [PASS]
33. 05/06 07:01:46 DEBUG| utils:0153| [stdout] # [18] event tracing - enable/disable with top level files [PASS]

[Test Plan]

 * Run ftrace test from kernel selftests.

[Where problems could occur]

 * Only kernel selftests should be affected.
 * ftrace test can have false positives or negatives.

Revision history for this message
Krzysztof Kozlowski (krzk) wrote :
tags: added: 5.8 aws focal sru-20210412
tags: added: arm64
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Found failing on two hosts for f/aws-5.8:

a1.medium (arm64) - passed on a retrigger, though when the test was ran again (rerun #4), ftracetest once again failed. Seems to be intermittent.

t2.small (amd64) - So far is consistently failing here. Didn't find to be failing on any other amd64 hosts.

Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Ian was able to get ftrace to pass on t2.small. It took a few tries, though at least shows that it is flaky there as well.

Po-Hsu Lin (cypressyew)
tags: added: ubuntu-kernel-selftests
Revision history for this message
Krzysztof Kozlowski (krzk) wrote (last edit ):

Found on focal/azure-5.8: 5.8.0-1033.35~20.04.1 and 5.8.0-1034.36~20.04.1 on Azure Standard_B1ms. Passes on other (bigger) instance types.

tags: added: amd64 azure sru-20210531
summary: - ubuntu_kernel_selftests ftrace fails on arm64 F / aws-5.8
+ ubuntu_kernel_selftests ftrace fails on arm64 F / aws-5.8 / amd64 F
+ azure-5.8
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

On Azure Standard_B1ms with focal/5.8.0-1033-azure reproduced only sometimes. Also sometimes similar failure appears with testcase [87] (not [15] as reported here):

[87] (instance) event tracing - restricts events based on pid notrace filtering [FAIL]

Changed in ubuntu-kernel-tests:
assignee: nobody → Krzysztof Kozlowski (krzk)
status: New → In Progress
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Sent patch upstream: https://lore.kernel<email address hidden>/T/#u
SRU needed for Focal+.

description: updated
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Fix accepted in mainline. Sent SRU.

Stefan Bader (smb)
Changed in linux (Ubuntu Focal):
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Groovy):
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Hirsute):
importance: Undecided → Medium
status: New → In Progress
Changed in linux (Ubuntu Impish):
importance: Undecided → Medium
status: New → In Progress
Stefan Bader (smb)
Changed in linux (Ubuntu Focal):
status: In Progress → Triaged
Stefan Bader (smb)
Changed in linux (Ubuntu Focal):
status: Triaged → Invalid
no longer affects: linux-aws (Ubuntu)
Changed in linux (Ubuntu Groovy):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Hirsute):
status: In Progress → Fix Committed
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-hirsute' to 'verification-done-hirsute'. If the problem still exists, change the tag 'verification-needed-hirsute' to 'verification-failed-hirsute'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-hirsute
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote :

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-focal' to 'verification-done-focal'. If the problem still exists, change the tag 'verification-needed-focal' to 'verification-failed-focal'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-focal
Changed in linux (Ubuntu Impish):
status: In Progress → Fix Released
Changed in ubuntu-kernel-tests:
status: In Progress → Invalid
Changed in linux (Ubuntu Groovy):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Impish):
assignee: nobody → Krzysztof Kozlowski (krzk)
Changed in linux-aws (Ubuntu Focal):
assignee: nobody → Krzysztof Kozlowski (krzk)
status: New → Fix Released
Changed in linux-aws (Ubuntu Groovy):
assignee: nobody → Krzysztof Kozlowski (krzk)
status: New → Fix Committed
Changed in linux-aws (Ubuntu Hirsute):
assignee: nobody → Krzysztof Kozlowski (krzk)
status: New → Fix Released
Changed in linux-aws (Ubuntu Impish):
assignee: nobody → Krzysztof Kozlowski (krzk)
status: New → Fix Released
Changed in linux-aws (Ubuntu Groovy):
status: Fix Committed → Fix Released
Changed in linux (Ubuntu Groovy):
status: Fix Released → Won't Fix
Changed in linux-aws (Ubuntu Groovy):
status: Fix Released → Won't Fix
tags: added: verification-done-focal verification-done-hirsute
removed: verification-needed-focal verification-needed-hirsute
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers