semctl09 from ubuntu_ltp_syscalls failed on X / F-oem-5.6 / F-oracle-5.4

Bug #1910312 reported by Po-Hsu Lin
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Low
Krzysztof Kozlowski
glibc (Ubuntu)
Undecided
Unassigned

Bug Description

This is a new test case.

Test output:
 startup='Tue Jan 5 19:38:52 2021'
 tst_test.c:1261: TINFO: Timeout per run is 0h 05m 00s
 semctl09.c:67: TINFO: Test SYS_semctl syscall
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with nobody user
 semctl09.c:154: TPASS: SEM_INFO returned valid index 10 to semid 10
 semctl09.c:164: TPASS: Counted used = 1
 semctl09.c:112: TPASS: semset_cnt = 1
 semctl09.c:119: TPASS: sen_cnt = 2
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with root user
 semctl09.c:154: TPASS: SEM_INFO returned valid index 10 to semid 10
 semctl09.c:164: TPASS: Counted used = 1
 semctl09.c:112: TPASS: semset_cnt = 1
 semctl09.c:119: TPASS: sen_cnt = 2
 tst_test.c:1261: TINFO: Timeout per run is 0h 05m 00s
 semctl09.c:70: TINFO: Test libc semctl()
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with nobody user
 semctl09.c:148: TFAIL: SEM_STAT_ANY doesn't pass the buffer specified by the caller to kernel
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with root user
 semctl09.c:148: TFAIL: SEM_STAT_ANY doesn't pass the buffer specified by the caller to kernel

 Summary:
 passed 8
 failed 2
 broken 0
 skipped 0
 warnings 0
 tag=semctl09 stime=1609875532 dur=0 exit=exited stat=1 core=no cu=0 cs=0

Po-Hsu Lin (cypressyew)
tags: added: 5.6 focal sru-20201130 ubuntu-ltp-syscalls
Revision history for this message
Po-Hsu Lin (cypressyew) wrote : Re: semctl09 from ubuntu_ltp_syscalls failed on X / F-oem-5.6

Found on Xenial 4.4 as well. With a slightly different error message:

 startup='Thu Jan 7 20:03:10 2021'
 tst_test.c:1263: TINFO: Timeout per run is 0h 05m 00s
 semctl09.c:67: TINFO: Test SYS_semctl syscall
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with nobody user
 semctl09.c:152: TFAIL: SEM_INFO haven't returned a valid index: SUCCESS (0)
 semctl09.c:167: TFAIL: Counted used = 0, semuse = 2
 semctl09.c:112: TPASS: semset_cnt = 2
 semctl09.c:119: TPASS: sen_cnt = 3
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with root user
 semctl09.c:152: TFAIL: SEM_INFO haven't returned a valid index: SUCCESS (0)
 semctl09.c:167: TFAIL: Counted used = 0, semuse = 2
 semctl09.c:112: TPASS: semset_cnt = 2
 semctl09.c:119: TPASS: sen_cnt = 3
 tst_test.c:1263: TINFO: Timeout per run is 0h 05m 00s
 semctl09.c:70: TINFO: Test libc semctl()
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with nobody user
 semctl09.c:152: TFAIL: SEM_INFO haven't returned a valid index: SUCCESS (0)
 semctl09.c:167: TFAIL: Counted used = 0, semuse = 2
 semctl09.c:112: TPASS: semset_cnt = 2
 semctl09.c:119: TPASS: sen_cnt = 3
 semctl09.c:132: TINFO: Test SEM_STAT_ANY with root user
 semctl09.c:152: TFAIL: SEM_INFO haven't returned a valid index: SUCCESS (0)
 semctl09.c:167: TFAIL: Counted used = 0, semuse = 2
 semctl09.c:112: TPASS: semset_cnt = 2
 semctl09.c:119: TPASS: sen_cnt = 3

 Summary:
 passed 8
 failed 8
 broken 0
 skipped 0
 warnings 0
 tag=semctl09 stime=1610049790 dur=0 exit=exited stat=1 core=no cu=0 cs=0

summary: - semctl09 from ubuntu_ltp_syscalls failed on F-oem-5.6
+ semctl09 from ubuntu_ltp_syscalls failed on X / F-oem-5.6
tags: added: 4.4 sru-20210104 xenial
tags: added: 4.15 azure bionic
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

found on bionic/fips 4.15.0-1053.61

tags: added: fips sru-20210125
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

In the test case comment there is a fix for it in glibc:
/*
 * The glibc bug was fixed in:
 *
 * * commit 574500a108be1d2a6a0dc97a075c9e0a98371aba
 * * Author: Dmitry V. Levin <email address hidden>
 * * Date: Tue, 29 Sep 2020 17:10:20 +0000 (14:10 -0300)
 */

Po-Hsu Lin (cypressyew)
summary: - semctl09 from ubuntu_ltp_syscalls failed on X / F-oem-5.6
+ semctl09 from ubuntu_ltp_syscalls failed on X / F-oem-5.6 / F-oracle-5.4
tags: added: 5.4 sru-20210315
Revision history for this message
Ian May (ian-may) wrote :

found on focal/aws 5.4.0-1042.44

Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Also on groovy/aws 5.8.0-1031.33

tags: added: 5.8 aws sru-20210412
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Found on focal/linux-gke 5.4.0-1043.45

24137. 04/26 18:26:51 DEBUG| utils:0153| [stdout] semctl09.c:121: TPASS: semset_cnt = 1
24138. 04/26 18:26:51 DEBUG| utils:0153| [stdout] semctl09.c:128: TPASS: sen_cnt = 2
24139. 04/26 18:26:51 DEBUG| utils:0153| [stdout] tst_test.c:1311: TINFO: Timeout per run is 0h 05m 00s
24140. 04/26 18:26:51 DEBUG| utils:0153| [stdout] semctl09.c:79: TINFO: Test libc semctl()
24141. 04/26 18:26:51 DEBUG| utils:0153| [stdout] semctl09.c:200: TFAIL: SEM_STAT_ANY doesn't pass the buffer specified by the caller to kernel
24142. 04/26 18:26:51 DEBUG| utils:0153| [stdout]
24143. 04/26 18:26:51 DEBUG| utils:0153| [stdout] HINT: You _MAY_ be missing glibc fixes, see:
24144. 04/26 18:26:51 DEBUG| utils:0153| [stdout]
24145. 04/26 18:26:51 DEBUG| utils:0153| [stdout] https://sourceware.org/git/?p=glibc.git;a=commit;h=574500a108be
24146. 04/26 18:26:51 DEBUG| utils:0153| [stdout]
24147. 04/26 18:26:51 DEBUG| utils:0153| [stdout] Summary:
24148. 04/26 18:26:51 DEBUG| utils:0153| [stdout] passed 8
24149. 04/26 18:26:51 DEBUG| utils:0153| [stdout] failed 1

tags: added: gke
tags: added: oem oem-5.6
tags: added: sru-20210510
Changed in ubuntu-kernel-tests:
assignee: nobody → Krzysztof Kozlowski (krzk)
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :
Changed in ubuntu-kernel-tests:
importance: Undecided → Low
status: New → In Progress
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in glibc (Ubuntu):
status: New → Confirmed
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Test skipped correctly on Oracle F-5.4 / B-4.15, therefore I am closing this bug for ubuntu-kernel-tests.

If anyone is still seeing this, please let us know, thanks!

Changed in ubuntu-kernel-tests:
status: Fix Committed → Fix Released
Revision history for this message
Luke Nowakowski-Krijger (lukenow) wrote :

Failure found on F/oracle 5.4.0-1055.59 on all instances in sru 2021-09-06

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

As we're not using the blacklist anymore, I will bring this bug back to Confirmed.

Changed in ubuntu-kernel-tests:
status: Fix Released → Confirmed
Revision history for this message
Ian May (ian-may) wrote :

Found on focal/linux-gcp-5.11: 5.11.0-1019.21~20.04.1

tags: added: sru-20210906
tags: added: 5.11
tags: added: gcp
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers