quotactl07 from ubuntu_ltp_syscalls failed

Bug #1864092 reported by Sean Feole on 2020-02-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Po-Hsu Lin
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Po-Hsu Lin
Bionic
Undecided
Po-Hsu Lin
Disco
Undecided
Po-Hsu Lin
Eoan
Undecided
Po-Hsu Lin

Bug Description

== SRU Justification ==
This quotactl07 is a new test case added in LTP test suite,

The test will fail with:
  <<<test_output>>>
  incrementing stop
  tst_kconfig.c:62: INFO: Parsing kernel config '/boot/config-5.0.0-38-generic'
  tst_device.c:244: INFO: Using test device LTP_DEV='/dev/loop4'
  tst_mkfs.c:90: INFO: Formatting /dev/loop4 with xfs opts='' extra opts=''
  tst_test.c:1217: INFO: Timeout per run is 0h 05m 00s
  quotactl07.c:34: FAIL: Q_XQUOTARM doesn't have quota type check

  HINT: You _MAY_ be missing kernel fixes, see:

  https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3dd4d40b4208

== Fix ==
* 3dd4d40b (xfs: Sanity check flags of Q_XQUOTARM call)

Focal got this patch from stable update. This patch can be cherry-picked into all the other kernels.

== Test ==
Test kernels could be found here:
https://people.canonical.com/~phlin/kernel/lp-1864092-quotactl07/

All patched kernels are working as expected,

== Regression Potential ==
Low, change limited to quota on XFS, and it's just adding a check for the flags.

== Original Bug Report ==
Initially Found:
Cloud: GCP
Kernel: 5.0.0-1032.33
Test: ubuntu_ltp_syscalls

02/20 15:04:55 DEBUG| utils:0153| [stdout] startup='Thu Feb 20 14:49:24 2020'
02/20 15:04:55 DEBUG| utils:0153| [stdout] tst_kconfig.c:62: INFO: Parsing kernel config '/boot/config-5.0.0-1032-gcp'
02/20 15:04:55 DEBUG| utils:0153| [stdout] tst_device.c:244: INFO: Using test device LTP_DEV='/dev/loop2'
02/20 15:04:55 DEBUG| utils:0153| [stdout] tst_mkfs.c:90: INFO: Formatting /dev/loop2 with xfs opts='' extra opts=''
02/20 15:04:55 DEBUG| utils:0153| [stdout] tst_test.c:1217: INFO: Timeout per run is 0h 05m 00s
02/20 15:04:55 DEBUG| utils:0153| [stdout] quotactl07.c:34: FAIL: Q_XQUOTARM doesn't have quota type check
02/20 15:04:55 DEBUG| utils:0153| [stdout]
02/20 15:04:55 DEBUG| utils:0153| [stdout] HINT: You _MAY_ be missing kernel fixes, see:
02/20 15:04:55 DEBUG| utils:0153| [stdout]
02/20 15:04:55 DEBUG| utils:0153| [stdout] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=3dd4d40b4208
02/20 15:04:55 DEBUG| utils:0153| [stdout]
02/20 15:04:55 DEBUG| utils:0153| [stdout] Summary:
02/20 15:04:55 DEBUG| utils:0153| [stdout] passed 0
02/20 15:04:55 DEBUG| utils:0153| [stdout] failed 1
02/20 15:04:55 DEBUG| utils:0153| [stdout] skipped 0
02/20 15:04:55 DEBUG| utils:0153| [stdout] warnings 0
02/20 15:04:55 DEBUG| utils:0153| [stdout] tag=quotactl07 stime=1582210164 dur=4 exit=exited stat=1 core=no cu=0 cs=0
02/20 15:04:55 DEBUG| utils:0153| [stdout] startup='Thu Feb 20 14:49:29 2020'
02/20 15:04:55 DEBUG| utils:0153| [stdout] tst_test.c:1217: INFO: Timeout per run is 0h 05m 00s
02/20 15:04:55 DEBUG| utils:0153| [stdout] read01.c:24: PASS: read(2) returned 512

Sean Feole (sfeole) on 2020-02-20
tags: added: 5.0
Po-Hsu Lin (cypressyew) on 2020-02-21
affects: linux-gcp (Ubuntu) → linux (Ubuntu)
Changed in ubuntu-kernel-tests:
assignee: nobody → Po-Hsu Lin (cypressyew)
status: Triaged → In Progress
Changed in linux (Ubuntu Bionic):
assignee: nobody → Po-Hsu Lin (cypressyew)
status: New → In Progress
Changed in linux (Ubuntu Disco):
status: New → In Progress
assignee: nobody → Po-Hsu Lin (cypressyew)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1864092

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Eoan):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2020-02-21
Changed in linux (Ubuntu Xenial):
status: New → In Progress

Patch already applied to Focal.

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
tags: added: 4.15 4.4 bionic disco eoan xenial
tags: added: 5.3 ubuntu-ltp-syscalls
Po-Hsu Lin (cypressyew) on 2020-02-21
description: updated
Changed in linux (Ubuntu Eoan):
status: Incomplete → In Progress
assignee: nobody → Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Xenial):
assignee: nobody → Po-Hsu Lin (cypressyew)
summary: - quotactl07 fails ubuntu_ltp_syscalls in 5.0 linux-gcp
+ quotactl07 from ubuntu_ltp_syscalls failed
Sean Feole (sfeole) on 2020-02-26
tags: added: aws
Po-Hsu Lin (cypressyew) on 2020-03-04
tags: added: kqa-blocker
Sean Feole (sfeole) wrote :

Patch has been applied upstream in focal, removing kqa-blocker.

Sean Feole (sfeole) wrote :

Are there further plans to backport the rest?

Changed in linux (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Disco):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Xenial):
status: In Progress → Fix Committed
Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
Sean Feole (sfeole) on 2020-03-11
tags: removed: kqa-blocker

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-xenial' to 'verification-done-xenial'. If the problem still exists, change the tag 'verification-needed-xenial' to 'verification-failed-xenial'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-xenial

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-bionic' to 'verification-done-bionic'. If the problem still exists, change the tag 'verification-needed-bionic' to 'verification-failed-bionic'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-bionic
Po-Hsu Lin (cypressyew) wrote :

quotactl07.c:32: PASS: Q_XQUOTARM has quota type check

tags: added: verification-done-xenial
removed: verification-needed-xenial
Po-Hsu Lin (cypressyew) wrote :

Passed with Bionic 4.15.0-94.95

 startup='Fri Mar 27 00:58:32 2020'
 tst_kconfig.c:62: INFO: Parsing kernel config '/boot/config-4.15.0-94-generic'
 tst_device.c:244: INFO: Using test device LTP_DEV='/dev/loop0'
 tst_mkfs.c:90: INFO: Formatting /dev/loop0 with xfs opts='' extra opts=''
 tst_test.c:1229: INFO: Timeout per run is 0h 05m 00s
 quotactl07.c:32: PASS: Q_XQUOTARM has quota type check

 Summary:
 passed 1
 failed 0
 skipped 0
 warnings 0
 tag=quotactl07 stime=1585270712 dur=1 exit=exited stat=0 core=no cu=0 cs=

tags: added: verification-done-bionic
removed: verification-needed-bionic
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers