zram01 / zram02 / zram03 in kernel_misc from ubuntu_ltp timeout on B ARM64

Bug #1854706 reported by Po-Hsu Lin on 2019-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned

Bug Description

Issue spotted on Bionic 4.15 ARM64 nodes, these tests have failed on both Moonshot and ThunderX nodes

 zram01 7 TINFO: filling zram3 (it can take long time)
 zram01 1 TBROK: test killed, timeout! If you are running on slow machine, try exporting LTP_TIMEOUT_MUL > 1

And this failure in zram01 is causing issue to zram02 / zram03 test.

We have tripled the timeout for this test on KVM instances, but as these two are bare-metal nodes, so the timeout multiplier is still the same (5mins)

It's better to check for other kernels to see if these ARM64 nodes will fail on them.
And we might need to set the timeout multiplier regardless if it's a KVM or not.

Po-Hsu Lin (cypressyew) wrote :

This issue can be found on B-AWS-5.0 (5.0.0-1022.25~18.04.1) instance t2.small as well.

These tests will fail on this instance even with 15 minute timeout.

tags: added: sru-20191111
Po-Hsu Lin (cypressyew) wrote :

Spotted on node lagalla, ms10-35-mcdivittB0-kernel with Eoan 5.3 (5.3.0-25.27)

tags: added: sru-20191202 ubuntu-ltp
Sean Feole (sfeole) wrote :

affects 4.15 also arm64 4.15.0-73.82-generic

Changed in ubuntu-kernel-tests:
status: New → Triaged
tags: added: bionic
tags: added: 4.15
tags: added: 5.0
Po-Hsu Lin (cypressyew) wrote :

Tested on moonshot ARM64
real 10m47.859s
user 7m0.956s
sys 3m52.593s

So it looks like we have to bump the timeout multiplier regardless if it's a KVM.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers