acct02 from ubuntu_ltp_syscalls failed on X/B/D/E-s390x

Bug #1839836 reported by Po-Hsu Lin on 2019-08-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

Error message on D-s390x KVM:

 startup='Thu Oct 3 01:17:21 2019'
 tst_kconfig.c:62: INFO: Parsing kernel config '/boot/config-4.15.0-66-generic'
 tst_test.c:1118: INFO: Timeout per run is 0h 05m 00s
 tst_kconfig.c:62: INFO: Parsing kernel config '/boot/config-4.15.0-66-generic'
 acct02.c:239: INFO: Verifying using 'struct acct_v3'
 acct02.c:192: INFO: == entry 1 ==
 acct02.c:82: INFO: ac_comm != 'acct02_helper' ('systemd-udevd')
 acct02.c:133: INFO: ac_exitcode != 32768 (0)
 acct02.c:141: INFO: ac_ppid != 32327 (705)
 acct02.c:147: INFO: ac_version != 3 (131)
 acct02.c:192: INFO: == entry 2 ==
 acct02.c:147: INFO: ac_version != 3 (131)
 acct02.c:192: INFO: == entry 3 ==
 acct02.c:82: INFO: ac_comm != 'acct02_helper' ('acct02')
 acct02.c:133: INFO: ac_exitcode != 32768 (0)
 acct02.c:141: INFO: ac_ppid != 32327 (32326)
 acct02.c:147: INFO: ac_version != 3 (131)
 acct02.c:182: FAIL: end of file reached

 Summary:
 passed 0
 failed 1
 skipped 0
 warnings 0

This was not spotted on other arches on D, just s390x

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: linux-image-5.0.0-25-generic 5.0.0-25.26
ProcVersionSignature: Ubuntu 5.0.0-25.26-generic 5.0.18
Uname: Linux 5.0.0-25-generic s390x
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay': 'aplay'
ApportVersion: 2.20.10-0ubuntu27.1
Architecture: s390x
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord': 'arecord'
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CurrentDmesg:
 [435066.563428] LTP: starting acct02
 [435067.737885] Process accounting resumed
Date: Mon Aug 12 13:49:49 2019
HibernationDevice: RESUME=UUID=eae923f9-f5a4-41c0-b3e4-04786207dbaa
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig': 'iwconfig'
Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcFB:

ProcKernelCmdLine: root=UUID=1a6af794-84a9-4034-a213-39506b9bb91c crashkernel=196M BOOT_IMAGE=0
RelatedPackageVersions:
 linux-restricted-modules-5.0.0-25-generic N/A
 linux-backports-modules-5.0.0-25-generic N/A
 linux-firmware 1.178.4
RfKill: Error: [Errno 2] No such file or directory: 'rfkill': 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
tags: added: 5.0 ubuntu-ltp-syscalls
tags: added: sru-20190722

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1839836

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

Issue could be found in Bionic s390x.

tags: added: sru-20190812
tags: added: 4.15 bionic
summary: - acct02 from ubuntu_ltp_syscalls failed on D-s390x
+ acct02 from ubuntu_ltp_syscalls failed on B/D-s390x
Po-Hsu Lin (cypressyew) on 2019-09-02
summary: - acct02 from ubuntu_ltp_syscalls failed on B/D-s390x
+ acct02 from ubuntu_ltp_syscalls failed on X/B/D-s390x

This test will need commit 4d9570158b626, which has already been applied to X/B/D/E.

Error message updated in the bug description.

no longer affects: ubuntu-kernel-tests
description: updated
summary: - acct02 from ubuntu_ltp_syscalls failed on X/B/D-s390x
+ acct02 from ubuntu_ltp_syscalls failed on X/B/D/E-s390x
tags: added: eoan
tags: added: 4.4 5.3 xenial
Po-Hsu Lin (cypressyew) wrote :

Passed with X-fips s390x KVM

Po-Hsu Lin (cypressyew) wrote :

ubuntu@s2lp6g003:~$ lscpu | grep "Byte Order"
Byte Order: Big Endian

Seems to be fixed with the following commit in LTP (acct: fix version check on big endian system):
https://github.com/linux-test-project/ltp/commit/fe5ffe2701f8dc8115a82808818b9d9d5b41508d

Changed in linux (Ubuntu):
status: Incomplete → Invalid
no longer affects: linux (Ubuntu Xenial)
no longer affects: linux (Ubuntu Bionic)
no longer affects: linux (Ubuntu Disco)
no longer affects: linux (Ubuntu Eoan)
Changed in ubuntu-kernel-tests:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers