ubuntu_nbd_smoke_test failed with kernel warning on X-4.15 i386

Bug #1813713 reported by Po-Hsu Lin on 2019-01-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
linux-hwe (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Issue found on a i386 SUT with X-4.15 generic / low-latency kernel:
  creating backing nbd image /tmp/nbd_image.img

  --------------------------------------------------------------------------------
  Image path: /tmp/nbd_image.img
  Mount point: /mnt/nbd-test-12309
  Date: Tue Jan 29 06:30:51 UTC 2019
  Host: pepe
  Kernel: 4.15.0-43-lowlatency #46~16.04.1-Ubuntu SMP PREEMPT Fri Dec 7 16:13:34 UTC 2018
  Machine: pepe i686 i686
  CPUs online: 8
  CPUs total: 8
  Page size: 4096
  Pages avail: 1824175
  Pages total: 2069973
  Free space:
  Filesystem Size Used Avail Use% Mounted on
  udev 4.0G 0 4.0G 0% /dev
  tmpfs 809M 8.8M 800M 2% /run
  /dev/sda1 275G 5.8G 255G 3% /
  tmpfs 4.0G 0 4.0G 0% /dev/shm
  tmpfs 5.0M 0 5.0M 0% /run/lock
  tmpfs 4.0G 0 4.0G 0% /sys/fs/cgroup
  tmpfs 809M 0 809M 0% /run/user/1000
  --------------------------------------------------------------------------------

  NBD device /dev/nbd0 created
  found nbd export
  NBD exports found:
  test
  starting client with NBD device /dev/nbd0
  Negotiation: ..size = 128MB
  creating ext4 on /dev/nbd0
  mkfs on /dev/nbd0 succeeded after 0 attempt(s)
  checking ext4 on /dev/nbd0
  fsck from util-linux 2.27.1
  /dev/nbd0: clean, 11/32768 files, 9787/131072 blocks

  mount:
  /dev/nbd0 on /mnt/nbd-test-12309 type ext4 (rw,relatime,data=ordered)
  mounted on /dev/nbd0

  free:
  Filesystem 1K-blocks Used Available Use% Mounted on
  /dev/nbd0 122835 1550 112111 2% /mnt/nbd-test-12309

  creating large file /mnt/nbd-test-12309/largefile
  -rw-r--r-- 1 root root 100M Jan 29 06:30 /mnt/nbd-test-12309/largefile

  free:
  Filesystem 1K-blocks Used Available Use% Mounted on
  /dev/nbd0 122835 103951 9710 92% /mnt/nbd-test-12309

  removing file /mnt/nbd-test-12309/largefile
  unmounting /mnt/nbd-test-12309
  stopping client
  disconnect, sock, done
  Found kernel warning, IO error and/or call trace
  echo
  [ 144.498338] creating backing nbd image /tmp/nbd_image.img
  [ 145.668377] NBD device /dev/nbd0 created
  [ 145.716876] found nbd export
  [ 146.760018] starting client with NBD device /dev/nbd0
  [ 146.761655] creating ext4 on /dev/nbd0
  [ 147.007051] mkfs on /dev/nbd0 succeeded after 0 attempt(s)
  [ 147.171873] checking ext4 on /dev/nbd0
  [ 147.222034] EXT4-fs (nbd0): mounted filesystem with ordered data mode. Opts: (null)
  [ 147.226224] mounted on /dev/nbd0
  [ 147.227449] creating large file /mnt/nbd-test-12309/largefile
  [ 147.940687] removing file /mnt/nbd-test-12309/largefile
  [ 148.007125] unmounting /mnt/nbd-test-12309
  [ 149.048638] stopping client
  [ 149.049176] block nbd0: NBD_DISCONNECT
  [ 149.049200] block nbd0: shutting down sockets
  [ 149.049320] nbd0: detected capacity change from 0 to 134217728
  [ 149.049346] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.055116] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.062402] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.068078] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.075363] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.080923] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.087847] ldm_validate_partition_table(): Disk read failed.
  [ 149.087861] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.093442] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.100409] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.105988] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.112912] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.118544] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.125537] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.131027] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.138007] Dev nbd0: unable to read RDB block 0
  [ 149.142647] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.148182] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.155213] print_req_error: I/O error, dev nbd0, sector 24
  [ 149.160837] Buffer I/O error on dev nbd0, logical block 3, async page read
  [ 149.167846] print_req_error: I/O error, dev nbd0, sector 0
  [ 149.173363] Buffer I/O error on dev nbd0, logical block 0, async page read
  [ 149.180357] nbd0: unable to read partition table
  [ 149.696627] Found kernel warning, IO error and/or call trace
  [ 149.696665] echo
  killing server
  ================================================================================

  Completed

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.15.0-43-lowlatency 4.15.0-43.46~16.04.1
ProcVersionSignature: User Name 4.15.0-43.46~16.04.1-lowlatency 4.15.18
Uname: Linux 4.15.0-43-lowlatency i686
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: i386
Date: Tue Jan 29 06:33:16 2019
SourcePackage: linux-hwe
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) on 2019-01-29
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-hwe (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux-hwe (Ubuntu Bionic):
status: New → Invalid
Po-Hsu Lin (cypressyew) on 2019-09-16
tags: added: ubuntu-nbd-smoke-test
Po-Hsu Lin (cypressyew) wrote :

Didn't see this on X-4.15
4.15.0-65.74~16.04.1 - generic / lowlatency.

Closing this bug.

Changed in ubuntu-kernel-tests:
status: New → Fix Released
Changed in linux (Ubuntu):
status: Confirmed → Invalid
Changed in linux (Ubuntu Xenial):
status: New → Invalid
Changed in linux (Ubuntu Bionic):
status: New → Invalid
Changed in linux-hwe (Ubuntu):
status: Confirmed → Invalid
Changed in linux-hwe (Ubuntu Xenial):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers