sysbench package for s390x required in ubuntu_btrfs_kernel_fixes is only available on Xenial

Bug #1809860 reported by Po-Hsu Lin on 2018-12-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Medium
Sean Feole
sysbench (Ubuntu)
Undecided
Unassigned
Declined for Bionic by Sean Feole
Declined for Cosmic by Sean Feole
Declined for Disco by Sean Feole

Bug Description

The sysbench package for s390x is only available on Xenial.

For Bionic and Cosmic, the build gets stuck at the "Missing build dependencies: libluajit-5.1-dev" state:

* B - https://launchpad.net/ubuntu/+source/sysbench/1.0.11+ds-1/+build/14216551
* C - https://launchpad.net/ubuntu/+source/sysbench/1.0.11+ds-1/+build/14826373
* D - https://launchpad.net/ubuntu/+source/sysbench/1.0.15+ds-1/+build/15588301

Po-Hsu Lin (cypressyew) on 2018-12-27
description: updated
jcfp (jcfp) wrote :

Libluajit-5.1-dev is a non-optional build-dep for sysbench releases more recent than the ancient version in xenial. Hence, this is not a bug in the sysbench package unless/until one can show there's something wrong with the dependency itself. Otherwise, if you want sysbench to build on s390x, you'll have to ensure its build-deps are present and accounted for on that architecture.

Changed in sysbench (Ubuntu):
status: New → Incomplete
jcfp (jcfp) on 2019-08-13
Changed in sysbench (Ubuntu):
status: Incomplete → Invalid
Sean Feole (sfeole) wrote :

+1 to blacklist this test on s390x, I don't see any value on bothering with xenial only per comment #1

Changed in ubuntu-kernel-tests:
assignee: nobody → Sean Feole (sfeole)
status: New → In Progress
importance: Undecided → Medium
Sean Feole (sfeole) wrote :

* cb9d9a84 (HEAD -> master, origin/master, origin/HEAD) Blacklist s390x arch on ubuntu_btrfs_kernel_fixes

Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers