ubuntu_ftrace_smoke_test time outed on X-4.15 / B-4.15

Bug #1796791 reported by Po-Hsu Lin on 2018-10-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Medium
Colin Ian King

Bug Description

The test was killed.
Compared to the test in X-4.4 (https://pastebin.ubuntu.com/p/hQDvv9qXFx/), it looks like the "tracer function can be enabled" is the one got killed.

Output:
  PASSED (CONFIG_FUNCTION_TRACER=y in /boot/config-4.15.0-36-generic)
  PASSED (CONFIG_FUNCTION_GRAPH_TRACER=y in /boot/config-4.15.0-36-generic)
  PASSED (CONFIG_STACK_TRACER=y in /boot/config-4.15.0-36-generic)
  PASSED (CONFIG_DYNAMIC_FTRACE=y in /boot/config-4.15.0-36-generic)
  PASSED all expected /sys/kernel/debug/tracing files exist
  PASSED (function_graph in /sys/kernel/debug/tracing/available_tracers)
  PASSED (function in /sys/kernel/debug/tracing/available_tracers)
  PASSED (nop in /sys/kernel/debug/tracing/available_tracers)
  PASSED (function can be enabled)
  PASSED (SyS_write traces found must be > 32, got 5575)
  PASSED (function_graph can be enabled)
  PASSED (vfs_write traces found must be > 32, got 10726)
  PASSED (tracer hwlat can be enabled (got 10 lines of tracing output))
  PASSED (tracer blk can be enabled (got 2 lines of tracing output))
  PASSED (tracer mmiotrace can be enabled (got 9 lines of tracing output))
  PASSED (tracer function_graph can be enabled (got 55991 lines of tracing output))
  PASSED (tracer wakeup_dl can be enabled (got 2 lines of tracing output))
  PASSED (tracer wakeup_rt can be enabled (got 44 lines of tracing output))
  PASSED (tracer wakeup can be enabled (got 60 lines of tracing output))
  TIMEOUT 1431
  KILLING 1431
  FAILED: aborting, timeout, took way too long to complete

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.15.0-36-generic 4.15.0-36.39~16.04.1
ProcVersionSignature: User Name 4.15.0-36.39~16.04.1-generic 4.15.18
Uname: Linux 4.15.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.18
Architecture: amd64
Date: Tue Oct 9 04:59:56 2018
SourcePackage: linux-signed-hwe
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :
Po-Hsu Lin (cypressyew) wrote :

It seems that this test can pass on the very same KVM node with timeout increased from 60 to 90 seconds.

ubuntu_ftrace_smoke_test/ubuntu_ftrace_smoke_test.sh:
    test_function_tracer()
    {
            timer_start 90

Po-Hsu Lin (cypressyew) on 2018-10-09
tags: added: bionic

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1796791

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2018-10-09
summary: - ubuntu_ftrace_smoke_test time outed on X-4.15
+ ubuntu_ftrace_smoke_test time outed on X-4.15 / B-4.15
Po-Hsu Lin (cypressyew) wrote :

Didn't see this on B-4.15 anymore

Po-Hsu Lin (cypressyew) wrote :

Didn't see this on X-4.15 as well.

I assume this was fixed with https://kernel.ubuntu.com/git/ubuntu/autotest-client-tests.git/commit/?id=b11bc2a1997f5e992549e5a5dfb55941356387c8
Closing this bug.

no longer affects: linux (Ubuntu)
no longer affects: linux (Ubuntu Bionic)
no longer affects: linux-signed-hwe (Ubuntu)
no longer affects: linux-signed-hwe (Ubuntu Bionic)
Changed in ubuntu-kernel-tests:
status: New → Fix Released
importance: Undecided → Medium
Changed in ubuntu-kernel-tests:
assignee: nobody → Colin Ian King (colin-king)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers