fcntl35 / fcntl35_64 in LTP syscall test failed with T/T-LTS/X kernel

Bug #1774394 reported by Po-Hsu Lin on 2018-05-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Low
Unassigned
linux (Ubuntu)
Undecided
Unassigned
Trusty
Low
Unassigned
Xenial
Undecided
Unassigned
linux-lts-xenial (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

The "fcntl35" and "fcntl35_64" from the LTP syscall tests have failed on a testing node with T-LTS i386 kernel installed (they were not tested on amd64/arm64 because the test was not ready when the SRU starts).

<<test_start>>>
tag=fcntl35 stime=1527764565
cmdline="fcntl35"
contacts=""
analysis=exit
<<<test_output>>>
tst_test.c:1015: INFO: Timeout per run is 0h 05m 00s
fcntl35.c:98: FAIL: an unprivileged user init the capacity of a pipe to 65536 unexpectedly, expected 4096
fcntl35.c:101: PASS: a privileged user init the capacity of a pipe to 65536 successfully

Summary:
passed 1
failed 1
skipped 0
warnings 0
<<<execution_status>>>
initiation_status="ok"
duration=0 termination_type=exited termination_id=1 corefile=no
cutime=0 cstime=0
<<<test_end>>>

<<<test_start>>>
tag=fcntl35_64 stime=1527764565
cmdline="fcntl35_64"
contacts=""
analysis=exit
<<<test_output>>>
tst_test.c:1015: INFO: Timeout per run is 0h 05m 00s
fcntl35.c:98: FAIL: an unprivileged user init the capacity of a pipe to 65536 unexpectedly, expected 4096
fcntl35.c:101: PASS: a privileged user init the capacity of a pipe to 65536 successfully

Summary:
passed 1
failed 1
skipped 0
warnings 0
<<<execution_status>>>
initiation_status="ok"
duration=0 termination_type=exited termination_id=1 corefile=no
cutime=0 cstime=0
<<<test_end>>>

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-4.4.0-128-generic 4.4.0-128.154~14.04.1
ProcVersionSignature: User Name 4.4.0-128.154~14.04.1-generic 4.4.131
Uname: Linux 4.4.0-128-generic i686
ApportVersion: 2.14.1-0ubuntu3.28
Architecture: i386
Date: Thu May 31 11:05:58 2018
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux-lts-xenial
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :

Could be found on X kernel as well.

summary: - fcntl35 / fcntl35_64 in LTP syscall test failed with X-LTS kernel
+ fcntl35 / fcntl35_64 in LTP syscall test failed with X/X-LTS kernel

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1774394

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2018-06-06
summary: - fcntl35 / fcntl35_64 in LTP syscall test failed with X/X-LTS kernel
+ fcntl35 / fcntl35_64 in LTP syscall test failed with T/X/X-LTS kernel
Po-Hsu Lin (cypressyew) on 2019-09-16
tags: added: ubuntu-ltp-syscalls
Po-Hsu Lin (cypressyew) on 2019-09-17
summary: - fcntl35 / fcntl35_64 in LTP syscall test failed with T/X/X-LTS kernel
+ fcntl35 / fcntl35_64 in LTP syscall test failed with T/T-LTS/X kernel
description: updated
Changed in ubuntu-kernel-tests:
assignee: nobody → Kleber Sacilotto de Souza (kleber-souza)
importance: Undecided → Medium
status: New → In Progress

This testcase is now passing on 4.4 kernels.

Changed in linux (Ubuntu Xenial):
status: New → Fix Released
no longer affects: linux-lts-xenial (Ubuntu Xenial)
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux-lts-xenial (Ubuntu):
status: New → Fix Released
Changed in linux-lts-xenial (Ubuntu Trusty):
status: New → Fix Released
Changed in linux (Ubuntu Trusty):
status: New → Confirmed

Setting priority to low as Trusty is now ESM.

Changed in ubuntu-kernel-tests:
status: In Progress → Triaged
importance: Medium → Low
assignee: Kleber Sacilotto de Souza (kleber-souza) → nobody
Changed in linux (Ubuntu Trusty):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers