Insert test_bpf module will report 4 failures for ubuntu_bpf_jit on X s390x

Bug #1768452 reported by Po-Hsu Lin on 2018-05-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Undecided
Unassigned
linux (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Disco
Medium
Unassigned

Bug Description

After the test_bpf insert issue for Xenial was fixed in bug 1765698

But it looks like the s390x needs some extra work.
$ sudo modprobe test_bpf
modprobe: ERROR: could not insert 'test_bpf': Invalid argument

4 tests failed here:
  test_bpf: #243 BPF_MAXINSNS: Ctx heavy transformations FAIL to prog_create err=-524 len=4096
  test_bpf: #244 BPF_MAXINSNS: Call heavy transformations FAIL to prog_create err=-524 len=4096
  test_bpf: #249 BPF_MAXINSNS: ld_abs+get_processor_id FAIL to prog_create err=-524 len=4096
  test_bpf: #250 BPF_MAXINSNS: ld_abs+vlan_push/pop FAIL to select_runtime err=-524

Complete test result:
https://pastebin.ubuntu.com/p/zMDwVjwF7X/

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-123-generic 4.4.0-123.147
ProcVersionSignature: Ubuntu 4.4.0-123.147-generic 4.4.128
Uname: Linux 4.4.0-123-generic s390x
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.20.1-0ubuntu2.16
Architecture: s390x
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Date: Wed May 2 03:45:22 2018
HibernationDevice: RESUME=UUID=f578fa27-1d57-41c9-bb1d-7ff64c1c9345
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: Error: [Errno 2] No such file or directory: '/proc/fb'
ProcKernelCmdLine: root=UUID=f26894a2-496d-4891-aa9a-f66344c77779 crashkernel=196M BOOT_IMAGE=0
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-123-generic N/A
 linux-backports-modules-4.4.0-123-generic N/A
 linux-firmware 1.157.17
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Changed in linux (Ubuntu Xenial):
status: New → Triaged
Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in linux (Ubuntu Xenial):
importance: Undecided → Medium
tags: added: kernel-da-key
Changed in ubuntu-kernel-tests:
status: New → Won't Fix
Changed in linux (Ubuntu):
status: Triaged → Invalid
Changed in linux (Ubuntu Xenial):
status: Triaged → Invalid
Po-Hsu Lin (cypressyew) wrote :

Re-open this bus, as it's for ubuntu_bpf_jit test, the patch mentioned in #3 is for the ubuntu_bpf test.

Will need to check if we need to blacklist Xenial for this as well (probably not, as we don't have it blacklisted at the very beginning)

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Changed in ubuntu-kernel-tests:
status: Won't Fix → Confirmed
Changed in linux (Ubuntu Xenial):
status: Invalid → Confirmed
Po-Hsu Lin (cypressyew) on 2018-11-05
summary: - Unable to insert test_bpf module on Xenial s390x
+ Unable to insert test_bpf module for ubuntu_bpf_jit on Xenial s390x

Checked on Disco, it will fail with the same error message.

$ cat /boot/config-5.0.0-8-generic | grep CONFIG_TEST_BPF
CONFIG_TEST_BPF=m

It looks like all the test have passed but jited as well.:

$ sudo modprobe test_bpf
....
test_bpf: Summary: 377 PASSED, 1 FAILED, [362/362 JIT'ed]

Please find the attachment for dmesg output.

Po-Hsu Lin (cypressyew) wrote :

BTW for Disco, it's complaining about 1 Failure, but I can't see any in the dmesg output.

For Xenial LPAR, the failure is a bit different:

There are 4 failures:
[508578.608193] test_bpf: #243 BPF_MAXINSNS: Ctx heavy transformations FAIL to prog_create err=-524 len=4096
[508578.609417] test_bpf: #244 BPF_MAXINSNS: Call heavy transformations FAIL to prog_create err=-524 len=4096
...
[508578.684174] test_bpf: #249 BPF_MAXINSNS: ld_abs+get_processor_id FAIL to prog_create err=-524 len=4096
[508578.685440] test_bpf: #250 BPF_MAXINSNS: ld_abs+vlan_push/pop FAIL to select_runtime err=-524

Po-Hsu Lin (cypressyew) wrote :

This has passed on Cosmic zVM.

Sean Feole (sfeole) on 2019-04-17
summary: - Unable to insert test_bpf module for ubuntu_bpf_jit on Xenial s390x
+ Unable to insert test_bpf module for ubuntu_bpf_jit s390x

For Disco (no failure but reported 1 failed), please refer to bug 1827845

As it's different from this report, I will mark it as fix-released for Disco here.

Changed in linux (Ubuntu Disco):
status: Confirmed → Fix Released
summary: - Unable to insert test_bpf module for ubuntu_bpf_jit s390x
+ Insert test_bpf module will report 4 failures for ubuntu_bpf_jit on X
+ s390x
Brad Figg (brad-figg) on 2019-07-24
tags: added: cscc
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers