aio-dio-invalidate-failure test failed with event res -22 on s390x

Bug #1730895 reported by Po-Hsu Lin on 2017-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Medium
Kleber Sacilotto de Souza

Bug Description

This bug is for tracking purpose, this is not a regression for current cycle as this issue exists for a long time.

It can be reproduced on zVM, zKVM and Ubuntu on LPAR

Steps:
1. git clone --depth=1 https://github.com/autotest/autotest-client-tests.git
2. make -C autotest-client-tests/aio_dio_bugs/src
3. sudo ./autotest-client-tests/aio_dio_bugs/src/aio-dio-invalidate-failure poo

Result:
event res -22

From the code itself, it's expecting a -EIO return value:
        if (event.res == -EIO) {
            printf("invalidation returned -EIO, OK\n");
            exit(0);
        }

The actual return value is -22, which I think is -EINVAL

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: linux-image-4.4.0-100-generic 4.4.0-100.123
ProcVersionSignature: Ubuntu 4.4.0-100.123-generic 4.4.95
Uname: Linux 4.4.0-100-generic s390x
NonfreeKernelModules: zfs zunicode zcommon znvpair zavl
AlsaDevices: Error: command ['ls', '-l', '/dev/snd/'] failed with exit code 2: ls: cannot access '/dev/snd/': No such file or directory
AplayDevices: Error: [Errno 2] No such file or directory: 'aplay'
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: s390x
ArecordDevices: Error: [Errno 2] No such file or directory: 'arecord'
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
CurrentDmesg:

Date: Wed Nov 8 01:57:40 2017
HibernationDevice: RESUME=UUID=f578fa27-1d57-41c9-bb1d-7ff64c1c9345
IwConfig: Error: [Errno 2] No such file or directory: 'iwconfig'
Lsusb: Error: command ['lsusb'] failed with exit code 1:
PciMultimedia:

ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: Error: [Errno 2] No such file or directory: '/proc/fb'
ProcKernelCmdLine: root=UUID=f26894a2-496d-4891-aa9a-f66344c77779 crashkernel=196M BOOT_IMAGE=0
RelatedPackageVersions:
 linux-restricted-modules-4.4.0-100-generic N/A
 linux-backports-modules-4.4.0-100-generic N/A
 linux-firmware 1.157.13
RfKill: Error: [Errno 2] No such file or directory: 'rfkill'
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)

Po-Hsu Lin (cypressyew) wrote :

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1730895

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Po-Hsu Lin (cypressyew) on 2017-11-08
description: updated
Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
tags: added: kernel-da-key
Po-Hsu Lin (cypressyew) on 2018-05-22
tags: added: bionix
tags: added: bionic
removed: bionix
Changed in linux (Ubuntu Bionic):
assignee: nobody → Kleber Sacilotto de Souza (kleber-souza)
Po-Hsu Lin (cypressyew) on 2018-06-01
Changed in ubuntu-kernel-tests:
assignee: nobody → Kleber Sacilotto de Souza (kleber-souza)
status: New → In Progress
importance: Undecided → Medium

Fixed the testcases under aio_dio_bugs/src/ on autotest-client-tests repo.

no longer affects: linux (Ubuntu)
no longer affects: linux (Ubuntu Xenial)
no longer affects: linux (Ubuntu Artful)
no longer affects: linux (Ubuntu Bionic)
Changed in ubuntu-kernel-tests:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers