Sound Blaster Play! SB-PLAY(MODEL NO SB1140)がノイズしか出力しない

Bug #1234142 reported by hibi.sasahara@gmail.com on 2013-10-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Japanese Kaizen Project
Undecided
Unassigned

Bug Description

USBサウンドデバイスの「Sound Blaster Play! SB-PLAY(MODEL NO SB1140)」(以下、SB-PLAY)から音声出力しようとすると、サウンドノイズが出力され、音声が出力されません。

[How To Reproduce]

・SB-PLAYをUSB端子に刺す
・ディスプレイ右上のサウンドアイコンからSoundSettingsを開く
・スピーカをSB-PLAYにつなぐ
(・音楽をRhythmboxで再生する)
・出力タブのサウンドの出力先を、「アナログ出力 内部オーディオ」から「Speaker Sound Blaster Play!」に切り替える
・スピーカからノイズが出力される

[Actual Result]

SB-PLAYから音声出力しようと上記の手順を行うと、スピーカからノイズしか出力されません。
(ヘッドホンでも同様の現象が出たこと、「アナログ出力 内部オーディオ」からは正常に音が出るため、スピーカが原因ではありませんでした。)
音楽の出力を止めると、ノイズも止まります。
また、「出力の音量」設定からミュートにしても、ノイズが止まります。

Rhythmboxだけでなく、totemプレイヤーによる音声出力でも、同様のノイズが出力されます。

環境はUbuntu13.10(beta)ですが、13.04でも同様の状態(SB-PLAYからノイズしか出ないため使用できない)でした。

[Expected Result]

(「アナログ出力 内部オーディオ」と同じようにSB-PLAYから音が出る。

Takashi Sakamoto (mocchi) wrote :

$ lsusb
...
Bus 007 Device 003: ID 041e:30d3 Creative Technology, Ltd Sound Blaster Play!
...

これがおそらくSB1140を指します。デバイスディスクリプタ情報を見たいので、以下のコマンドの出力を教えてください。なお、オプションとして与えるIDは適宜読み替えて下さい。

$ lsusb -vs 007:003

また、ALSAのデバッグ情報も見たいので、以下のコマンドの出力を教えてください。

$ bash /usr/share/alsa-base/alsa-info.sh --stdout

長々と出力されますので、「--stdout」オプションの代わりに「--output ファイル名」を活用してください。

lsusb
および、(Sound Blaster Play! のデバイス番号から)
lsusb -vs 007:005
の実行結果を添付いたします。

alsa-info の結果はこの次に続けてアップします。

続いて、
bash /usr/share/alsa-base/alsa-info.sh --output alsa-info_sb1140.txt
の結果です。

(念の為、サウンド設定でSB1140を選択し、音楽を流してサウンドノイズを聴きながらファイルとりました。たぶん意味はないのでしょうが)

自宅の別マシンに入っているUbuntu12.04でSB1140を試してみたところ、問題なく音が出ました。

alsa-infoは(パスにファイルがなかったので)取れませんでしたが、lsusb -vsおよびalsaと名前の付いている導入パッケージのバージョン情報、ハードウェア情報を添付させていただきます。
役に立てば幸いです。

Ubuntu13.10がリリースされたため、クリーンインストールしてSB1140を試してみたところ、問題なく音が出ました。

数日使って、問題がなければ、このままバグレポートを閉じようと思います。
(どなたかが直してくださった結果なのか、あるいは偶然なのかがわからないので、数日は様子を見ます)
(レポートを閉じる方法がわからないので調べるつもりですが、ご教示いただけると嬉しいです)

皆様の(特にTakashi Sakamoto様の)ご厚意に感謝いたします。

Changed in ubuntu-jp-improvement:
status: New → Fix Released

2013/11/23時点で、不具合が再出現しています。
アップデートが原因だとすると、いつのアップデートによるのか不明ですが、2週間以上前から同様の状態だったようです。

とりあえず、StatusをFix Releaseから変更しておきました。

Changed in ubuntu-jp-improvement:
status: Fix Released → Incomplete

2013/12/01時点で、不具合が無くなり正常に音が出ています。

今回も、数日ほど様子を見て不具合がなければStatusを変更してレポートを閉じようと思います。

とはいえこういった場合、どうしたものかわからないので、閉じる際の基準など、アドバイスをいただけると幸いです。

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu Japanese Kaizen Project because there has been no activity for 60 days.]

Changed in ubuntu-jp-improvement:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers