Grub installation fails on JeOS Hardy on KVM Hardy

Bug #215618 reported by c.bubel on 2008-04-11
10
Affects Status Importance Assigned to Milestone
Ubuntu JeOS
Undecided
Unassigned

Bug Description

I'm trying to install JeOS hardy on a Ubuntu hardy KVM, but Grub installation fails (sorry i have no further information). Lilo works fine and the Grub installation with a JeOS gutsy works also fine.

Fabián Rodríguez (magicfab) wrote :

I can confirm this in VMWare too. I don't think it's a KVM issue, this is most likely intentional, however GRUB should not be part of the install process if intentional, it should just use LILO.

Changed in ubuntu-jeos:
status: New → Confirmed
Fabián Rodríguez (magicfab) wrote :

I am attaching a screenshot of the error I get when attempting the install in VMWare.

It reads "The grub package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot"

Fabián Rodríguez (magicfab) wrote :

Workaround: this will let the install complete succesfully, although it will be using LILO:
1) When the error occurs, choose <GO BACK>
2) Then choose "Install the LILO bootloader on a hard disk" from the menu
3) Choose "Main boot sector" as target or else, as appropriate.

The install will then resume and complete as usual.

Nick Barcet (nijaba) wrote :

Well, with today's jeos iso and KVM, it is even worse than this for me:
- Network card not detected (bridged or virtual)
- / cannot be mounted after partionning step

There seems to be a major problem for the iso at the moment

Colin Watson (cjwatson) wrote :

Nick's problem is due to kernel ABI desync (affecting all images to one degree or another, depending on luck), and will be fixed in tomorrow's images. It's almost certainly unconnected to the rest of this bug report.

Nick Barcet (nijaba) wrote :

Thanks Colin. Just reproduced the issue with the beta iso, here are the logs.

Colin Watson (cjwatson) wrote :

This is due to volumeid having been partially-but-not-quite-removed from the base system, and should disappear in tomorrow's images.

Nick Barcet (nijaba) on 2008-04-11
Changed in ubuntu-jeos:
status: Confirmed → Fix Released
Fabián Rodríguez (magicfab) wrote :

I was a bit quick with my "workaround". Apr. 11's nightly won't complete the install even using Lilo.

Apr. 10's nightly, however, can be installed using the workaround i mentioned.

Thanks to all involved, will keep an eye on coming releases.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers