Bluetooth indicator will not stay turned off after reboot

Bug #922375 reported by Jason Warner
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ubuntu network, Bluetooth, keyboard menus
Fix Released
Low
Charles Kerr
gnome-bluetooth (Ubuntu)
Low
Unassigned

Bug Description

I turned off bluetooth indicator and rebooted. Bluetooth indicator was turned on again after reboot. This happens everytime I reboot meaning I have to turn off bluetooth indicator each time I reboot.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: indicator-appmenu 0.3.2+hud5-0ubuntu1~ppa4
ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CrashDB: indicator_appmenu
Date: Fri Jan 27 10:32:18 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
SourcePackage: indicator-appmenu
ThirdParty: True
UpgradeStatus: Upgraded to precise on 2011-12-14 (43 days ago)

Revision history for this message
Jason Warner (jasoncwarner) wrote :
Ted Gould (ted)
affects: indicator-appmenu → ubuntu-indicator-mods
Changed in ubuntu-indicator-mods:
assignee: nobody → charles (charlesk)
Changed in gnome-bluetooth (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
importance: Low → High
Revision history for this message
Sebastien Bacher (seb128) wrote :

There was an obvious bug in the code, update_icon_visibility() which calls g_settings_get_boolean (gsettings, GSETTINGS_VISIBLE_KEY) was being called before g_settings_new() due to one of the other init funtions, I've fixed that in r63 by moving the g_settings_init block a bit ealier, not sure if that's enough to fix your issue though since I could confirm the bug on my box

Revision history for this message
Sebastien Bacher (seb128) wrote :

Jason, is that still an issue? I lower the importance since the ui got dropped

Changed in gnome-bluetooth (Ubuntu):
importance: High → Low
status: Confirmed → Incomplete
Revision history for this message
Jason Warner (jasoncwarner) wrote : Re: [Bug 922375] Re: Bluetooth indicator will not stay turned off after reboot

Yes, this is still happening, though I agree on the lower priority.

On Wed, Feb 29, 2012 at 5:05 PM, Sebastien Bacher <email address hidden> wrote:

> Jason, is that still an issue? I lower the importance since the ui got
> dropped
>
> ** Changed in: gnome-bluetooth (Ubuntu)
> Importance: High => Low
>
> ** Changed in: gnome-bluetooth (Ubuntu)
> Status: Confirmed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/922375
>
> Title:
> Bluetooth indicator will not stay turned off after reboot
>
> Status in Ubuntu network, Bluetooth, keyboard menus:
> New
> Status in “gnome-bluetooth” package in Ubuntu:
> Incomplete
>
> Bug description:
> I turned off bluetooth indicator and rebooted. Bluetooth indicator was
> turned on again after reboot. This happens everytime I reboot meaning
> I have to turn off bluetooth indicator each time I reboot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 12.04
> Package: indicator-appmenu 0.3.2+hud5-0ubuntu1~ppa4
> ProcVersionSignature: Ubuntu 3.2.0-10.18-generic 3.2.1
> Uname: Linux 3.2.0-10-generic x86_64
> ApportVersion: 1.91-0ubuntu1
> Architecture: amd64
> CrashDB: indicator_appmenu
> Date: Fri Jan 27 10:32:18 2012
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110919)
> SourcePackage: indicator-appmenu
> ThirdParty: True
> UpgradeStatus: Upgraded to precise on 2011-12-14 (43 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-indicator-mods/+bug/922375/+subscriptions
>

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-bluetooth (Ubuntu):
status: New → Confirmed
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Jason,

What kind of system are you seeing this happening on? I'm wondering if the killswitch status saving/restoring might be broken for some Dell devices, since one of the rfkill devices actually gets removed and re-added when the state is toggled for Dell systems (at least, it's easily reproducible on mine, and a few other Dell machines I've tried).

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Incomplete
Changed in ubuntu-indicator-mods:
status: New → Incomplete
Revision history for this message
Display Name (user340562791542-deactivatedaccount) wrote :

My computer is not Dell and I can confirm this annoying bug.

Bluetooth device (USB):
        ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Motherboard:
        Intel D946GZIS

Changed in gnome-bluetooth (Ubuntu):
status: Incomplete → Confirmed
Changed in ubuntu-indicator-mods:
status: Incomplete → Confirmed
Charles Kerr (charlesk)
Changed in ubuntu-indicator-mods:
importance: Undecided → Low
Revision history for this message
Cas (calumlind) wrote :

I have a Dell Precision M4300 running 12.04 and am seeing the same issue.

Revision history for this message
bruno.braga (bruno-braga) wrote :

I have the same issue.

bruno@mac17: ~ $ uname -a
Linux mac17 3.2.0-20-generic #33-Ubuntu SMP Tue Mar 27 16:42:26 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
bruno@mac17: ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

Revision history for this message
Luke Hoersten (lukehoersten) wrote :

I have a 12.04 Macbook Air with the same issue. This bug is a duplicate of bug #964299 but I'll close that since the discussion seems to be here.

I'd like the priority to be increased on this as well because it's a significant power drain for laptops.

Revision history for this message
Klaus Buehler (buehler-z) wrote :

I still have the same issue on a lenovo ThinkPad T520:

bt0200@buehler01:~$ uname -a
Linux buehler01 3.2.0-34-generic #53-Ubuntu SMP Thu Nov 15 10:48:16 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
bt0200@buehler01:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise

Revision history for this message
Klaus Buehler (buehler-z) wrote :

Forgot to mention that I am not using unity desktop. I am using gnome classic instead. Did not uninstall unity though. Can switch back to unity.

Revision history for this message
Սահակ (petrosyan) wrote :

I have Samsung Series 9 900X3B and I am seeing the same issue.

If I disable Bluetooth in the Bluetooth applet, after rebooting Bluetooth is enabled again.

Revision history for this message
sojusnik (sojusnik) wrote :

I've updated the BIOS to a new version, something with 03, then did a fresh install of Ubuntu Gnome Shell 12.10, added the Gnome3 ppa and realized, that the Bluetooth status is saved now.

Revision history for this message
Սահակ (petrosyan) wrote :

I can confirm that this issue seems to have been fixed on the latest Ubuntu 12.10 with all the latest updates installed

Changed in gnome-bluetooth (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-indicator-mods:
status: Confirmed → Fix Released
Revision history for this message
Coiby Xu (coiby) wrote :

Oh, the bug appears again in Ubuntu 13.4.

Revision history for this message
Սահակ (petrosyan) wrote :

Coiby, I can confirm that the bug reappeared in Ubuntu 13.04

I am not able to re-open this bug.

Can you please file a new bug report and paste a link to that bug here?

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers