ubuntu-image turns non-sparse swapfile into a sparce file forcefully

Bug #1900718 reported by Łukasz Zemczak
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Image
Critical
Łukasz Zemczak
ubuntu-image (Ubuntu)
Undecided
Unassigned

Bug Description

We wanted to add a 1GB /swapfile to the Pi desktop images, and we do so via livecd-rootfs hooks. Everything is done correctly there, but apparently mkfs.ext4, when populating the contents, turns our non-sparse 1GB swapfile into a sparse one. We tried reading the possible options (along with 'nodiscard') but nothing worked.

We will work-around it in ubuntu-image for now, until we get a better idea. This basically blocks the pi images from being releasable.

Changed in ubuntu-image (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-image - 1.10+20.10ubuntu2

---------------
ubuntu-image (1.10+20.10ubuntu2) groovy; urgency=medium

  [ Brian Murray ]
  * Fix a typo in README.rst.

  [ Łukasz 'sil2100' Zemczak ]
  * Add a workaround for mkfs.ext4 forcefully sparsifying our classic image
    swapfile (LP: #1900718)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 20 Oct 2020 19:40:57 +0200

Changed in ubuntu-image (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers