new connections: stanza causes validation error in ubuntu-image

Bug #1780217 reported by Oliver Grawert on 2018-07-05
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Image
High
Łukasz Zemczak

Bug Description

trying to build an image with a gadget that uses the new "connections" stanza in gadget.yaml fails the yaml validation step when creating an image.

https://forum.snapcraft.io/t/the-gadget-snap/696/13

i guess the validation code for gadget.yaml in ubuntu-image needs updating for the new keywords.

Oliver Grawert (ogra) wrote :

looking at the code there is indeed nothing about "connect*" in
https://git.launchpad.net/ubuntu-image/tree/ubuntu_image/parser.py

Changed in ubuntu-image:
assignee: nobody → Łukasz Zemczak (sil2100)
Łukasz Zemczak (sil2100) wrote :

When the parser was created the gadget.yaml specification did not include the connections: stanza - we'll add that now. mvo had a good idea about adding a flag for ignoring unknown fields in the gadget.yaml - I'll fill in a separate bug for that and add it. Since otherwise, in cases where the gadget.yaml file will get a new field that'll start being in use, users will be blocked until the new u-i release.

Changed in ubuntu-image:
status: New → Confirmed
importance: Undecided → High
milestone: none → 1.4
Changed in ubuntu-image:
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :

The bug for handling the cases of unsupported stanzas is LP: #1780295.

That being said, it would be nice if the ubuntu-image maintainers would be informed of changes in the gadget.yaml spec. How else can we know that a new stanza has been introduced? Are we supposed to poll the forum for any changes regularly? That doesn't seem quite optimal. ubuntu-image is one of the bigger consumers of gadget.yaml so it would be nice to be included in the loop.

Samuele Pedroni (pedronis) wrote :

@sil2100 that's a reasonable request. To be fair it was a while it wasn't changed and both mvo and me didn't consider that ubunbu-image is doing strict parsing of the whole and not only "volumes".

About informing:
* we could ping you through the forum
* email
* open always a formal bug

let us know what are your preferences.

Changed in ubuntu-image:
status: In Progress → Fix Committed
Changed in ubuntu-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers