The snap.sh autopkgtest suite failes on non amd64/i386 arches

Bug #1704979 reported by Łukasz Zemczak on 2017-07-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Image
Critical
Łukasz Zemczak
ubuntu-image (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned
Zesty
Undecided
Unassigned

Bug Description

[Impact]

With the current ubuntu-image 1.1, it is impossible for the package to migrate to the release pocket as the autopkgtests for armhf, ppc64el and arm64 will fail (the snap.sh test). This test does not make sense to be run as part of .deb migration as it's testing snap buildability - it's a bad idea to mix those two worlds.

[Test Case]

Make sure that all the autopkgtests pass for all architectures (with the snap.sh test skipped).

[Regression Potential]

None. This is only a test change. Skipping the test on package migration introduces no real possibility of regressions. Snap buildability is checked during the github source CI for each pull-request. Besides, snap buildability is a feature of the source that is not used by the .deb parts and is completely irrelevant to users.

[Original Description]

We have an autopkgtest called snap.sh that checks if we're able to properly build an ubuntu-image snap from the current source and that the resulting tool is usable. This test started failing with ubuntu-image 1.1 for armhf, ppc64el and s390x.

By checking the test logs, this test was never really working for archs other than amd64 and i386. The snap never really got properly built and installed, and the test only passed because, for some reason, ubuntu-image was available as a deb (you can see it in the old logs by examining the ubuntu-image --version output, stating a non-snap version number). Starting with changes from 1.1, we now have some tests that make sure the deb is not installed.

In theory building the ubuntu-image snap should be possible on all arches. In practice, on all the fancy archs basically the core snap is *always* failing to install with:
error: cannot communicate with server: Post http://localhost/v2/snaps/core: dial unix /run/snapd.socket: connect: connection refused

This doesn't seem to be a transient error. This causes ubuntu-image to not migrate.

Łukasz Zemczak (sil2100) wrote :

My first proposition for quickly dealing with this is: skipping the test for arches other than amd64 and i386. They're not the target for the ubuntu-image tool (I can't imagine a real use-case) - especially that we're only supporting ubuntu-image for amd64 and i386 in the store.

If needed, we can dive in and try to find out why there are issues with the core snap on those arches. Anyway, it doesn't seem to be related to u-i itself.

Changed in ubuntu-image:
status: New → Triaged
Łukasz Zemczak (sil2100) wrote :

Ok, a different solution. As mentioned by infinity, actually the right way to go here would be not to run the test *at all* on package migration. Adam had a point that testing snap buildability as part of the deb migration has absolutely no sense - it's something that makes sense for github PR, but not in such a case. So I'll be going with this option instead.

Changed in ubuntu-image:
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-image - 1.1+17.10ubuntu3

---------------
ubuntu-image (1.1+17.10ubuntu3) artful; urgency=medium

  * Only run the snap.sh test on github PRs as it doesn't make sense to run it
    as part of regular deb package migration. (LP: #1704979)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Wed, 19 Jul 2017 15:31:06 +0200

Changed in ubuntu-image (Ubuntu):
status: New → Fix Released
description: updated
Changed in ubuntu-image (Ubuntu Yakkety):
status: New → Invalid
Changed in ubuntu-image:
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

The upload that fixes this bug also drops support for Yakkety, should that be mentioned in the changelog too?

Hello Łukasz, or anyone else affected,

Accepted ubuntu-image into zesty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-image/1.1+17.04ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-zesty to verification-done-zesty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-zesty. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in ubuntu-image (Ubuntu Zesty):
status: New → Fix Committed
tags: added: verification-needed verification-needed-zesty
Steve Langasek (vorlon) wrote :

Hello Łukasz, or anyone else affected,

Accepted ubuntu-image into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-image/1.1+16.04ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-image (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Steve Langasek (vorlon) wrote :

Hello Łukasz, or anyone else affected,

Accepted ubuntu-image into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-image/1.1+16.04ubuntu4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Łukasz Zemczak (sil2100) wrote :

Verified for both xenial (1.1+16.04ubuntu4) and zesty (1.1+17.04ubuntu3): autopkgtests are all passing, with the snap.sh test being skipped as intended:

autopkgtest [17:17:01]: test snap.sh: [-----------------------
Skipping test, not ran as part of a pull request.

tags: added: verification-done-xenial verification-done-zesty
removed: verification-needed verification-needed-xenial verification-needed-zesty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-image - 1.1+16.04ubuntu4

---------------
ubuntu-image (1.1+16.04ubuntu4) xenial; urgency=medium

  * Drop part of the xenial delta, adding the fakeroot dependency as per master.
    Properly handling the lack of the dependency and still getting 100% code
    coverage on all series requires too much unnecessary work. (LP: #1709029)

ubuntu-image (1.1+16.04ubuntu3) xenial; urgency=medium

  * Only run the snap.sh test on github PRs as it doesn't make sense to run it
    as part of regular deb package migration. (LP: #1704979)

ubuntu-image (1.1+16.04ubuntu1) xenial; urgency=medium

  [ Łukasz 'sil2100' Zemczak ]
  * SRU tracking number LP: #1702933
  * Fix snapcraft.yaml for classic snappage. (LP:1673576)
  * Add a new step in the builder that generates .manifest files listing all
    snaps installed in the resulting image. (LP:1680574)
  * Further fixes to snapcraft.yaml, making sure that we only have one
    ubuntu-image version installed in the snap. (LP:1692901)
  * Move files around during snap build to have all needed libraries and python
    files in common accessible paths, install missing dependencies into the
    snap. (LP:1694982, LP:1694993)

  [ Michael Vogt ]
  * Use fakeroot when running mkfs.ext4. (LP:1702628)

  [ Steve Langasek ]
  * Add fakeroot to the snapcraft.yaml and as a test dep. (LP:1702628)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Tue, 08 Aug 2017 10:44:33 +0200

Changed in ubuntu-image (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-image has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-image - 1.1+17.04ubuntu3

---------------
ubuntu-image (1.1+17.04ubuntu3) zesty; urgency=medium

  * Only run the snap.sh test on github PRs as it doesn't make sense to run it
    as part of regular deb package migration. (LP: #1704979)

ubuntu-image (1.1+17.04ubuntu1) zesty; urgency=medium

  [ Łukasz 'sil2100' Zemczak ]
  * SRU tracking number LP: #1702933
  * Fix snapcraft.yaml for classic snappage. (LP:1673576)
  * Add a new step in the builder that generates .manifest files listing all
    snaps installed in the resulting image. (LP:1680574)
  * Further fixes to snapcraft.yaml, making sure that we only have one
    ubuntu-image version installed in the snap. (LP:1692901)
  * Move files around during snap build to have all needed libraries and python
    files in common accessible paths, install missing dependencies into the
    snap. (LP:1694982, LP:1694993)

  [ Michael Vogt ]
  * Use fakeroot when running mkfs.ext4. (LP:1702628)

  [ Steve Langasek ]
  * Add fakeroot to the snapcraft.yaml and as a test dep. (LP:1702628)

 -- Łukasz 'sil2100' Zemczak <email address hidden> Wed, 19 Jul 2017 15:31:06 +0200

Changed in ubuntu-image (Ubuntu Zesty):
status: Fix Committed → Fix Released
Changed in ubuntu-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers