ubuntu-html5-container package has unused dependency on dpkg-dev

Bug #1369052 reported by Steve Langasek on 2014-09-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu HTML5 UI SDK
Medium
Alexandre Abreu
ubuntu-html5-theme (Ubuntu)
Undecided
Unassigned

Bug Description

The ubuntu-html5-container package has a dependency on dpkg-dev. But the only references anywhere to dpkg-dev in the ubuntu-html5-theme source are in ./tests/autopilot/ubuntu_html5_ui_toolkit/tests/__init__.py, installed in the ubuntu-html5-ui-toolkit-autopilot package.

The dependency on dpkg-dev pulls an additional 13.3MB of packages onto the phone images which are not used. The dependency should be dropped.

Related branches

David Barth (dbarth) on 2014-09-15
Changed in ubuntu-html5-theme:
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Pat McGowan (pat-mcgowan) wrote :

while this is marked medium I would like to see it land, thats a fair junk of space

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-html5-theme - 0.1.2+14.10.20140922.1-0ubuntu1

---------------
ubuntu-html5-theme (0.1.2+14.10.20140922.1-0ubuntu1) utopic; urgency=low

  [ Alexandre Abreu ]
  * make ubuntu-html5-container multi-arch foreign; update dependencies
    for libqt5webkit5-qmlwebkitplugin to qml-module-qtwebkit

  [ Steve Langasek ]
  * Drop unused dependency on dpkg-dev from ubuntu-html5-container. LP:
    #1369052. (LP: #1369052)
 -- Ubuntu daily release <email address hidden> Mon, 22 Sep 2014 21:14:27 +0000

Changed in ubuntu-html5-theme (Ubuntu):
status: New → Fix Released
David Barth (dbarth) on 2014-09-23
Changed in ubuntu-html5-theme:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers