gnome-shell crashed with signal 5 in _XIOError()

Bug #1658665 reported by Saurav Sengupta on 2017-01-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

This crash occurs in both the default Ubuntu GNOME system (with supported updates) and with GNOME 3.22 from the gnome3-staging PPA.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: gnome-shell 3.22.2-1ubuntu1~ubuntu16.10.1 [origin: LP-PPA-gnome3-team-gnome3-staging]
ProcVersionSignature: Ubuntu 4.8.0-34.36-generic 4.8.11
Uname: Linux 4.8.0-34-generic x86_64
ApportVersion: 2.20.3-0ubuntu8.2
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME-Greeter:GNOME
Date: Mon Jan 23 17:31:53 2017
DisplayManager: gdm3
ExecutablePath: /usr/bin/gnome-shell
GsettingsChanges:

InstallationDate: Installed on 2017-01-23 (0 days ago)
InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Release amd64 (20161012.1)
ProcCmdline: /usr/bin/gnome-shell
Signal: 5
SourcePackage: gnome-shell
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libmutter.so.0
 _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 XPending () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/x86_64-linux-gnu/libgdk-3.so.0
Title: gnome-shell crashed with signal 5 in _XIOError()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

information type: Private → Public

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

affects: ubuntu → gnome-shell (Ubuntu)
Changed in gnome-shell (Ubuntu):
status: New → Invalid
Download full text (6.6 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for xserver-xorg
no debug symbol package found for libfribidi0
gnome-themes-standard-data version 3.22.2-1ubuntu1~ubuntu16.10.1 required, but 3.20.2-3ubuntu1 is available
no debug symbol package found for python3-cups
gnome-control-center version 1:3.22.1-1ubuntu1~yakkety1 required, but 1:3.20.2-0ubuntu2 is available
no debug symbol package found for gir1.2-atspi-2.0
no debug symbol package found for libphonenumber7
nautilus-data version 1:3.22.2-1ubuntu0~yakkety1 required, but 1:3.20.3-1ubuntu3.1 is available
no debug symbol package found for libflac8
libpangoxft-1.0-0 version 1.40.3-2~ubuntu16.10.1 required, but 1.40.1-1ubuntu1 is available
no debug symbol package found for gir1.2-freedesktop
gnome-control-center-data version 1:3.22.1-1ubuntu1~yakkety1 required, but 1:3.20.2-0ubuntu2 is available
libgoa-1.0-common version 3.22.4-1~ubuntu16.10.1 required, but 3.20.5-0ubuntu0.1 is available
libpangocairo-1.0-0 version 1.40.3-2~ubuntu16.10.1 required, but 1.40.1-1ubuntu1 is available
no debug symbol package found for gir1.2-gdkpixbuf-2.0
libpango-1.0-0 version 1.40.3-2~ubuntu16.10.1 required, but 1.40.1-1ubuntu1 is available
gir1.2-mutter-3.0 version 3.22.2-3~ubuntu16.10.1 required, but 3.20.3-2 is available
no debug symbol package found for gir1.2-mutter-3.0
libgtk-3-0 version 3.22.7-1ubuntu1~ubuntu16.10.1 required, but 3.20.9-1ubuntu2 is available
no debug symbol package found for base-files
gsettings-desktop-schemas version 3.22.0-1ubuntu1~yakkety1 required, but 3.20.0-3ubuntu1 is available
no debug symbol package found for xserver-xorg-video-all
package libmutter0i does not exist, ignoring
adwaita-icon-theme version 3.22.0-1ubuntu1~ubuntu16.10.1 required, but 3.20-3ubuntu2 is available
libgnome-desktop-3-12 version 3.22.2-1ubuntu1~ubuntu16.10.1 required, but 3.20.2-1ubuntu1 is available
no debug symbol package found for gir1.2-upowerglib-1.0
no debug symbol package found for libiptc0
no debug symbol package found for gir1.2-packagekitglib-1.0
libgtk-3-common version 3.22.7-1ubuntu1~ubuntu16.10.1 required, but 3.20.9-1ubuntu2 is available
no debug symbol package found for python3-cairo
no debug symbol package found for gir1.2-networkmanager-1.0
gtk-update-icon-cache version 3.22.7-1ubuntu1~ubuntu16.10.1 required, but 3.20.9-1ubuntu2 is available
no debug symbol package found for xdg-user-dirs
gir1.2-gdesktopenums-3.0 version 3.22.0-1ubuntu1~yakkety1 required, but 3.20.0-3ubuntu1 is available
no debug symbol package found for gir1.2-gdesktopenums-3.0
no debug symbol package found for dash
gir1.2-soup-2.4 version 2.56.0-1~ubuntu16.10.1~ppa1 required, but 2.54.1-1 is available
no debug symbol package found for gir1.2-soup-2.4
no debug symbol package found for gir1.2-nmgtk-1.0
libsoup-gnome2.4-1 version 2.56.0-1~ubuntu16.10.1~ppa1 required, but 2.54.1-1 is available
gnome-session version 3.22.2-1ubuntu1~ubuntu16.10.1 required, but 3.20.2-1...

Read more...

tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers