Ubuntu GNOME should install flatpak by default

Bug #1652539 reported by Jeremy Bicha on 2016-12-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Low
Unassigned
ubuntu-gnome-meta (Ubuntu)
Low
Unassigned
Trusty
Low
Unassigned
Xenial
Low
Unassigned
Yakkety
Low
Unassigned

Bug Description

Impact
======
I believe all other GNOME distros include or will include Flatpak 0.8 in the default install.

Once Flatpak 0.8 is available, it would be nice if Ubuntu GNOME users could benefit it from it without having to install extra packages.

https://blogs.gnome.org/alexl/2016/12/22/a-stable-base-for-flatpak-0-8/

Test Case
=========
Install the updated ubuntu-gnome-desktop
Check if 'flatpak' is installed.

Regression Potential
====================
None. This just adds flatpak to the default install and there are no known bugs caused by that.

Other Info
==========
These are command-line tools. There is GUI support in gnome-software-plugin-flatpak 3.22 which is only available in Ubuntu 17.04 since GNOME Software 3.22 has various dependencies that are only available starting in that release (GTK 3.22 and PackageKit 1.1.4), but see also bug 1650783.

Ubuntu GNOME still installs Ubuntu Snap support (snapd).

Jeremy Bicha (jbicha) on 2016-12-25
Changed in ubuntu-gnome-meta (Ubuntu Trusty):
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-gnome-meta (Ubuntu Xenial):
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-gnome-meta (Ubuntu Yakkety):
importance: Undecided → Low
status: New → Triaged
description: updated
Changed in ubuntu-gnome:
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-meta - 0.73

---------------
ubuntu-gnome-meta (0.73) zesty; urgency=medium

  * Refreshed dependencies
  * Added chrome-gnome-shell to desktop (LP: #1652538)
  * Added flatpak to desktop (LP: #1652539)
  * Added xdg-desktop-portal-gtk to desktop

 -- Jeremy Bicha <email address hidden> Sun, 25 Dec 2016 17:33:01 -0500

Changed in ubuntu-gnome-meta (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers