17.04: Unable to login with regular "Gnome" or "Gnome Classic" shell/-session

Bug #1643370 reported by Mathias Avelind on 2016-11-20
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
Ubuntu GNOME
Undecided
Unassigned
mutter (Ubuntu)
Critical
Unassigned

Bug Description

When attempting to login with either regular Gnome or Gnome Classic shell/-session by selecting one of them through the default login screen it just sends me back to the login screen, making me type the password indefinitely, but when selecting the Wayland option, it signs me in as usual.
---
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
CurrentDesktop: GNOME
DisplayManager: gdm3
DistroRelease: Ubuntu 17.04
GsettingsChanges:
 org.gnome.shell app-picker-view uint32 1
 org.gnome.shell favorite-apps ['firefox.desktop', 'thunderbird.desktop', 'qBittorrent.desktop', 'discord-canary.desktop', 'steam.desktop', 'vlc.desktop', 'org.gnome.Nautilus.desktop']
 org.gnome.desktop.interface gtk-im-module 'gtk-im-context-simple'
InstallationDate: Installed on 2016-11-09 (11 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Alpha amd64 (20161109)
Package: gnome-shell 3.22.1-1ubuntu2
PackageArchitecture: amd64
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 4.9.0-1.2-generic 4.9.0-rc5
Tags: zesty wayland-session
Uname: Linux 4.9.0-1-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True

Not sure if this will help, but it's worth a shot.

description: updated
summary: - Ubuntu Gnome 17.04: Unable to login with regular Gnome or Gnome Classic
- session
+ Unable to login with regular "Gnome" or "Gnome Classic" shell/-session

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:
apport-collect 1643370

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

apport information

tags: added: apport-collected wayland-session zesty
description: updated

apport information

I notice you have -proposed enabled. I do not recommend using -proposed when running a development release.

http://askubuntu.com/q/785414/1579

Jeremy Bicha (jbicha) wrote :

I can duplicate this in VirtualBox (where -proposed is not enabled). My primary machine is still running Ubuntu GNOME 16.10.

summary: - Unable to login with regular "Gnome" or "Gnome Classic" shell/-session
+ 17.04: Unable to login with regular "Gnome" or "Gnome Classic"
+ shell/-session
Changed in gnome-shell (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1643370

tags: added: iso-testing
Neil Gunther (neil-gunther) wrote :

I'm also experiencing this bug in 16.10 with Gnome PPA's installed though. It seemed to occur when I upgraded the kernel to 4.8.1 with synaptic. Since then I can only boot into a Wayland session and can't launch synaptic either, though I can install other package managers.

Changed in ubuntu-gnome:
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Neil, did this just break for you this week?

I believe the only packages that should have changed in both Zesty and the Yakkety GNOME PPA are mutter and gnome-desktop3.

Jeremy Bicha (jbicha) wrote :

Downgrading mutter to 3.22.1 fixes this, in my testing.

affects: gnome-shell (Ubuntu) → mutter (Ubuntu)
Changed in mutter (Ubuntu):
status: Confirmed → Triaged
Jeremy Bicha (jbicha) wrote :

I uploaded a fix for this.

For the GNOME3 PPA, the version is 3.22.2-1ubuntu1~ubuntu16.10.1 Give it an hour or so to build and publish.

Changed in ubuntu-gnome:
status: Confirmed → Fix Released
Changed in mutter (Ubuntu):
status: Triaged → Fix Committed
Neil Gunther (neil-gunther) wrote :

Jeremy

I can see a new version of mutter is being built in the Staging PPA. I'll give it a shot once its done.

Cheers

Neil

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.22.2-1ubuntu1

---------------
mutter (3.22.2-1ubuntu1) zesty; urgency=medium

  * Add git_stack-docks-below-fullscreen-windows.patch:
    - Add patch from 3.22 branch that prevented logging into GNOME on X
      for some users (LP: #1643370)

 -- Jeremy Bicha <email address hidden> Tue, 22 Nov 2016 12:22:52 -0500

Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Neil Gunther (neil-gunther) wrote :

Jeremy

Installed the revised version of mutter and rebooted. I can now access Gnome DE on Xorg and launch Synaptic.

Thanks

Neil

Nicely done, it's working again.

Changed in mutter:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.