Login option 'GNOME on Wayland' does not start from LightDM

Bug #1632772 reported by Fred on 2016-10-12
110
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
unity8-desktop-session
High
Unassigned
lightdm (Ubuntu)
High
Unassigned
ubuntu-meta (Ubuntu)
Critical
Unassigned
unity8-desktop-session (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned
Zesty
High
Unassigned

Bug Description

When picking GNOME on Wayland as session and attempting to login from LightDM then it fails, all you see is a black screen with a blinking cursor.

However, manually running:
$ dbus-run-session gnome-shell --display-server --wayland
from the console/vt1 (Ctrl+Alt+F1) seems to work.
But from LightDM it does not work.

ProblemType: Bug
DistroRelease: Ubuntu 16.10
Package: gnome-session-wayland 3.20.2-1ubuntu7
ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
Uname: Linux 4.8.0-22-generic x86_64
ApportVersion: 2.20.3-0ubuntu8
Architecture: amd64
Date: Wed Oct 12 18:06:13 2016
InstallationDate: Installed on 2013-12-26 (1020 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64 (20131016.1)
SourcePackage: gnome-session
UpgradeStatus: No upgrade log present (probably fresh install)

Fred (eldmannen+launchpad) wrote :
Robert Ancell (robert-ancell) wrote :

Can you attach the contents of /var/log/lightdm/lightdm.log after attempting to start the session? Thanks.

Changed in lightdm (Ubuntu):
status: New → Incomplete
Fred (eldmannen+launchpad) wrote :

Requested log file attached.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-session (Ubuntu):
status: New → Confirmed
BigcityCat (pshomeexpress) wrote :

Keeping Unity-Gtreeter is a great way to keep the Ubuntu in gnome3. The importance should be high.

Changed in lightdm (Ubuntu):
status: Incomplete → New
importance: Undecided → Medium
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lightdm (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-04-18
Changed in ubuntu-gnome:
status: New → Confirmed
Jeremy Bicha (jbicha) on 2017-04-19
tags: added: wayland
Fred (eldmannen+launchpad) wrote :

I no longer experience this issue.
I can login to my Wayland session now.

However, I do have a related issue where I cannot login to Wayland as guest.

Fred, How did you fix it?

On Wed, Apr 19, 2017 at 9:28 AM, Fred <email address hidden> wrote:

> I no longer experience this issue.
> I can login to my Wayland session now.
>
> However, I do have a related issue where I cannot login to Wayland as
> guest.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1632772
>
> Title:
> GNOME on Wayland does not start from LightDM
>
> Status in Ubuntu GNOME:
> Confirmed
> Status in gnome-session package in Ubuntu:
> Confirmed
> Status in lightdm package in Ubuntu:
> Confirmed
>
> Bug description:
> When picking GNOME on Wayland as session and attempting to login from
> LightDM then it fails, all you see is a black screen with a blinking
> cursor.
>
> However, manually running:
> $ dbus-run-session gnome-shell --display-server --wayland
> from the console/vt1 (Ctrl+Alt+F1) seems to work.
> But from LightDM it does not work.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 16.10
> Package: gnome-session-wayland 3.20.2-1ubuntu7
> ProcVersionSignature: Ubuntu 4.8.0-22.24-generic 4.8.0
> Uname: Linux 4.8.0-22-generic x86_64
> ApportVersion: 2.20.3-0ubuntu8
> Architecture: amd64
> Date: Wed Oct 12 18:06:13 2016
> InstallationDate: Installed on 2013-12-26 (1020 days ago)
> InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release amd64
> (20131016.1)
> SourcePackage: gnome-session
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-gnome/+bug/1632772/+subscriptions
>

@johny, I don't recall having done anything to fix it.
I think it just resolved itself by some package update or something.
Logging into GNOME on Wayland from LightDM as my user works now.
But as guest it doesn't work still.

willmo (willmo) wrote :

It looks like the bug is actually in unity8-desktop-session. It installs /usr/share/lightdm/lightdm.conf.d/45-unity8.conf, which sets session-wrapper=lightdm-unity8-session, which means lightdm-unity8-session is run in order to start *any* session. lightdm-unity8-session is a shell script that's also part of unity8-desktop-session, and looking at its contents, it appears to be buggy because it assumes that any session that doesn't use X (such as Wayland) is Unity 8 and should run upstart instead of lightdm-session.

I was able to work around this by creating a file /etc/lightdm/lightdm.conf.d/00-willmo.conf with contents

[Seat:*]
session-wrapper=lightdm-session

This overrides the offending setting in 45-unity8.conf and sets session-wrapper back to the default, avoiding the Unity 8 assumptions in lightdm-unity8-session. After rebooting, Wayland sessions now work for me.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8-desktop-session (Ubuntu):
status: New → Confirmed
summary: - GNOME on Wayland does not start from LightDM
+ Login option 'GNOME on Wayland' does not start from LightDM
Daniel van Vugt (vanvugt) wrote :

Confirmed, thanks willmo. The simple fix for zesty and artful is:

$ sudo apt remove unity8-desktop-session
$ sudo apt autoremove

Changed in unity8-desktop-session:
status: New → Confirmed
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

ubuntu-meta (1.380) artful; urgency=medium

  * update.cfg; zesty -> artful
  * Refreshed dependencies
  * Removed unity8-desktop-session from desktop-recommends [amd64 arm64
    armhf i386 ppc64el]

 -- Dimitri John Ledkov <email address hidden> Sun, 23 Apr 2017 15:03:58 +0100

Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Dimitri John Ledkov (xnox)
importance: Undecided → Critical
status: New → Fix Released
Changed in unity8-desktop-session (Ubuntu):
status: Confirmed → Won't Fix
Changed in lightdm (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-session (Ubuntu):
status: Confirmed → Invalid
Changed in unity8-desktop-session:
status: Confirmed → Invalid
Changed in ubuntu-gnome:
status: Confirmed → Invalid
Changed in unity8-desktop-session:
status: Invalid → Won't Fix
Dimitri John Ledkov (xnox) wrote :

unintentional fix =))))

however, my upload I think is now causing a mess with components mismatches.

Dimitri John Ledkov (xnox) wrote :

Note, we cannot just remove unity8-desktop-session in zesty, thus some other workaround needed, if we want to SRU this change.

Daniel van Vugt (vanvugt) wrote :

I think zesty is fine unfixed. If anyone wants a quick fix in zesty then see the previous comments.

Oliver Grawert (ogra) wrote :

note that i see the non-starting wayland session on a 16.04 system that does not have the unity8-desktop-session package installed, x11 gnome as well as unity (7) start just fine and there is no trace of any unity8 packages on this laptop.

Jeremy Bicha (jbicha) wrote :

The ubuntu-meta change was a workaround, not a fix, and it doesn't do us any good for Ubuntu Stable Releases so I'm reopening this bug.

Changed in unity8-desktop-session (Ubuntu):
status: Won't Fix → Triaged
importance: Undecided → High
Changed in ubuntu-gnome:
status: Invalid → Triaged
importance: Undecided → High
no longer affects: gnome-session (Ubuntu)
no longer affects: lightdm (Ubuntu Yakkety)
no longer affects: lightdm (Ubuntu Zesty)
no longer affects: ubuntu-meta (Ubuntu Yakkety)
no longer affects: ubuntu-meta (Ubuntu Zesty)
Changed in unity8-desktop-session (Ubuntu Yakkety):
importance: Undecided → High
status: New → Triaged
Changed in unity8-desktop-session (Ubuntu Zesty):
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-meta (Ubuntu):
assignee: Dimitri John Ledkov (xnox) → nobody
BigcityCat (pshomeexpress) wrote :

I implemented willmo's fix and I also removed unity 8 desktop. It does login into Wayland after applying these workarounds but logout is broken. You can't logout. Juts gets stuck on a blank screen.

fcole90 (fcole90) wrote :

Using 16.04 I can still reproduce the bug. I don't have any trace of unity8 as well.

Jeremy Bicha (jbicha) wrote :

fcole90, please file a new bug for your issue.

fcole90 (fcole90) wrote :

Ok, mine is 1695872

monkeydri (monkeydri) wrote :

I can successfully login with lightdm after deleting every Xorg session entries correpsonding to a wayland session entry (ex rm /usr/share/xessions/gnome /usr/share/xessions/ubuntu and leave /usr/share/wayland-sessions/gnome and /usr/share/wayland-sessions/ubuntu).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers