Unable to delete large folders in Trash

Bug #1612343 reported by Wise Melon on 2016-08-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gvfs
Incomplete
High
gvfs (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I have found that since the indicator of file operations was replaced with the notification coming from the right of the top bar rather than a popup window, that I am unable to delete large folders from Trash. Placing them in Trash sometimes means that other items (even really small ones) can't be deleted until the large folders have been moved from Trash to another location, though on other occasions all, or at least half, of the other files will be seemingly successfully deleted, though not the large folder(s).

For instance I have a folder with many sub-folders, which each have many sub-sub-folders etc and lots of files... The folder's file size is about 1.7GB. I tried creating a tar of the file which was 1.8GB, I moved that into Trash and it was deleted within about a second with no trouble at all so it seems only to be folders.

I looked at the properties for a large folder I placed in Trash by itself, and even though I had clicked the Empty Trash button many times now, it was staying at the same size.

I find that the indicator which is meant to be indicating how it's doing to me is always just stuck at "Preparing", even when it actually deletes stuff it only ever really shows that so is not very useful.

I am running Ubuntu GNOME 16.04 with GNOME 3.20, but I believe this was also present in 3.18, though not to such a bad degree (pressing the Empty Trash button many times in some cases eventually worked on 3.18, but on 3.20 I can't seem to do anything to delete the folder without first splitting it up).

One thing to note though is that if I am to use the right-click option to permanently delete files and folders (which can be enabled in the Preferences) then it deletes them just fine apart from showing a huge and negative amount of files per seconds, but that is for another bug report.

I have only tested this in Nautilus, I have not yet tested if it works better in a different file manager, I will comment when I have tested it with a different file manager.

tags: added: xenial
description: updated
Changed in nautilus:
importance: Unknown → High
status: Unknown → Confirmed
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-gnome:
status: New → Confirmed
tags: added: yakkety
affects: nautilus → gvfs
Changed in gvfs:
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.