Clicking "Show details" in AO for Nautilus produces "Could not find 'nautilus.desktop'" error from gnome-software

Bug #1606901 reported by Wise Melon on 2016-07-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Low
Unassigned
gnome-pkg-tools (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
gnome-shell (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
gnome-software (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned
nautilus (Ubuntu)
Low
Unassigned
Xenial
Low
Unassigned

Bug Description

In the Activities Overview applications list, if I right-click on "Files" (AKA Nautilus) and select the "Show details" option gnome-software is launched but with the error of "Could not find 'nautilus.desktop'":

    gnome-software_Could_Not_Find_Nautilus-desktop.png

I am running Ubuntu GNOME 16.04 with GNOME 3.20.

description: updated
Jeremy Bicha (jbicha) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Low
tags: added: yakkety
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-07-29
Changed in ubuntu-gnome:
importance: Undecided → Low
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

This is a bug with the Ubuntu-specific /usr/bin/pkg-gnome-compat-desktop-file from gnome-pkg-tools and affects all apps that use that script.

Changed in gnome-pkg-tools (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in ubuntu-gnome:
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
Changed in gnome-pkg-tools (Ubuntu Xenial):
importance: Undecided → Low
status: New → Triaged
description: updated
Sebastien Bacher (seb128) wrote :

Jeremy, could you give some details on what's the issue with that script?

Jeremy Bicha (jbicha) wrote :

Seb, I believe the major problem is a logic error. /usr/bin/pkg-gnome-compat-desktop-file adds these fields to the .desktop files:

> file-roller.desktop (the compatibility .desktop)
X-AppStream-Ignore=true

> org.gnome.FileRoller.desktop ( the new upstream .desktop)
NoDisplay=true

Moving the AppStream-Ignore rule to the .desktop that has NoDisplay set fixes the GNOME Shell integration issue.

There's another smaller issue with the script, see bug 1623748 for that.

Jeremy Bicha (jbicha) on 2018-04-13
Changed in gnome-software (Ubuntu):
status: New → Fix Released
Changed in gnome-software (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Low
Changed in gnome-software (Ubuntu):
importance: Undecided → Low
Jeremy Bicha (jbicha) wrote :

I looked at the status of this today in Ubuntu 18.04. GNOME Software has been updated so that it shows better results in this case instead of an error. (But it's still not perfect. Try gedit as the test case instead of nautilus.)

Seb Bacher suggested that gnome-shell is probably wrong for sending the old .desktop ID to gnome-software instead of the new one so I'm opening a gnome-shell task here.

We also discussed this general issue in the Ubuntu Desktop team today. We do not intend to drop the compatibility desktop files now for Ubuntu 18.04 LTS since they provide a useful service to upgrading Unity users. It looks like we will probably drop them in 18.10 though since they should no longer be needed then for GNOME or Unity.

Changed in nautilus (Ubuntu):
status: Triaged → Invalid
Changed in nautilus (Ubuntu Xenial):
status: Triaged → Invalid
Changed in gnome-pkg-tools (Ubuntu):
status: Triaged → Invalid
Changed in gnome-pkg-tools (Ubuntu Xenial):
status: Triaged → Invalid
Changed in gnome-shell (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-shell (Ubuntu Xenial):
importance: Undecided → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers