Comment 36 for bug 1551283

Alkis Georgopoulos (alkisg) wrote :

> ... I'll try to raise the issue in Debian's im-config, ... I will ask that ibus isn't running in locales where it's not needed...

I installed Debian Stretch with the Gnome desktop environment and neither im-config nor ibus were installed by default there.
So I cannot report it in Debian, as it does make sense that if someone manually installs ibus, he'd want to have it running by default.

The problem is Ubuntu-specific, that people that don't need ibus have it installed by default and running anyway.

Nevertheless, since ibus isn't running under gnome-flashback in non-cjkv locales, I'm not affected by that, so I can't complain.
Thanks again Gunnar, much appreciated! :)

About the "XDG_CURRENT_DESKTOP=Unity" part in gnome-flashback, it's caused by
unity-control-center/shell/control-center.c:
  g_setenv ("XDG_CURRENT_DESKTOP", "Unity", TRUE);