"Input Sources" button looks really out of place in Keyboard settings

Bug #1525402 reported by Wise Melon on 2015-12-11
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Undecided
Unassigned
gnome-control-center (Ubuntu)
Wishlist
Robert Hönig

Bug Description

I am running Ubuntu GNOME 15.10 with GNOME 3.18 and I have recently noticed that in the gnome-control-center, at the bottom in the KeyBoard section there is a button which says "Input Sources": Input_Sources_Out_Of_Place_Button.png

Though this button is only text, so actually not very obviously a button and in fact looks quite out of place, until I clicked it and it took me somewhere else I didn't really know what it was... The only time that a button like outline actually appeared around it was when I clicked it and that was only brief. So I really think that you should firstly make this button look more like a button (e.g.: add a boarder round it), and secondly actually put it somewhere on the page where it doesn't look just completely out of place, I don't know, maybe somewhere at the top or something, but it just looks odd and out of place where it currently is...

summary: - "Input Sources" button looks out of place in Keyboard settings
+ "Input Sources" button looks really out of place in Keyboard settings
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Robert Hönig (indielives010) wrote :

I can reproduce this bug with Ubuntu 16.04. Here, just the text changed, but not its appearance: It now says Text Entry

Steps to reproduce:
1. Run gnome-control-center
2. Switch to Keyboard Panel, look in the lower left corner.

Changed in ubuntu-gnome:
status: New → Confirmed
Tim Lunn (darkxst) on 2015-12-14
Changed in ubuntu-gnome:
milestone: none → xenial
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Tim Lunn (darkxst) wrote :

Pretty sure that has been like that for most of ever, however I do agree this looks out of place. This should be fixed in co-ordination with upstream.

Changed in gnome-control-center (Ubuntu):
importance: Low → Wishlist
Changed in ubuntu-gnome:
status: Confirmed → In Progress
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Hönig (indielives010)
status: Triaged → In Progress
Changed in ubuntu-gnome:
status: In Progress → Confirmed
Tim Lunn (darkxst) wrote :

Missed you on IRC, Have a look through all the other panels and see what they do with buttons.

Robert Hönig (indielives010) wrote :
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Tim Lunn (darkxst) wrote :

Can you attach a screenshot when using adwaita.

Robert Hönig (indielives010) wrote :

Here is the look of gnome-control-center in adwaita, the buttons design fits the others like the Help Button in the Language Panel.

Tim Lunn (darkxst) wrote :

That screenshot looks the same as the last one ;( Also what help button, I hope you are not comparing it the Ubuntu "Language Support" panel, that is not included in gnome-control-center anymore with 16.04

Robert Hönig (indielives010) wrote :

Ok, finally done :)
Moved the LinkButton to the header, screenshot appended.
The new branch is here:
https://code.launchpad.net/~indielives010/gnome-control-center/fixKeyboardPanelLayout

Tim Lunn (darkxst) wrote :

A few nitpicks
- Use a normal button, not the link button
- You seem to have broken the frame/window size of the keyboard panel, this should always remain the same as all other panels.
- It needs to be based on the xenial/3.18 branch, this is not something we could backport to trusty
- Screenshots are far more useful if they use all defaults, such as button layouts, fonts etc. Grab screenshots in a live session if need be.

Further the keyboard settings have been moved into universal-access panel for 3.20
https://git.gnome.org/browse/gnome-control-center/commit/?id=1f192985ef1e18792151c1479be1f3c96c8f4f4c

Tim Lunn (darkxst) wrote :

actually seems I was wrong about the frame size, they do jump around a bit, so its probably ok as it.

Hey Tim,
so I got the following problem:
The input sources button is a linkbutton, which is not changeable into a
normal button without loosing its ability to open the other panel.
However, it seems to be not possible to change the design of this
linkbutton to make it look like a normal button. I asked on
StackOverflow how to do this, here is the link:
http://stackoverflow.com/questions/34495313/set-the-style-of-gtklinkbuttons
But maybe you can help me earlier/better :)

Tim Lunn (darkxst) wrote :

did you update the callback? GtkButton wont have an activate-link signal.

Robert Hönig (indielives010) wrote :

I did, turned it to activate signal. But then, clicking the button just does nothing. So I tried changing the design of the LinkButton, without success :(

Tim Lunn (darkxst) wrote :

I think "activate" is actually fired on double click for GtkButton, you probably want to use "clicked"

Robert Hönig (indielives010) wrote :

AWESOME! THAT DID IT! :)
Didn't run the program under the newly installed Ubuntu Gnome yet, but as the source code is the most recent from pull-lp-source and I didn't do any changes to the layout of the program, it should look good in GNOME. Will submit this now to launchpad with bzr.

Tim Lunn (darkxst) wrote :

but you left the old button as well ;(

that is the wrong branch, if you want to use bzr then it is lp:~ubuntu-desktop/gnome-control-center/ubuntu

otherwise make a debdiff against the ubuntu source from pull-lp-source.

either way you changes need to be done as a quilt patch!

Robert Hönig (indielives010) wrote :

Ok, so here again, with the debdiff.

Robert Hönig (indielives010) wrote :

And the screenshot

The attachment "gnome-control-center_3.18.2-1ubuntu4.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Tim Lunn (darkxst) wrote :

Thanks Robert, have uploaded your fix!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.18.2-1ubuntu4

---------------
gnome-control-center (1:3.18.2-1ubuntu4) xenial; urgency=medium

  [ Robert Hönig ]
  * debian/patches/keyboardLayoutChange.patch: Make the "Input Sources"
    Link, a headerbar Button in the Keyboard Panel. (LP: #1525402)

 -- Tim Lunn <email address hidden> Tue, 02 Feb 2016 18:41:34 +1100

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2016-03-21
Changed in ubuntu-gnome:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers